Wo sind die Geräte?

Dieses Thema im Forum "Linux OS" wurde erstellt von rasidrasid, 02.08.2012.

  1. #1 rasidrasid, 02.08.2012
    rasidrasid

    rasidrasid Eroberer

    Dabei seit:
    25.05.2010
    Beiträge:
    68
    Zustimmungen:
    0
    Hallo,

    ich habe auf einen alten PC per debootstrap ein Debian-Sarge installiert (auf einen USB-Stick). Ich habe noch eine zweite USB-Schnittstelle. Wenn ich mount eingebe, dann bekomme ich die Meldung das es ein /dev/sda1 gibt, was ich nicht unter /dev finde. Wenn ich in die zweite Schnittstelle nacheinander unterschiedliche USB-Stick einstecke, dann tauchen bei dmesg mal sdb1 und sdc1, aber ich finde diese sd* nirgends. Heißen die anders oder wo finde ich die, da ich einen neuen Stick mounten will, aber was soll ich mounten.

    Danke

    Code:
    
    dmesg
    Linux version 2.4.31-wyse (root@phaser) (gcc version 3.3.6 (Debian 
    1:3.3.6-7)) #24 Fri Nov 18 23:02:28 CET 2005
    BIOS-provided physical RAM map:
      BIOS-e801: 0000000000000000 - 000000000009f000 (usable)
      BIOS-e801: 0000000000100000 - 0000000001c00000 (usable)
    28MB LOWMEM available.
    On node 0 totalpages: 7168
    zone(0): 4096 pages.
    zone(1): 3072 pages.
    zone(2): 0 pages.
    DMI not present.
    Kernel command line:  root=/dev/sda1 lang=us quiet tz=Europe/Amsterdam 
    video=nscfb:vmode:1024x768-16,vfreq:75 splash=silent reboot=bios
    bootsplash: silent mode.
    Initializing CPU#0
    Working around Cyrix MediaGX virtual DMA bugs.
    Detected 300.684 MHz processor.
    Console: colour dummy device 80x25
    Calibrating delay loop... 470.22 BogoMIPS
    Memory: 25160k/28672k available (1863k kernel code, 3124k reserved, 555k 
    data, 96k init, 0k highmem)
    Checking if this processor honours the WP bit even in supervisor mode... Ok.
    Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
    Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
    Working around Cyrix MediaGX virtual DMA bugs.
    CPU:     After generic, caps: 00808131 00818131 00000000 00000001
    CPU:             Common caps: 00808131 00818131 00000000 00000001
    CPU: NSC Geode(TM) Integrated Processor by National Semi stepping 01
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Probing PCI hardware (bus 00)
    PCI: Fixup for MediaGX/Geode Slave Disconnect Boundary (0x41=0x9c)
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    Journalled Block Device driver loaded
    Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    National Geode FrameBuffer Driver Version 2.7.7
    Geode Processor Detected (Type = 1,Version = 8.1)
    Looking for splash picture... no good signature found.
    Console: switching to colour frame buffer device 128x48
    pty: 256 Unix98 ptys configured
    Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ 
    SERIAL_PCI enabled
    Real Time Clock Driver v1.10f
    Non-volatile memory driver v1.2
    scx200: NatSemi SCx200 Driver
    sc1200wdt: build 20020303<7>scx200_wdt: NatSemi SCx200 Watchdog Driver
    keyboard: Timeout - AT keyboard not present?(ed)
    keyboard: Timeout - AT keyboard not present?(f4)
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    ThunderLAN driver v1.15
    TLAN: 0 devices installed, PCI: 0  EISA: 0
    natsemi dp8381x driver, version 1.07+LK1.0.17, Sep 27, 2002
       originally by Donald Becker <becker@scyld.com>
       http://www.scyld.com/network/natsemi.html
       2.4.x kernel port by Jeff Garzik, Tjeerd Mulder
    PCI: Setting latency timer of device 00:0f.0 to 64
    eth0: NatSemi DP8381[56] at 0xc2a94000, 00:80:64:12:d3:2e, IRQ 10.
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    CS5530: IDE controller at PCI slot 00:12.2
    CS5530: chipset revision 0
    CS5530: not 100% native mode: will probe irqs later
    PCI: Setting latency timer of device 00:12.0 to 64
         ide0: BM-DMA at 0xfb00-0xfb07, BIOS settings: hda:pio, hdb:pio
         ide1: BM-DMA at 0xfb08-0xfb0f, BIOS settings: hdc:pio, hdd:pio
    SCSI subsystem driver Revision: 1.00
    kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    PCI: Setting latency timer of device 00:13.0 to 64
    host/usb-ohci.c: USB OHCI at membase 0xc00cc000, IRQ 6
    host/usb-ohci.c: usb-00:13.0, Compaq Computer Corporation ZFMicro 
    Chipset USB
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    USB Mass Storage support registered.
    Initializing Cryptographic API
    IPv6 v0.8 for NET4.0
    IPv6 over IPv4 tunneling driver
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 2048 bind 4096)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    RAMDISK: Compressed image found at block 0
    Freeing initrd memory: 1k freed
    VFS: Mounted root (ext2 filesystem).
    hub.c: new USB device 00:13.0-1, assigned address 2
    scsi0 : SCSI emulation for USB Mass Storage devices
       Vendor: USB2.0    Model: Flash disk        Rev: 2.10
       Type:   Direct-Access                      ANSI SCSI revision: 02
    Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    SCSI device sda: 1988608 512-byte hdwr sectors (1018 MB)
    sda: Write Protect is off
    Partition check:
      sda: sda1
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
    VFS: Mounted root (ext2 filesystem).
    Trying to move old root to /initrd ... okay
    Freeing unused kernel memory: 96k freed
    hub.c: new USB device 00:13.0-2, assigned address 3
    scsi1 : SCSI emulation for USB Mass Storage devices
       Vendor:           Model:                   Rev: 8.07
       Type:   Direct-Access                      ANSI SCSI revision: 02
    Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0
    SCSI device sdb: 15175680 512-byte hdwr sectors (7770 MB)
    sdb: Write Protect is off
      sdb: sdb1
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 3
    Adding Swap: 131064k swap-space (priority -1)
    eth0: link up.
    eth0: Setting full-duplex based on negotiated link capability.
    eth0: no IPv6 routers present
    usb.c: USB disconnect on device 00:13.0-2 address 3
    hub.c: new USB device 00:13.0-2, assigned address 4
    scsi2 : SCSI emulation for USB Mass Storage devices
       Vendor: USB 2.0   Model: Flash Drive       Rev: 0.00
       Type:   Direct-Access                      ANSI SCSI revision: 02
    Attached scsi removable disk sdc at scsi2, channel 0, id 0, lun 0
    SCSI device sdc: 3938824 512-byte hdwr sectors (2017 MB)
    sdc: Write Protect is off
      sdc: sdc1
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 4
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 02.08.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Du kannst die Devices/Partitionen über /dev/sdXN ansprechen, auch wenn es keine entsprechenden Gerätedateien dafür gibt.
     
  4. #3 rasidrasid, 02.08.2012
    rasidrasid

    rasidrasid Eroberer

    Dabei seit:
    25.05.2010
    Beiträge:
    68
    Zustimmungen:
    0
    Danke erstmal. Also Du meinst ich kann per mount /dev/sda2 den 2. Stick mounten? Soweit ich das weiß, gibt es nur die sda’s auch unter /initrd/dev aber keine sdb und sdc.

    Danke
     
  5. #4 bitmuncher, 02.08.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Unter welchem Device der Stick verfügbar ist, kannst du ja dem dmesg-Output entnehmen.

    Code:
    Attached scsi removable disk sdc at scsi2, channel 0, id 0, lun 0
    Welche Partitionen darauf sind, kannst du im Output von 'fdisk -l' sehen. Und die kannst du dann auch entsprechend mounten.
     
  6. #5 rasidrasid, 02.08.2012
    rasidrasid

    rasidrasid Eroberer

    Dabei seit:
    25.05.2010
    Beiträge:
    68
    Zustimmungen:
    0
    Vielleicht verstehe ich es noch nicht ganz, aber wo ist scsi2? Sowas habe ich auch nirgends gefunden.

    Danke
     
  7. #6 bitmuncher, 02.08.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ja, du verstehst das noch nicht ganz.

    Code:
    removable disk sdc
    In diesem Fall ist es also /dev/sdc.
     
  8. #7 rasidrasid, 02.08.2012
    rasidrasid

    rasidrasid Eroberer

    Dabei seit:
    25.05.2010
    Beiträge:
    68
    Zustimmungen:
    0
    sorry, kann wohl sein. Was bei mir noch nicht klick gemacht hat ist, dass es keine Datei mit /dev/sdc gibt und auch nicht scsi2. Nichts...wird da auf etwas anderes referenziert? was müsste ich jetzt genau zum mounten angeben?

    Danke
     
  9. #8 bitmuncher, 02.08.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Es gibt auch keine Dateien für Netzwerk-Devices und dennoch kannst du diese ansprechen. Nicht alles, was als Datei ansprechbar ist, muss auch als Datei existieren.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 rasidrasid, 02.08.2012
    rasidrasid

    rasidrasid Eroberer

    Dabei seit:
    25.05.2010
    Beiträge:
    68
    Zustimmungen:
    0
    danke nochmals, bitte wie mounte ich es...kannst du mir den Befehl senden?

    Danke
     
  12. #10 bitmuncher, 02.08.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Gib einfach mal 'man mount' in ein Terminal ein. :rtfm:
     
Thema:

Wo sind die Geräte?

Die Seite wird geladen...

Wo sind die Geräte? - Ähnliche Themen

  1. Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11

    Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11: Hallo liebes Forum. Es scheint mir wie eine plumpe Anfängerfrage, jedoch habe ich zu dem Thema nichts sinnvolles gefunden. Ich habe CentOS...
  2. Stallman: Systeme von Apple und Microsoft sind Malware

    Stallman: Systeme von Apple und Microsoft sind Malware: In einem Artikel in der britischen Zeitung »The Guardian« bezeichnet Richard Stallman die Betriebssysteme von Micrososft und Apple als Malware....
  3. Bradley Kuhn: Beitragsvereinbarungen sind überflüssig

    Bradley Kuhn: Beitragsvereinbarungen sind überflüssig: Bradley M. Kuhn, der Präsident der Software Freedom Conservancy und Vorstandsmitglied der FSF, hat Beitragsvereinbarungen (Contributor Licensing...
  4. [FRAGE] Dateinamen normalisieren während sie in einer "for" Schleife sind

    [FRAGE] Dateinamen normalisieren während sie in einer "for" Schleife sind: Moin Gemeinde, ich habe ein Skript welches Emails abholt und weiterverarbeitet, manche müssen ausgedruckt werden. Nun hat sich herausgestellt...
  5. Freigegebene Drucker sind nicht auffindbar / nutzbar

    Freigegebene Drucker sind nicht auffindbar / nutzbar: Hallo zusammen, so langsam bin ich am Verzweifeln. Ich will an einem Rechner zwei Drucker freigeben, die dort problemlos funktionieren....