wieder mal: Debian 3.0, Geforce2 Ti und NVIDIA1.0-4191

console_fighter

Grünschnabel
Beiträge
3
Hm, ich hab hier mal die Meldungen durchgesehen, die ähnlihce Probs wie meines betreffen, leider konnte ich es nicht exakt ausmachen. Deshalb poste ich hier die letzten Zeilen der Log-Datei, wenn der X-Server hochfahren soll und kein Gerät findet (die Meldungen vorher sind höchstens auf (WW), also verursachen keinen Abbruch):

----------------------------------------
.......

(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver 1.0-4191 Mon Dec 9 11:51:41 PST 2002
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

------------------------------------------------

Vielleicht kann ja auch mir hier geholfen werden?

Ich hatte vorher übrigens eine Kyro2-Karte drin, die mit dem Framebuffer lief, bevor ich die Karte auf die genannte austauschte. Ausserdem habe ich rpm-Pakete ins deb-Format umgewandelt (mit alien), und ich konnte die Dateien auch installieren mit aptitude. Wäre hier ein Fehler aufgetaucht, hätte ich da ja wohl was mit bekomme müssen, oder?

Danke schon mal an alle Tipgeber!
 

console_fighter

Grünschnabel
Beiträge
3
Aber klar doch! Hier ist sie:

-------------------------------------------------
### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "v4l"
Load "speedo"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection


Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "MapName" "Standard Keyboard [ pc104 ]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 30-96
Identifier "Monitor[0]"
ModelName "Unknown"
Option "DPMS"
VendorName "Unknown"
VertRefresh 50-160
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
# Modeline "1024x768" 71.39 1024 1040 1216 1400 768 768 777 802
# Modeline "1024x768" 81.01 1024 1040 1216 1400 768 768 777 802
EndSection


Section "Device"
BoardName "GeForce2 Ti"
BusID "1:0:0"
Driver "nvidia.o"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
#Option "NvAGP" "0" # disable agp
#Option "NvAGP" "1" # use nvidia agp
#Option "NvAGP" "2" # use agpgart
Option "NvAGP" "3" # try 2 than 1
VendorName "NVidia"
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x960" "1024x768" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Screen "Screen[0]"
EndSection


### END DEBCONF SECTION

-----------------------------------------

Die DEBCONF-Einträge stehen dort, weil ich anfangs X mit dem reconfigure unter Debian eingerichtet hatte (noch mit fb-device). Diese config basiert auf der meines anderen Rechners, in der eine Geforce4 unter SuSE läuft - bestens übrigens...
 

console_fighter

Grünschnabel
Beiträge
3
nun habe ich folgende Varianten ausprobiert, um das NVidia-Kernel-Modul zu benennen:

nvidia
nvidia.o
nvidia_drv
nvidia_drv.o

Alle erfolglos. Dabei wäre die Lösung so schön einfach gewesen...

Gibt es denn keine kompliziertere Lösung, die dann vielleicht gar funkioniert? :D
 

Ähnliche Themen

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht

X startet nichtmehr

xserver startet nicht: no screens

xrandr: cant open display

Oben