USB device not accepting address

N

notms

Gast
Ich habe ein Asus K8N-E Deluxe Motherboard mit Athlon64 Prozessor und Debian Linux Kernel 2.6.9 installiert und bekomme keine USB Geräte zum laufen. Ich befürchte, dies ist kein Problem, speziell mit Linux, denn mit WinXP funktionierts auch nicht. Bei jeder Verbindung bekomme ich die Fehlermeldung in der Art

usb 2-4: new full speed USB device using address 2
ohci_hcd 0000:00:02.1: urb df586100 path 4 ep0out 5ec20000 cc 5 --> status -110
usb 2-4: device not accepting address 2, error -110

Auf der Suche im Internet habe ich zahlreiche Meldungen diebezüglich gefunden, jedoch keine einzige funktionierende Lösung (mit/ohne ACPI, APIC, ...). Habe außerdem verschiedene Kernel und Konfigurationen probiert, bisher ohne Erfolg. Poste hier mal die komplette Ausgabe, wenn ich das Modul ohci-hcd mit angeschlossenem USB-Gerät neu lade, vielleicht kann mir ja jemand helfen oder einen Tip geben:

Code:
Nov 25 11:45:01 localhost kernel: ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
Nov 25 11:45:01 localhost kernel: ohci_hcd: block sizes: ed 64 td 64
Nov 25 11:45:01 localhost kernel: ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 21 (level, low) -> IRQ 21
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: PCI device 10de:00e7 (nVidia Corporation)
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: reset, control = 0x600
Nov 25 11:45:01 localhost kernel: PCI: Setting latency timer of device 0000:00:02.0 to 64
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: irq 21, pci mem e0a44000
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: supports USB remote wakeup
Nov 25 11:45:01 localhost kernel: usb usb1: new device strings: Mfr=3, Product=2, SerialNumber=1
Nov 25 11:45:01 localhost kernel: usb usb1: default language 0x0409
Nov 25 11:45:01 localhost kernel: usb usb1: Product: PCI device 10de:00e7 (nVidia Corporation)
Nov 25 11:45:01 localhost kernel: usb usb1: Manufacturer: Linux 2.6.9 ohci_hcd
Nov 25 11:45:01 localhost kernel: usb usb1: SerialNumber: 0000:00:02.0
Nov 25 11:45:01 localhost kernel: usb usb1: hotplug
Nov 25 11:45:01 localhost kernel: usb usb1: adding 1-0:1.0 (config #1, interface 0)
Nov 25 11:45:01 localhost kernel: usb 1-0:1.0: hotplug
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: usb_probe_interface
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: usb_probe_interface - got id
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: USB hub found
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: 4 ports detected
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: standalone hub
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: no power switching (usb 1.0)
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: individual port over-current protection
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: power on to power good time: 2ms
Nov 25 11:45:01 localhost kernel: hub 1-0:1.0: local power source is good
Nov 25 11:45:01 localhost usb.agent[7714]:      usbcore: already loaded
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: created debug files
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: OHCI controller state
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: OHCI 1.0, with legacy support registers
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: control 0x683 RWE RWC HCFS=operational CBSR=3
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: intrstatus 0x00000004 SF
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: intrenable 0x8000000a MIE RD WDH
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: hcca frame #005b
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.a 01000a04 POTPGT=1 OCPM NPS NDP=4
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.b 00000000 PPCM=0000 DR=0000
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.status 00008000 DRWE
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.portstatus [0] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.portstatus [1] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.portstatus [2] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.0: roothub.portstatus [3] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ACPI: PCI interrupt 0000:00:02.1[B] -> GSI 20 (level, low) -> IRQ 20
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: PCI device 10de:00e7 (nVidia Corporation)
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: reset, control = 0x600
Nov 25 11:45:01 localhost kernel: PCI: Setting latency timer of device 0000:00:02.1 to 64
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: irq 20, pci mem e0ac0000
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 2
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: supports USB remote wakeup
Nov 25 11:45:01 localhost kernel: usb usb2: new device strings: Mfr=3, Product=2, SerialNumber=1
Nov 25 11:45:01 localhost kernel: usb usb2: default language 0x0409
Nov 25 11:45:01 localhost kernel: usb usb2: Product: PCI device 10de:00e7 (nVidia Corporation)
Nov 25 11:45:01 localhost kernel: usb usb2: Manufacturer: Linux 2.6.9 ohci_hcd
Nov 25 11:45:01 localhost kernel: usb usb2: SerialNumber: 0000:00:02.1
Nov 25 11:45:01 localhost kernel: usb usb2: hotplug
Nov 25 11:45:01 localhost kernel: usb usb2: adding 2-0:1.0 (config #1, interface 0)
Nov 25 11:45:01 localhost kernel: usb 2-0:1.0: hotplug
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: usb_probe_interface
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: usb_probe_interface - got id
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: USB hub found
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: 4 ports detected
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: standalone hub
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: no power switching (usb 1.0)
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: individual port over-current protection
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: power on to power good time: 2ms
Nov 25 11:45:01 localhost kernel: hub 2-0:1.0: local power source is good
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: created debug files
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: OHCI controller state
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: OHCI 1.0, with legacy support registers
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: control 0x683 RWE RWC HCFS=operational CBSR=3
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: cmdstatus 0x00000 SOC=0
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: intrstatus 0x00000044 RHSC SF
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: intrenable 0x8000000a MIE RD WDH
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: hcca frame #000e
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.a 01000a04 POTPGT=1 OCPM NPS NDP=4
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.b 00000000 PPCM=0000 DR=0000
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.status 00008000 DRWE
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.portstatus [0] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.portstatus [1] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.portstatus [2] 0x00000100 PPS
Nov 25 11:45:01 localhost kernel: ohci_hcd 0000:00:02.1: roothub.portstatus [3] 0x00010101 CSC PPS CCS
Nov 25 11:45:02 localhost usb.agent[7757]:      usbcore: already loaded
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.0: suspend root hub
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: GetStatus roothub.portstatus [3] = 0x00010101 CSC PPS CCS
Nov 25 11:45:02 localhost kernel: hub 2-0:1.0: port 4, status 0101, change 0001, 12 Mb/s
Nov 25 11:45:02 localhost kernel: hub 2-0:1.0: debounce: port 4: total 100ms stable 100ms status 0x101
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: GetStatus roothub.portstatus [3] = 0x00100103 PRSC PPS PES CCS
Nov 25 11:45:02 localhost kernel: usb 2-4: new full speed USB device using address 2
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: urb df586100 path 4 ep0out 5ec20000 cc 5 --> status -110
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: urb df586100 path 4 ep0out 5ec20000 cc 5 --> status -110
Nov 25 11:45:02 localhost kernel: usb 2-4: device not accepting address 2, error -110
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: GetStatus roothub.portstatus [3] = 0x00100103 PRSC PPS PES CCS
Nov 25 11:45:02 localhost kernel: usb 2-4: new full speed USB device using address 3
Nov 25 11:45:02 localhost kernel: ohci_hcd 0000:00:02.1: urb df586100 path 4 ep0out 5ec20000 cc 5 --> status -110
Nov 25 11:45:03 localhost kernel: ohci_hcd 0000:00:02.1: urb df586100 path 4 ep0out 5ec20000 cc 5 --> status -110
Nov 25 11:45:03 localhost kernel: usb 2-4: device not accepting address 3, error -110
Nov 25 11:45:03 localhost kernel: ohci_hcd 0000:00:02.1: GetStatus roothub.portstatus [2] = 0x00010100 CSC PPS
Nov 25 11:45:03 localhost kernel: hub 2-0:1.0: port 3, status 0100, change 0001, 12 Mb/s
Nov 25 11:45:03 localhost kernel: hub 2-0:1.0: debounce: port 3: total 100ms stable 100ms status 0x100



Danke,

Wolfgang
 

Zico

Lebende Foren Legende
Beiträge
1.559
Als ich das Topic eben sah war mein erster Gedanke "Kernel".
Aber wenn du sagst, dass du 2.6.9 verwendest und es auch unter Windows nicht geht.
Hmm also ich denk mal, dass da war mit der Hardware nicht stimmt.
Du sagst also dass du keine Geräte zum laufen bekommst und die Meldungen deuten auch auf ein größeres Problem hin.
Aber vielleicht kann man da ja was machen. Wie verwendest du denn USB? Hast du rückseitige USB Anschlusse, wurden die benutzt? oder Front USB? Oder sogar nen HUB? Und vor allem: Hat das Board noch Garantie? Ich würds dann nämlich Austauschen. Is ja Mist wenn USB nicht läuft...
 

damager

Moderator
Beiträge
3.065
ich hatte sowas mal mit einem usb-mp3 player mit usb 1.0 der auf einem usb 2.0 anschluß nicht laufen wollte.
erst als ein usb 1.0 hub angeschloßen war hat der player die adresse akzeptiert. evtl. das gleich problem?

gehen gar keine usb-geräte? wie sehen dein bios-einstellungen für usb aus? usb-legacy-suppot aktiviert?
 

Cyber

.:DISTORTED:.
Beiträge
999
wie sehen dein bios-einstellungen für usb aus? usb-legacy-suppot aktiviert?

Öhm, das ist AFAIK doch nur für USB-Tastaturen (Maus) gedacht.

//Edit: Revidiere meine Aussage.

So, kurzer Blick ins Handbuch, Kapitel 4.4.5, USB-Configuration
Du hast da folgende Optionen:
- USB Controller Setup (USB1.1 + USB2.0)
- Legacy USB Support
- USB Controller Mode (HighSpeed)

Stell den Mode von High-Speed (480 Mbps) mal auf Full Speed (12 Mbps) um.
Try it again.
 
Zuletzt bearbeitet:

khs

Routinier
Beiträge
408
Gibt es irgendwo eine Liste der Fehler-Codes, warum ein Device die ID nicht akzeptiert?
Einen hab ich selbst erlebt und zwei weitere hier gelesen, jeweils unterschiedlich. Aber daraus auf die Ursache schliessen? Zumindest mir bisher nicht moeglich.

-khs
 

Zico

Lebende Foren Legende
Beiträge
1.559
Also den Fehler mit not accepting Adress und Fehlercode -110 kenne ich persönlich auch. Das muss ich schon sagen. In Verbindung mit meinem USB Stick. Nur war es bei mir ab Kernel 2.6x behoben
 

damager

Moderator
Beiträge
3.065
er benutzt aber schon einen 2.6.9 .... und unter windoof geht ja auch nicht.
daher meine vermutung das es an der hardware und /oder an den bios einstellungen liegt.
 

Atomara

Debrandeter User
Beiträge
1.255
ich kenne diese fehlermeldung , meistens ist es behoben in dem ich den port wechsle , ich habe den 2.6.8.1 und kann nicht upgraden weil ich cedega unter 2.6.9 nicht zocken kann .
 

Zico

Lebende Foren Legende
Beiträge
1.559
er benutzt aber schon einen 2.6.9 .... und unter windoof geht ja auch nicht.
daher meine vermutung das es an der hardware und /oder an den bios einstellungen liegt.

Mein erster Post hat Ähnliches angedeuted :D
 

Cyber

.:DISTORTED:.
Beiträge
999
Entweder seh ich doppelt oder der Zico hat sich verklickt ;)

Jedenfalls sollten wir erstmal abwarten was bei notms rausgekommen ist, da bis jetzt ja noch kein Feddback vorliegt.
 
A

andreash

Gast
Ich habe seit einem Kernel update bei fedora core 6 ein sehr ähnliches Problem mit einem Bluetooth stick.
mit Kernel 2.6.18-1.2798 hat noch alles funktioniert
seit Kernel 2.6.20-1.2944 bekomme ich die Fehlermeldung.

Sobald ich in bios von USB2.0 auf 1.1 umschalte kommt der Fehler nicht mehr. Bluetooth funktioniert aber trotzdem nicht. Beim starten des Systems kann auserdem der hidd daemon nicht gestartet werden.

USB 1-1 not accepting address 2 error -71

lg Andreas
 

Ähnliche Themen

Problem mit SATA

Keine grafische Oberfläche (Debian Installation)

Problem bei der installation einer Sun Netzwerkkarte

Creative Labs SoundBlaster Audigy 2 ZS unter Debian / Kernel 3.16

UDEV rules - How ?

Oben