ULi M5455 unter Debian Wheezy 7.9

Diskutiere ULi M5455 unter Debian Wheezy 7.9 im Debian/Ubuntu/Knoppix Forum im Bereich Linux Distributionen; Hallo zusammen Habe eine Sun Ultra45 (Sparc) mit Debian 7.9 unter Kernel 3.16 (backport) am laufen. Wenn ich bei den Audioeinstellungen...

  1. jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Hallo zusammen

    Habe eine Sun Ultra45 (Sparc) mit Debian 7.9 unter Kernel 3.16 (backport) am laufen. Wenn ich bei den Audioeinstellungen nachschaue, sehe ich unter "Output" einen Eintrag "Dummy Device", jedoch ist unter "Hardware" nicht zu finden.

    Gnome habe ich manuell installiert. Evtl. habe ich dabei was vergessen? Pulseaudio ist jedenfalls installiert...?
     
  2. #2 Goodspeed, 09.01.2016
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.168
    Zustimmungen:
    2
    Ort:
    Dresden
    Was sagt denn
    Code:
    lspci
    zum Thema Audio?
     
  3. jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Das Gerät existiert in der Systemkonfiguration* - dank "lspci" weiss ich auch den Namen.

    *Wenn etwas mit lspci angezeigt wird, dann heisst dass das a.) lediglich das Gerät erkannt wurde oder b.) das Gerät erkannt, und ein Treiber geladen wurde...?

    Wenn ich meine alte externe Creative Labs SoundBlaster Extigy USB-Soundkarte anschliesse, sehe ich zwar unter dem Tab "Hardware" ein Gerät - aber der Output ist weiterhin "dummy"...?

    Oder weiss jemand eine Soundkarte (PCI-Express oder der alte PCI-Bus mit 2 Einbuchtungen beim Slot) welche problemlos mit Debian Wheezy läuft? (Manchmal ist es irgendwie einfacher, ein wenig Geld auszugeben und die Hardware dem Linux anzupassen als das Linux der Hardware ;-))
     
  4. #4 Goodspeed, 09.01.2016
    Zuletzt bearbeitet: 09.01.2016
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.168
    Zustimmungen:
    2
    Ort:
    Dresden
    Das sagt nur, welche Hardware erkannt wird. Da Du uns im Dunkeln lässt, wirste den richtigen Treiber selber suchen müssen ...
    Code:
    aplay -l
    sagt Dir, welche ALSA-devices es aktuell gibt (sorry, mit dem Gnome-Gedöns kenn ich mich nicht aus ...)

    Edit sagt: snd-intel8x0 könnte passen ... zumindest für Ali M5455 ... oder snd_hda_intel
     
  5. jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Will nichts vorenthalten, hatte das Gerät nur gerade nicht zur Hand..;-)

    "lspci" gibt mir folgendes aus:
    Code:
    02:00.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    03:01.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    03:02.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    03:03.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    03:08.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    03:09.0 PCI bridge: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch
    (rev aa)
    04:00.0 PCI bridge: ULi Electronics Inc. M5249 HTT to PCI Bridge
    05:1c.0 USB controller: ULi Electronics Inc. USB 1.1 Controller (rev 03)
    05:1c.1 USB controller: ULi Electronics Inc. USB 1.1 Controller (rev 03)
    05:1c.2 USB controller: ULi Electronics Inc. USB 1.1 Controller (rev 03)
    05:1c.3 USB controller: ULi Electronics Inc. USB 2.0 Controller (rev 01)
    05:1d.0 Multimedia audio controller: ULi Electronics Inc. M5455 PCI AC-Link Cont
    roller Audio Device (rev 21)
    05:1e.1 Bridge: ULi Electronics Inc. M7101 Power Management Controller [PMU]
    05:1f.0 IDE interface: ULi Electronics Inc. M5229 IDE (rev c8)
    06:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev b3)
    07:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethe
    rnet (rev a2)
    07:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethe
    rnet (rev a2)
    09:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 0
    3)
    0a:00.0 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridg
    e (A-Segment Bridge) (rev 09)
    0a:00.2 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridg
    e (B-Segment Bridge) (rev 09)
    0b:01.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1064 PCI-X Fusion-
    MPT SAS (rev 02)
    0c:01.0 VGA compatible controller: NVIDIA Corporation NV34GL [Quadro NVS 280 PCI
    ] (rev a1)
    
    "aplay -l" das hier:
    Code:
    aplay: device_list:252: no soundcards found...
     
  6. #6 Goodspeed, 10.01.2016
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.168
    Zustimmungen:
    2
    Ort:
    Dresden
    Kannst Du mal schauen, ob die beiden genannten Module geladen sind und wenn nicht ... nachladen und nochmal testen.
    Wenn das alles nichts hilft, bitte nochmal
    Code:
     lspci -knn
    ... und zumindest für das Audiodevice posten.
     
  7. #7 jmar83, 10.01.2016
    Zuletzt von einem Moderator bearbeitet: 11.01.2016
    jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Die scheinen gar nicht zu existieren:
    Code:
    root@ultra45:~# modprobe snd_intel_hd
    FATAL: Module snd_intel_hd not found.
    root@ultra45:~# modprobe snd-intel8x0
    FATAL: Module snd-intel8x0 not found.
    root@ultra45:~#
    
    In diesem Fall müsste ich wohl selbst was kompilieren, oder wie sieht das aus? Gar den Kernel mögicherweise?



    lspci -knn gibt das aus:
    Code:
    root@ultra45:~#  lspci -knn
    02:00.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    03:01.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    03:02.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    03:03.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    03:08.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    03:09.0 PCI bridge [0604]: PLX Technology, Inc. PEX 8532  Versatile PCI Express Switch [10b5:8532] (rev aa)
    04:00.0 PCI bridge [0604]: ULi Electronics Inc. M5249 HTT to PCI Bridge [10b9:5249]
    05:1c.0 USB controller [0c03]: ULi Electronics Inc. USB 1.1 Controller [10b9:5237] (rev 03)
      Subsystem: ULi Electronics Inc. ASRock 939Dual-SATA2 Motherboard [10b9:5237]
      Kernel driver in use: ohci-pci
    05:1c.1 USB controller [0c03]: ULi Electronics Inc. USB 1.1 Controller [10b9:5237] (rev 03)
      Subsystem: ULi Electronics Inc. ASRock 939Dual-SATA2 Motherboard [10b9:5237]
      Kernel driver in use: ohci-pci
    05:1c.2 USB controller [0c03]: ULi Electronics Inc. USB 1.1 Controller [10b9:5237] (rev 03)
      Subsystem: ULi Electronics Inc. ASRock 939Dual-SATA2 Motherboard [10b9:5237]
      Kernel driver in use: ohci-pci
    05:1c.3 USB controller [0c03]: ULi Electronics Inc. USB 2.0 Controller [10b9:5239] (rev 01)
      Subsystem: ULi Electronics Inc. Device [10b9:5238]
      Kernel driver in use: ehci-pci
    05:1d.0 Multimedia audio controller [0401]: ULi Electronics Inc. M5455 PCI AC-Link Controller Audio Device [10b9:5455] (rev 21)
      Subsystem: ULi Electronics Inc. ASRock 939Dual-SATA2 Motherboard [10b9:5455]
    05:1e.1 Bridge [0680]: ULi Electronics Inc. M7101 Power Management Controller [PMU] [10b9:7101]
    05:1f.0 IDE interface [0101]: ULi Electronics Inc. M5229 IDE [10b9:5229] (rev c8)
      Subsystem: ULi Electronics Inc. M5229 IDE [10b9:5229]
      Kernel driver in use: pata_ali
    06:00.0 PCI bridge [0604]: Broadcom EPB PCI-Express to PCI-X Bridge [1166:0103] (rev b3)
    07:04.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethernet [14e4:1678]  (rev a2)
      Subsystem: Oracle/SUN Device [108e:1678]
      Kernel driver in use: tg3
    07:04.1 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethernet [14e4:1678] (rev a2)
      Subsystem: Oracle/SUN Device [108e:1678]
      Kernel driver in use: tg3
    09:00.0 USB controller [0c03]: NEC Corporation uPD720200 USB 3.0 Host Controller [1033:0194] (rev 03)
      Subsystem: Western Digital USB 3.0 PCIe Card [1b96:0001]
      Kernel driver in use: xhci_hcd
    0a:00.0 PCI bridge [0604]: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (A-Segment Bridge) [8086:0340] (rev 09)
    0a:00.2 PCI bridge [0604]: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (B-Segment Bridge) [8086:0341] (rev 09)
    0b:01.0 SCSI storage controller [0100]: LSI Logic / Symbios Logic SAS1064 PCI-X Fusion-MPT SAS [1000:0050] (rev 02)
      Subsystem: LSI Logic / Symbios Logic Device [1000:3020]
      Kernel driver in use: mptsas
    0c:01.0 VGA compatible controller [0300]: NVIDIA Corporation NV34GL [Quadro NVS 280 PCI] [10de:032a] (rev a1)
      Subsystem: NVIDIA Corporation Device [10de:019f]
      Kernel driver in use: nouveau
    root@ultra45:~#
    
     
  8. #8 Goodspeed, 11.01.2016
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.168
    Zustimmungen:
    2
    Ort:
    Dresden
    Hmm ... das snd-intel8x0-Modul gibt es wirklich nicht in den Sparc-Kerneln ... warum auch immer. Keine Ahnung, ob man das Bauen kann (wenn, dann den kompletten Kernel).
     
  9. jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Trotzdem vielen Dank!!

    Dann werde ich es mal mit dem SoundBlaster Extigy für den USB-Bus versuchen. Werde dann ggf. einen neuen Thread eröffnen.
     
  10. jmar83

    jmar83 Routinier

    Dabei seit:
    05.07.2011
    Beiträge:
    260
    Zustimmungen:
    0
    Gleiches Problem wenn ich auf der "Blade 2500 Silver" Debian 7.x installiere, liegt also irgendwo im System (ALSA-Konfiguration - diese "Cookie"-Fehlermeldungen im Log?) und hat nichts mit der verwendeten Soundkarte zu tun. Selbst wenn die Treiber die richtigen sind...

    PCI, PCIE oder USB spielt keine Rolle, habe immer das gleiche "Theather" damit. Wenn notwenig kann ich aber auch auf Sound verzichten bei den Sun-Rechnern ;)
     
Thema:

ULi M5455 unter Debian Wheezy 7.9

Die Seite wird geladen...

ULi M5455 unter Debian Wheezy 7.9 - Ähnliche Themen

  1. Anlage einer SWAP-Datei unter CentOS 7 funktioniert nicht

    Anlage einer SWAP-Datei unter CentOS 7 funktioniert nicht: Hallo zusammen, ich verwende einen vServer von Strato (Linux V30) mit CentOS 7 64bit. Hier wollte ich nun einen SWAP-Speicher mit 8GB anlegen -...
  2. Robots aussperren, Websitescan unterbinden, PHP Checkbox-Captcha?

    Robots aussperren, Websitescan unterbinden, PHP Checkbox-Captcha?: Hallo zusammen, ich hätte gerne einen bestimmten Bereich der Webseite, den Robots oder scriptbasierte Scans von irgendwelchen Suchmaschinen oder...
  3. [gelöst] 2.HDD unter Freebsd partitionieren

    [gelöst] 2.HDD unter Freebsd partitionieren: Hallo Habe eine Testserver mit freeBSD 11.0 auf einer IDE-HDD (ada0) mit ZFS-root hab jetzt eine 2. HDd (SATA) angeschlossen und wollte die...
  4. Installation von COM Ports unter Unix

    Installation von COM Ports unter Unix: Hallo, vorne weg, ich habe von Linux nur Grundkenntnisse und bitte daher etwas um Rücksicht, wenn ich doofe fragen stelle;). Zum Problem: Es gibt...
  5. Samba 4 trennt sich beim Übertragen unter Windows7/10

    Samba 4 trennt sich beim Übertragen unter Windows7/10: Hallo zusammen Mir ist nun schon ein paar Mal aufgefallen dass sich mein Samba-Server (Debian 8.7.1 + backports-Kernel v4.9.x) "einfach so", ohne...