SW-Raid SCSI langsam?

Diskutiere SW-Raid SCSI langsam? im Anwendungen Forum im Bereich Linux/Unix Allgemein; Hi Leute Hab einen Server, auf dem ich Gentoo mit SW-Raid (Raid1) installiert hab. Server: Opteron 2.0 GHZ, 2x SCSI 500GB, 2GB Ram, kernel...

  1. #1 luusbueb, 02.08.2006
    luusbueb

    luusbueb unverhofft kommt oft

    Dabei seit:
    16.12.2005
    Beiträge:
    54
    Zustimmungen:
    0
    Ort:
    CH - Schaffhausen
    Hi Leute

    Hab einen Server, auf dem ich Gentoo mit SW-Raid (Raid1) installiert hab.

    Server: Opteron 2.0 GHZ, 2x SCSI 500GB, 2GB Ram, kernel 2.6.17-gentoo-r4
    Partitionierung/Raid:

    md1: sda1,sdb1 (not mounted)
    md2: sda2,sdb2 (swap, not mounted)
    md3: sda3,sdb3 (root)
    md4: sda4,sdb4

    Hatte bei der Installation schon einige Probleme, weil sich der Server beim resync von md4 immer wieder aufgehängt hatte. Musste sogar eine ältere Live-CD nehmen, mit der 2006 für AMD64 hat das resync nie bis zum Schluss geklappt.
    Das System läuft jetzt, die Raids md1, 2, 3 laufen, keine Probleme.
    Einzig md4 bereitet mir (und anscheinend auch dem Server) Kopfschmerzen.
    Beim letzten boot sagt /var/log/messages (nachdem md1, 2, 3 ok sind):

    Code:
    md: created md4
    md: bind<sda4>
    md: bind<sdb4>
    md: running: <sdb4><sda4>
    md: md4: raid array is not clean -- starting background reconstruction
    .
    .
    .
    md: syncing RAID array md4
    md: minimum _guaranteed_ reconstruction speed: 1000 KB/sec/disc.
    md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for reconstruction.
    md: using 128k window, over a total of 467820736 blocks.
    
    Ok, kann ich nachvollziehen. (Ich nehme an, dass ist einmalig.)

    Doch nach ca. 10 Minuten Sync (wenn überhaupt), zeigt "cat /proc/mdstat" folgendes an:

    Code:
    md4 : active raid1 sdb4[1] sda4[0]
          467820736 blocks [2/2] [UU]
          [=>...................]  resync =  7.9% (36999680/467820736) finish=1254851.7min speed=5K/sec
    
    Das garantierte 1MB/s ist leider nicht ganz erreicht mit 7K/s.
    Ich könnte das akzeptieren, aber in 1254851.7 min bin ich wahrscheinlich schon lange tot. :schlaf:

    Hat irgendjemand ähnliche Erfahrungen gemacht mit einem SW-Raid für so grosse Partitionen?
    Ich weiss echt nicht woran das liegt...

    Danke für jeden Hinweis!

    P.S.
    Falls es hilfreich ist, hier noch was in /var/log/messages während des resyncs am laufenden Band eingetragen wird:
    Code:
    ata2: command 0x35 timeout, stat 0x50 host_stat 0x24
    ata2: status=0x50 { DriveReady SeekComplete }
    sdb: Current: sense key: No Sense
    Additional sense: No additional sense information
    ata1: command 0x25 timeout, stat 0x50 host_stat 0x24
    ata1: status=0x50 { DriveReady SeekComplete }
    sda: Current: sense key: No Sense
    Additional sense: No additional sense information
    ata2: command 0xca timeout, stat 0x50 host_stat 0x24
    ata2: status=0x50 { DriveReady SeekComplete }
    sdb: Current: sense key: No Sense
    Additional sense: No additional sense information
    Info fld=0x6dc5eff
    
     
  2. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Sieht fuer mich nach einer defekten Platte im RAID aus.
    Code:
    ata1: command 0x25 timeout, stat 0x50 host_stat 0x24
    ata1: status=0x50 { DriveReady SeekComplete }
     
  3. #3 luusbueb, 03.08.2006
    Zuletzt bearbeitet: 08.08.2006
    luusbueb

    luusbueb unverhofft kommt oft

    Dabei seit:
    16.12.2005
    Beiträge:
    54
    Zustimmungen:
    0
    Ort:
    CH - Schaffhausen
    Ja, unmöglich ist das leider nicht.
    Werde das mal checken und melde mich dann wieder...

    Danke für den Hinweis.

    (Weitere Ideen natürlich willkommen....) :)

    EDIT:

    Ok, Hardware-Defekt war's keiner.
    Was es war, weiss ich noch immer nicht.
    Aber ein BIOS-Update hatte geholfen.

    (Thread kann geschlossen werden)
     
Thema:

SW-Raid SCSI langsam?

Die Seite wird geladen...

SW-Raid SCSI langsam? - Ähnliche Themen

  1. Daten UND Betriebssystem, alles auf einem SW-RAID1-Array...?

    Daten UND Betriebssystem, alles auf einem SW-RAID1-Array...?: Hallo zusammen Wollte fragen wie man sowas macht, leider finde ich im Internet immer nur die Anleitungen wo davon ausgegangen wird dass eine sep....
  2. Grub + Sw-raid1

    Grub + Sw-raid1: ich bin gerade mal ein bisschen am experimentieren mit linux und versuche nun eine etwas kompliziertere Partitionierung Bei dieser...
  3. iscsi-dienst mit virtl. laufwerk unter solaris einrichten

    iscsi-dienst mit virtl. laufwerk unter solaris einrichten: hallo zusammen das habe ich versucht: sudo pkg install group/feature/storage-server sudo svcadm enable stmf sudo zfs create -V 1g...
  4. iscsi-target als sparse-file?

    iscsi-target als sparse-file?: hallo zusammen, habe gestern ein iscsi-target in der grösse von 750gb mithilfe von "dd if" angelegt. (bs=768k, count=1024000) nun ging das...
  5. SCSI page 83h VPD descriptor mit Linux SCSI target framework (tgt)

    SCSI page 83h VPD descriptor mit Linux SCSI target framework (tgt): Hallo, ich habe einen Linux Server (auf VMware Workstation Basis) der seine 3 Festplatten via iSCSI exportiert (Target). Auf einem Windows...