solaris über router ans netz

C

chriss

Gast
kann mir da einer helfen? verzweifle gaaaanz langsam bei der sache....

pc1 - mit windoof xp
pc2 - mit windoof xp

die beiden pc's sind über einen router miteinander und mit dem internet verbunden.

habe jetzt eine unix-ws bekommen, habe solaris 9 aufgesetzt, ein netzwerkkabel vom onboard-port zum router gezogen. dann habe ich in der datei /etc/hosts folgenden eintrag gemacht:

ip (191.167.1.3) (domainname) unix2 loghost

habe dann beim router die ip und den domainnamen auch eingetragen.

ergebnis: ping unix-ws von beiden pc's aus -> alive.
ping von beiden pc's aus auf die unix-ws -> alive.
ping unix-ws an den router -> alive.

aber keine internetverbindung. irgendwas fehlt oder ist falsch.....???

da ich ein absuluter neuling in der solaris welt bin wäre ich froh, wenn mir jemand eine "step-by-step anleitung" geben könnte, wie ich die unix-ws via router ans internet bringe......

vielen dank für eure hilfe
 
devilz

devilz

Pro*phet
so wie ich das sehe hast du vergessen der Solaris WS die Inet Route mitzuteilen.

ein "route add -net default gw IPDEINESROUTERS" sollte ein ping auf den T-Online DNS (194.25.2.129) erlauben ?
 
mjup

mjup

Tripel-As
du solltest in /etc/defaultrouter die IP von dem router eintragen, dann wird die route beim systemstart automatisch eingetragen. ;)

Ausserdem solltest du in der /etc/resolv.conf deine DNS eintragen.

search meine.domain.at
domain meine.domain.at
nameserver 192.168.0.1
nameserver 192.168.0.2

Das obenstehende musst du natürlich mit deinen daten ersetzen. Wenn du search und domain nicht weisst, kanst du es weglassen.


Und zu guter letzt noch /etc/nsswich.conf editieren und bei hosts dns dazuschreiben.
hosts: files dns

nun sollte nach einem neustart alles funken. :]
 
pcdog

pcdog

Jungspund
was hast du denn für ein subnet? 191.167??

is das ein fake oder was?
falls ned, solltest du ändern....
 

Ähnliche Themen

Problem mit Ubuntu/openVPN-Server hinter Router

Routing funktioniert nicht mehr nach dem Start der Firewall

SOLARIS shell und apache installation

Kein Ping mit Suse 10.0 auf DSL-provider (über wwwoffle) möglich

Wie mache ich eine Internet freigebe unter MDK 10 für Windows rechner?

Oben