RTL8180 WLAN-Chipsatz

Moritz

Moritz

Life is hard and so am I
Hallo liebe Linux'erInnen!

Ich beschäftige mich seit einiger Zeit mit meiner WLAN-Karte mit dem Chip von Realtek (RTL8180).
Erhältlich unter anderem auf der Level1 WPC-0101 oder der Linksys WPC100.
Diese Chip wird nicht native vom Kernel unterstützt.
Da ich eh den 2.4.22 nutze habe ich PCMCIA neukonfiguriert. Damit meine
normale CardBus NIC läuft benötige ich das Modul tulip_cb, dass man nur von
pcmcia-cs (http://pcmcia-cs.sf.net), wenn man im Kernel das PCMCIA-Subsystem
deaktiviert:
Code:
#
# PCMCIA/CardBus support
#
# CONFIG_PCMCIA is not set
#
# Wireless LAN (non-hamradio)
#
CONFIG_NET_RADIO=y
CONFIG_NET_WIRELESS=y
Soweit so gut. Die für WLAN nötigen Tools wireless_tools (
http://hpl.hp.com/personal/Jean_Tourrilhes/Linux/ ) und wlan-ng ( http://www.linux-wlan.com )
sind ebenfalls installiert.

Die Treiber des Chips finden sich auf der Realtek-Homepage
( http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=8180 )
zumindest für RedHat 7.2 und 9.0 ( ftp://210.51.181.211/cn/wlan/rtl8180l/rtl8180_linuxdrv_v14_rh90.zip ).

Die habe ich dann entpackt und der README nachbearbeitet:
Code:
[root@Atlas root]# unzip rtl8180_linuxdrv_v14_rh90.zip
Archive:  rtl8180_linuxdrv_v14_rh90.zip
  inflating: release/Makefile
  inflating: release/priv_part.o
  inflating: release/r8180_export.h
  inflating: release/r8180_if.c
  inflating: release/r8180_if.h
  inflating: release/r8180_pci_init.c
  inflating: release/r8180_pci_init.h
  inflating: release/r8180_type.h
  inflating: release/readme
  inflating: release/rls_note_1030
  inflating: release/wlandown
  inflating: release/wlanup
[root@Atlas root]# cd release/
[root@Atlas release]# vi Makefile
Im Makefile muss in jedem Fall das KERNELRELEASE und der INCLUDEPATH
angepasst werden
Code:
 #-----------------------------------------------
#Specify kernel version and include path
#-----------------------------------------------
KERNELRELEASE=2.4.22
INCLUDEPATH=-I /usr/src/linux-$(KERNELRELEASE)/include/
Die anderen einstellbaren Sachen wie z.B.IO_FLAGS oder ENDIAN_FLAGS verstehe
ich nicht und habe ich nicht verändert. Danach kann Kompeliert werden:
Code:
 [root@Atlas release]# make
gcc -O6 -Wall -DMODULE -D__KERNEL__ -DLINUX -I
/usr/src/linux-2.4.22/include/ -DRTL_IO_MAP -DRTL_LITTLE_ENDIAN -DRTL_ACT_AS_STA
-DRTL8180_DRV_ON_PC -DENABLE_DBG_PRINT -c -o r8180_pci_init.o
r8180_pci_init.c
In file included from /usr/src/linux-2.4.22/include/asm/semaphore.h:39,
                 from /usr/src/linux-2.4.22/include/linux/fs.h:200,
                 from /usr/src/linux-2.4.22/include/linux/capability.h:17,
                 from /usr/src/linux-2.4.22/include/linux/binfmts.h:5,
                 from /usr/src/linux-2.4.22/include/linux/sched.h:9,
                 from r8180_pci_init.c:26:
/usr/src/linux-2.4.22/include/asm/system.h: In function `__set_64bit_var':
/usr/src/linux-2.4.22/include/asm/system.h:190: warning: dereferencing
type-punned pointer will break strict-aliasing rules
/usr/src/linux-2.4.22/include/asm/system.h:190: warning: dereferencing
type-punned pointer will break strict-aliasing rules
gcc -O6 -Wall -DMODULE -D__KERNEL__ -DLINUX -I
/usr/src/linux-2.4.22/include/ -DRTL_IO_MAP -DRTL_LITTLE_ENDIAN -DRTL_ACT_AS_STA
-DRTL8180_DRV_ON_PC -DENABLE_DBG_PRINT -c -o r8180_if.o r8180_if.c
In file included from /usr/src/linux-2.4.22/include/asm/semaphore.h:39,
                 from /usr/src/linux-2.4.22/include/linux/fs.h:200,
                 from /usr/src/linux-2.4.22/include/linux/capability.h:17,
                 from /usr/src/linux-2.4.22/include/linux/binfmts.h:5,
                 from /usr/src/linux-2.4.22/include/linux/sched.h:9,
                 from r8180_if.c:27:
/usr/src/linux-2.4.22/include/asm/system.h: In function `__set_64bit_var':
/usr/src/linux-2.4.22/include/asm/system.h:190: warning: dereferencing
type-punned pointer will break strict-aliasing rules
/usr/src/linux-2.4.22/include/asm/system.h:190: warning: dereferencing
type-punned pointer will break strict-aliasing rules
--- Generate open part open_part.o ---

--- Generate rtl8180 linux driver  rtl8180_24x.o on 2.4.22 ---
Erstmal beschreibe ich, wie es weitergehen würde, wenn ich keinen Fehler
bekomme, da ja vielleicht andere Leute mehr "Glück" haben und die interessiert
mein Fehler ja nicht.
Diese beiden Konfigurationen müssen in die /etc/pcmcia/wlan-ng.conf
eingetragen werden.
Code:
device "rtl8180_24x"
   class "wlan-ng" module "rtl8180_24x"

card "Level1 WPC-0101 11Mb/s 802.11b WLAN Card"
   manfid 0x0000, 0x024c
   bind "rtl8180_24x"
Der erste Eintrag zeigt dem PCMCIA-Daemon, dass es das Modul rtl8180_24x
gibt und der zweite weißt der Karte mit der manfid 0x0000, 0x024c das Modul
rtl8180_24x zu. Entnehmen kann man diese Informationen cardctl:
Code:
 [root@Atlas release]# cardctl ident
Socket 0:
  product info: "Realtek", "Rtl8180"
  manfid: 0x0000, 0x024c
  function: 6 (network)
  PCI id: 0x10ec, 0x8180
Socket 1:
  product info: "CardBus", "Fast Ethernet", "V1.0", ""
  manfid: 0x13d1, 0xab02
  function: 6 (network)
  PCI id: 0x13d1, 0xab02
Nach dem nächsten Neustart des PCMCIA-Daemons (oder des Rechners ;-)) sollt
die Karte laufen.


Sollte, tut sie bei mir aber nicht :-(((
In meinem Syslog werden folgende Infos gespeichert:
Code:
 Nov  7 16:47:23 atlas kernel: cs: cb_alloc(bus 1): vendor 0x10ec, device 0x8180
Nov  7 16:47:23 atlas cardmgr[103]: socket 0: Level1 WPC-0101 11Mb/s  02.11b WLAN Card
Nov  7 16:47:23 atlas cardmgr[103]: executing: 'modprobe rtl8180_24x'
Nov  7 16:47:24 atlas kernel:
Nov  7 16:47:24 atlas kernel:
Nov  7 16:47:24 atlas kernel: ******** RTL8180 Wireless Lan Driver 2003-10-17 loaded********
Nov  7 16:47:24 atlas kernel: PCI: No IRQ known for interrupt pin A of device .
Nov  7 16:47:24 atlas kernel: PCI: Setting latency timer of device  to 64
Nov  7 16:47:24 atlas kernel: RTL8180: : region #0 not a PIO resource, aborting
Nov  7 16:47:24 atlas kernel: unregister_netdevice: device  lan%%d/c1a80c00 never was registered
Nov  7 16:47:24 atlas kernel: RTL8180: wlan driver load failed
Nov  7 16:47:24 atlas kernel: rtl8180: No devices found, RTL8180 Wireless Lan Driver 2003-10-17 unregistered
Nov  7 16:47:24 atlas cardmgr[103]: + /lib/modules/2.4.22/pcmcia/rtl8180_24x.o: init_module: No such device
Nov  7 16:47:24 atlas cardmgr[103]: + /lib/modules/2.4.22/pcmcia/rtl8180_24x.o: insmod  /lib/modules/2.4.22/pcmcia/rtl8180_24x.o failed
Nov  7 16:47:24 atlas cardmgr[103]: + /lib/modules/2.4.22/pcmcia/rtl8180_24x.o: insmod rtl8180_24x failed
Nov  7 16:47:24 atlas cardmgr[103]: + Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
Nov  7 16:47:24 atlas cardmgr[103]: +       You may find more information in syslog or the output from dmesg
Nov  7 16:47:24 atlas cardmgr[103]: modprobe exited with status 255
Nov  7 16:47:24 atlas cardmgr[103]: executing: 'insmod /lib/modules/2.4.22/pcmcia/rtl8180_24x.o'
Nov  7 16:47:24 atlas kernel:
Nov  7 16:47:24 atlas kernel:
Nov  7 16:47:24 atlas kernel: ******** RTL8180 Wireless Lan Driver 2003-10-17 loaded********
Nov  7 16:47:24 atlas cardmgr[103]: + /lib/modules/2.4.22/pcmcia/rtl8180_24x.o: init_module: No such device
Nov  7 16:47:24 atlas kernel: PCI: No IRQ known for interrupt pin A of device .
Nov  7 16:47:24 atlas cardmgr[103]: + Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
Nov  7 16:47:24 atlas kernel: RTL8180: : region #0 not a PIO resource, aborting
Nov  7 16:47:24 atlas cardmgr[103]: +       You may find more information in syslog or the output from dmesg
Nov  7 16:47:24 atlas kernel: unregister_netdevice: device wlan%%d/c1a80c00 never was registered
Nov  7 16:47:24 atlas cardmgr[103]: insmod exited with status 1
Nov  7 16:47:24 atlas kernel: RTL8180: wlan driver load failed
Nov  7 16:47:24 atlas kernel: rtl8180: No devices found, RTL8180 Wireless Lan Driver 2003-10-17 unregistered
Nov  7 16:47:25 atlas cardmgr[103]: get dev info on socket 0 failed: Resource temporarily unavailable
lilo habe ich bereits mit append="pci=biosirq" angepasst (wurde mir vom
kernel via syslog befohlen)

Ich kann die Fehlermeldung allerdings nur schwer verstehen: Irgendwie werden
IRQs über vier Pins vergeben (A,B,C,D). Und das entweder vom BIOS oder vom
OS. Im BIOS kann man deswegen solche Kleinigkeiten einstellen, aber egal was
ich wähle, immer bekomme ich die gleiche Fehlermeldung. (glaube ich... habe
nie ge'diff't)
Code:
[root@Atlas release]# cat /proc/pci
[...]
  Bus  5, device   0, function  0:
    Ethernet controller:  (rev 17).
      IRQ 9.
      Master Capable.  Latency=64.  Min Gnt=255.Max Lat=255.
  Bus  1, device   0, function  0:
    Ethernet controller:  (rev 32).
      Master Capable.  Latency=64.  Min Gnt=32.Max Lat=64.
Es wird also kein IRQ zugewiesen (die erste Karte ist meine normal NIC)

Hat jemand nen Rat?

Vielen Dank im Vorraus!
Moritz

PS: Entschuldigung für die extrem lange Mail, aber es gab bisher kaum gut
dokumentierte Anleitungen für den RTL8180-Chip und so dachte ich schreibe es
mal für andere auf, die vielleicht weniger Probleme haben als ich.
PPS: Benutze wie oben schon beschrieben den 2.4.22 mit DevFS und gcc 3.3.2
(nur zur Info)
 
Zuletzt bearbeitet:
LinuxSchwedy

LinuxSchwedy

ehem. Mod
Ich habe die letzten 2 Wochen mit einer PCI-Karte mit dem gleichen Chip gekämpft. Weder unter SuSE 8.2 und 9.0, noch unter Slackware 9.1 und Gentoo 1.4 habe ich diese zum Laufen gebracht. Habe zum Thema hunderte von Seiten "durchgeblättert". Wir sind wohl nicht die einzigen, die es nicht schaffen...

Ich habe die Karte zurück an den Händler geschickt, weil auf der Verpackung die Unterstützung für Linux versprochen und nicht realisierbar war. X(
 
devilz

devilz

Pro*phet
Hmmm ... soweit so gut ....

Hast du mal APIC ausgeschaltet ? Bzw. im Kernel drinne ?

Welche Distro verwendest du ? (Schaut nach Gentoo ~x86 aus ?)
 
Moritz

Moritz

Life is hard and so am I
Hey LinuxSchwedy!
Hört sich ja nicht so prikelnd an! Ich kann leider nix mehr umtauschen... habe die Karte schon recht lange. Und von Linux war nix angegeben. :-/

devilz schrieb:
Hast du mal APIC ausgeschaltet ? Bzw. im Kernel drinne ?

Welche Distro verwendest du ? (Schaut nach Gentoo ~x86 aus ?)
Der Laptop in dem die Karte drinne steckt hat von APIC noch nie was gehört (Fujitsu Siemens LifeBook C345). Oder meinst Du ACPI? Da bin ich mir gerade nicht ganz sicher....
Ich benutze ArchLinux (www.archlinux.org). Eine i686-Optimierte Distri. Absolut empfehlenswert. Habe in irgendeinem anderen Forum mal ne Vorstellung von Arch geschrieben. Leider ist das Forum zur Zeit down. Wenn ich an den Text wieder dran komme werde ich ihn auch hier mal posten!
 
devilz

devilz

Pro*phet
Hmm ich bin Gentooist .. eine Meta-Distro die du ohne weiteres auf fast jede CPU Optimieren kannst.
(www.gentoo.de)

APIC = Advanced Programmable Interrupt Controller
ACPI = Advanced Configuration and Power Interface

Ich meinte das erstere ... check mal bitte deine Kernel Settings !
 
Moritz

Moritz

Life is hard and so am I
okay... ich bin mir zwar nicht ganz sicher, ob das ne Fehlerquelle sein kann, da die Hardware ja kein APIC unterstützt, aber ich werd mal schaun!
Wo find ich das denn im Kernel? (2.4.22) :bounce:

EDIT:
Okay... habs gefunden! Es ist ausgeschaltet ("CONFIG_X86_UP_APIC is not set")
Ist das gut oder schlecht?
 
Zuletzt bearbeitet:
Moritz

Moritz

Life is hard and so am I
Hmm... habe nochmal den Standard-Kernel meiner Distrie draufgespielt, und auf einmal klappts.
Werd nochmal n bischen gucken, aber das macht ja schonmal Hoffnung! :bounce:
 
J

jpsaenz

Grünschnabel
Hi Moritz,

ich hatte anfangs genau das Problem... Die blöde Karte bekam keinen IRQ bzw. I/O zugewiesen... (Debian Woody mit 2.4.18-bf2.4) Ich habe mir den 2.4.22er. kompiliert und das Problem war gelöst (Was in Deinem Fall nicht sehr tröstlich ist, da Du genau diesen Kernel verwendest... aber welche Distri?) Verschiedene PCI Boot-Einstellungen (pci=biosirq, direct, any) waren bei mir ebenfalls unfruchtbar. Versuch's halt mit einem höheren Kernelversion, vielleicht klappt's dann.

Von den wireless_tools brauchst Du nur iwpriv, alle anderen werden von der Karte nicht unterstüzt, da diese einen eigenen Befehlsatz verwendet. wlan-ng kannst Du auch in die Tonne werfen, da läuft nur den von Realtek selbstgebauten Mist (rtl8180_24x.o bzw. priv_part.o)

Allerdings muss ich sagen, dass diese Sch**ß Karte echt zum Kotzen ist, jetzt wird sie zwar erkannt, die Treibern lassen sich zwar kompilieren und laden (nur die Version für den gcc 3xx), die Karte meldet sich fröhlich beim AP und erkennt es ohne weiteres, keine weitere Verbindung kommt aber zustande. Alle Vesuche, den AP zu pingen, schlugen fehl (den Treiber sagt dabei entweder gar nichts oder "tx a packet failure!!") und wehe, man möchte die Karte rausnehmen oder herunterfahren: Kernel Panic.

Naja, ich bin halt etwas frustriert... Viellleicht hat jemand bessere Erfahrungen gemacht?

Saludos,
Juan Pablo
 
J

JohnnyBi

Grünschnabel
Wlan-Karte

Hast du des skript, das ebim Treiberm itgeliefert wurde? Also dieses wlanup/wlandown? Bei mir blinkt die karte immerhin schonmal und ich kann sie auch mit ifconfig konfiggn. ;)

Ich hab' redhat mit dem 2.4.20-20.9 kernel und hab' nix an dem rumgepfuscht, sondern hab' den standartmäßigen benutzt!

Have Phun!


--------------------------------------------------------------------

Linux is like a Wigwam - no Windows, no Gates and Apache inside!
 
J

jpsaenz

Grünschnabel
jö, habe ich. Das Problem habe ich aber gelöst, in dem ich mir den 2.4.20er gebacken habe... nun geht es :-)

Saludos,
jp
 
Zuletzt bearbeitet:
Moritz

Moritz

Life is hard and so am I
hmmm.....
glaube nicht, dass es an der Version des Kernels liegt... habe seit 2.4.18 alles probiert (auch so ziemlich jeden AC- und RC-Patch)
Falls hier noch jemand Probleme hat mit der Karte, könnt Ihr mal mal Eure Kernel-Config auf folgende Einträge überprüfen:
Code:
CONFIG_PCMCIA
CONFIG_CADBUS
CONFIG_TCIC
CONFIG_I82092
CONFIG_I82365
Ich vermute mal da liegt mein Problem
Genauer hab ich's noch nicht eingegrenzt, da einmal Kernel kompelieren bei mir mind. 30 Minuten dauert :-(

Grüße,
Moritz
 
J

jpsaenz

Grünschnabel
also nach meiner Erfahrung kann ich mit ziemlicher Sicherheit sagen, dass es an der Kernel-Version lag. Ich habe (bei DebianWoody) [1] den Generic-Kernel (2.4.18-bf2.4) versucht, da wurde der Karte keinen IRQ bzw. I/O zugewiesen, [2] mit dem 2.4.22 wurde die Karte richtig erkannt und die Treiber geladen, die Karte meldete sich sogar ordnungsgemäß beim AP, ich konnte aber keine Daten senden ("Tx Error"), und [3] mit dem 2.4.9 konnte ich die Drivers nicht laden. Das binäre Teil der Treiber wurde jedoch auf einem RH 2.4.20-8 kompiliert, da habe ich mir diesen Kernel gebaut und es hat funktioniert... Natürlich habe ich immer dieselben Parametern benutzt, IMHO steht somit fest, dass es daran gelegen haben *muss*... kannst Du es mal versuchen, kostet nur Zeit ;-)

Viel Glück!
jp
 
Moritz

Moritz

Life is hard and so am I
Da Du einmal ne Debian-Konfig und einmal nicht verwendet hast ist das meiner Meinung nach nicht wirklich vergleichbar!
Habe jetzt ne Konfig mit der sowohl meine normal NIC als auch meine W-NIC läuft. Und zum Spaß hab ich das auch mal mit 2.4.18 kompeliert und es geht.
Der RTL-8180 braucht wohl irgendwelche Infos vom PCMCIA-Subsystem. Das gelingt aber nur, wenn die oben genannten Punkte fest im Kernel sind. (vielleicht auch weniger, habe noch nicht getestet welche genau!)
Aber so läuft's jetzt bei mir!
 
LinuxSchwedy

LinuxSchwedy

ehem. Mod
Mensch, muss man echt den Kernel neu kompilieren, um die Sch***-Treiber zu installieren?

Warum wird in der Readme das nicht erwähnt ?

Jetzt habe ich leider die Karte nicht mehr, weil ich die weggeschickt habe ...
 
Moritz

Moritz

Life is hard and so am I
Hab das ganze jetzt nochmal mit 2.4.23-rc1 ausprobiert und da geht's (warum auch immer) nit mehr.
Hmm... teste gleich nochmal, aber vielleicht muss Realtek bald mal nen neuen Treiber ausspucken (n 2.6er wäre auch cool!!!)
 
J

jpsaenz

Grünschnabel
@Moritz: Was meinst Du mit

Da Du einmal ne Debian-Konfig und einmal nicht verwendet hast ist das meiner Meinung nach nicht wirklich vergleichbar!

die Config war dieselbe, und nur unter Debian habe ich's probiert... ok, bei den generic-Kernel sind ein Paar Sachen mehr drauf als bei den selbstkompilierten, aber dann hätte es *gerade da* eher laufen sollen... wie gesagt:

[1] 2.4.2-bf2.4: Karte hängt tot da, es werden keine IRQ I/O zugewiesen
[2] 2.4.22: Karte lebt, module werden geladen, Karte sieht AP, AP sieht Karte, Karte sendet aber nicht(s)
[3] 2.4.9: Module können nicht geladen werden ("priv_part.o" spuckt 'ne Menge unresolved Symbols aus, Kernel Missmatch Errors u.ä.)
[4] 2.4.20: Karte lebt, Module auch, "priv_part.o" sagt zwar "Kernel tainted" usw, wird aber geladen, ich kann das Teil mit iwpriv configurieren und zum Laufen bringen.

man merke: die Versuche [2] bis [4] habe ich mit derselben Konfig gamacht, nichts hinzugefügt und nichts weggelassen (Wichtig hier: PCMCIA Unterstützung und ORINOCO Tribers). Den darausresultierenden Kernel wurde (logischerweise) um einiges schlanker als den Generic-Kernel, bei dem die Karte nicht mal angesprochen werden konnte.

Wenn's nicht an der Kernelversion liegt, dann habe ich da was grundlich missverstanden :-)

Saludos,
jp
 
J

JohnnyBi

Grünschnabel
RTL8180 - tut nur so halb

Hi! Ich hab' zwar meine Karte zum blinken bekommen, und auch, dass ifconfig/iwconfig sie mir anzeigt! Aber zu meinem AP connecten kann ich immernoch net! Der hat nur ne WEP verschlüsselung! Wie kann ich den denn zumindest pingen?

Der meint bei mir immer "Destination host not reachable"

Kann mal vllt einer von euch, die es geschafft haben, ihre "wlanup" hier rein pasten?

Wäre euch sehr verbunden - danke! ;)
 
J

jpsaenz

Grünschnabel
Also wenn die Karte läuft, musst Du das Setzen der Default-Route nicht vergessen.

Du machen:

RECHNER:# ifconfig wlan0 DEINE_IP netmask DEINE_NM*
RECHNER:# route add default gw DEINE_GATEWAY

meine config habe ich grad'nicht dabei, poste sie noch bei Gelegenheit...

Saludos,
jp

--
*wahrscheinlich 255.255.255.0
 
J

jpsaenz

Grünschnabel
eps, ich habe mich Rechner wieder, hier meine Config:

Code:
#--------------------------
# Load wireless lan driver
#--------------------------
/sbin/insmod -f rtl8180_24x
/sbin/insmod -f priv_part

case "$1" in

 ap)
        echo "ap"
        #------------------------------------------
        # Config AP mode
        # Assign SSID and operation channel.
        #------------------------------------------
        /sbin/iwpriv wlan0 wlan_para ssid=
        /sbin/iwpriv wlan0 wlan_para channel=
        ;;

 infra)
        echo "infra"
        #------------------------------------------
        # Config infrastructure mode
        # Assign network type and desired SSID.
        #------------------------------------------
        /sbin/iwpriv wlan0 wlan_para preamble=auto
        /sbin/iwpriv wlan0 wlan_para networktype=infra
        /sbin/iwpriv wlan0 wlan_para authtype=opensystem
        /sbin/iwpriv wlan0 wlan_para ssid2scan=[DEINE_SSID]
        /sbin/iwpriv wlan0 wlan_para ssid=[DEINE_SSID]
        /sbin/iwpriv wlan0 wlan_para channel=[DEIN_CH]
        /sbin/iwpriv wlan0 wlan_para fragthres=3000,rtsthres=2304
        /sbin/iwpriv wlan0 wlan_para bcnint=64
        /sbin/iwpriv wlan0 wlan_para basicrates=0xf
        /sbin/iwpriv wlan0 wlan_para oprates=0xf
        ;;

 adhoc)
        echo "adhoc"
        #------------------------------------------
        # Config infrastructure mode
        # Assign network type and desired SSID.
        # 'ssid' and 'channel' are the default setting
        # and meaningful if this is the first station
        # in an IBSS.
        #------------------------------------------
        /sbin/iwpriv wlan0 wlan_para networktype=adhoc
        /sbin/iwpriv wlan0 wlan_para ssid=default
        /sbin/iwpriv wlan0 wlan_para channel=13
        ;;
 *)
        /sbin/rmmod rtl8180_24x
        echo "Usage: $0 {ap | infra | adhoc}"
        exit 1
esac




 #--------------------------
 # Config WEP mode
 #--------------------------
#/sbin/iwpriv wlan0 wlan_para encmode=off
#/sbin/iwpriv wlan0 wlan_para wepmode=off

/sbin/iwpriv wlan0 wlan_para encmode=wep,wepmode=wep40
/sbin/iwpriv wlan0 wlan_para wepmode=wep40,wepdkeyid=0,wepkey40_1=[DEIN_WEPKEY_HEXADEZIMAL]




 #--------------------------
 # Config debugging message
 #--------------------------
/sbin/iwpriv wlan0 msglevel 0
#/sbin/iwpriv wlan0 msglevel 1
#/sbin/iwpriv wlan0 msglevel 2
#/sbin/iwpriv wlan0 msglevel 3


 #--------------------------
 # Enable wireless lan driver
 #--------------------------
/sbin/iwpriv wlan0 enable


 #--------------------------
 # Configure wlan0 IP address
 #--------------------------
/sbin/ifconfig wlan0 [DEINE_IP] netmask [DEINE_NM]
route add default gw [DEINE_GW]
echo "$(/sbin/ifconfig wlan0)"

wenn's immer noch nicht läuft, solltest Du den MSGLEVEL auf 1|2|3 setzen und gucken, was er bei den Ping-Versuchen noch alles sagt...

Und Du solltest auch die aktuelle Version 1.4 verwenden...

Viel Glück!
jps
 
J

JohnnyBi

Grünschnabel
Ich bin am Verzweifeln!

Ich hab' nun deine wlanup bei mir gestartet (nochmals danke), er findet zwar meinen AP, steht zumindest im Log, aber des mit dem Ping tut immernoch net! Brauch ich denn noch mehr als die wireless-tools und den Treiber?

Und sobald ich die Karte deaktiviere hängt sich mein gesamtes System auf mit so (Kernel tainted, etc...), das ist echt lustig, da er dann beim Neustart immer die Platte scannen muss (Wie schaltet man das bei redhat ab?)

Danke schomal im vorraus! (Ich bin wohl der einzige depp, der es net hinbekommt! *ggrrr*)
 

Ähnliche Themen

X startet nichtmehr

xrandr: cant open display

OpenSuse 12.3 / Tiefschlaf funktioniert nicht

Mysteriöser 11.4 Absturz - Maschine läuft, SSH und vor Ort Login unmöglich

Displayport + externer Monitor zeigt bei startx nichts erst bei DVI

Oben