Problem mit RedHat

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
Hi
Ich habe mir gestern mal übergangsweise wieder RedHat draufgemacht. ISt schon ne Weile her seit ich das das letzte Mal benutzt habem sonst immer nur Debian! Nun stehe ich hier aber vor 2 Probleme!

Zum einen scheint er mkfs nciht mehr zu finden, und zum anderen funktioniert apt auch nicht mehr.

Zuerst zu mkfs..ich wollte nen USB Stick formatieren, und da sagt er mir, er findet mkfs nicht. Also hab ich mal schnell die dosfstools installiert, aber es klappt immernoch nciht.
Weiss einer da Rat?

Nun zu apt.
Als ich früher schonmal RedHat hatte lief apt, das ich per rpm installiert hatte, immmer einwandfrei, aber seit neustem sagt er mir immer nur, das er das Paket nciht finden kann, egal was ich installieren will!

//edit:

Hmm, ich habe mich mal richtig als root eingeloggt, und siehe da, alles funzt....apt geht, mkfs geht alles geht....aber eben nur wenn ich mich als root einlogge, wenn ich mich wieder als USer einlogge gehts wieder nciht mehr

Woran kann das liegen?

MfG
RlddLeR
 

PlantMan

Eroberer
Beiträge
69
Versuch mal

ls -l /usr/sbin/mkfs (oder wo auch immer die Datei liegt)

VIelleicht is das/die Programm(e) als suid root installiert ?
 

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
Hmm...ich bin mit dem mkfs jetzt schon so weit, das ich es zwar starten kann (wenn auch mühsam), aber es kommt immer ein Fehler: incorrectly build...

Komisch Komisch...wenn ich richtig als root eingeloggt bin, geht alles ohne Probleme!

Das Problem mit apt hab ich aber schonmal behoben gekriegt....nur mlfs spackt noch rum...
 

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
Ok es hat geklappt, ich hab das Problem mit kfs regeln können, alles klappt nun ohne Einwand.

Danke ncohmal an PLantman!
 

Ähnliche Themen

Windows clients können nicht mehr auf lange laufendes System zugreifen

Squid als RPCoHTTPS Proxy für Outlook Anywhere

Hi großes problem

Problem mit Apache2 + MySQL Server

0-laenge Pakete und Xorg Probleme

Oben