PANGO problem

MTS

Kaiser
Beiträge
1.242
hi, ich habe gentoo und folgendes Problem beim kompilieren von pango, bei allen versionen die ich auswählen kann.
Obwohl ich schon xft, freetype und gtk-doc neu kompiliert habe (wie es mir im gentooforum vorgeschlagen wurde), bekomme ich immer denselben fehler ..

gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/etc\" -DLIBDIR=\"/usr/lib\" -DMODULE_VERSION=\"1.2.0\" -DG_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/X11R6/include -I.. -march=athlon-xp -O3 -pipe -Wall -c pangoft2.c -fPIC -DPIC -o pangoft2.lo
pangoft2.c: In function `pango_ft2_font_get_face':
pangoft2.c:224: `FC_HINT_STYLE' undeclared (first use in this function)
pangoft2.c:224: (Each undeclared identifier is reported only once
pangoft2.c:224: for each function it appears in.)
pangoft2.c:225: `FC_HINT_FULL' undeclared (first use in this function)
pangoft2.c:227: `FC_HINT_NONE' undeclared (first use in this function)
pangoft2.c:231: `FC_HINT_SLIGHT' undeclared (first use in this function)
pangoft2.c:234: `FC_HINT_MEDIUM' undeclared (first use in this function)
make[3]: *** [pangoft2.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1/pango'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1'
make: *** [all-recursive-am] Error 2

!!! ERROR: x11-libs/pango-1.2.1 failed.
!!! Function src_compile, Line 46, Exitcode 2
!!! serial make failed

ich hab echt null peil was das soll...
 
A

Anzeige

Hallo MTS,

schau mal hier: PANGO problem. Dort wird jeder fündig!

devilz

Pro*phet
Beiträge
12.245
Hast du mal probiert dein CFLAGS wegzulassen in der make.conf ?

Oder mal probieren PANGO per Hand zu installieren und dann injecten ......

Geht das ???
 

MTS

Kaiser
Beiträge
1.242
hmm, ich hab mir die sources gezogen, die kann ich kompilieren .. habs dann injected. aber wenn ich dann gtk+ neukompilieren will, sagt mir das irgendwann während des kompilierens, dass er pango nicht finden konnte ...
mäglich das ich pango unter dem falschem pfad gespeichert habe ,,, wo muss das hin?? (prefix)
 

devilz

Pro*phet
Beiträge
12.245
Dann nimm doch als Prefix den Pfad wo du es installiert hast bei make install ..... dann sollte es gehen .....
 

Ähnliche Themen

Nginx als Reverse Proxy für Nextcloud und Emby

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

Was mache ich falsch? Tiniywm und Mate Install unter OpenBSD

Samba compile

X startet nichtmehr

Oben