Notebook, ATI und zweiter Screen - ich verzweifle

Diskutiere Notebook, ATI und zweiter Screen - ich verzweifle im Gentoo Forum im Bereich Linux Distributionen; Ich versuche es jetzt seit Tagen, einen zweiten an mein Notebook angeschlossenen Monitor zusätzlich zum Laufen zu bringen, und schaffe es einfach...

  1. #1 Bloodsurfer, 20.12.2006
    Bloodsurfer

    Bloodsurfer Gentoo-User

    Dabei seit:
    15.10.2005
    Beiträge:
    243
    Zustimmungen:
    0
    Ich versuche es jetzt seit Tagen, einen zweiten an mein Notebook angeschlossenen Monitor zusätzlich zum Laufen zu bringen, und schaffe es einfach nicht vernünftig...

    Im Book ist eine ATI X700. Interner Monitor ist ein 15er mit 1400x1050, extern soll ein 18er ran mit 1280x1024. Verwenden will ich KDE mit Xgl und Beryl. Nutze die proprietären ATI Treiber aus portage.

    Meine ursprüngliche xorg.conf sieht so aus:

    Code:
    Section "ServerLayout"
    	Identifier     "Server Layout"
    	Screen         "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	Option	       "AIGLX" "off"
    EndSection
    
    Section "Files"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/Type1/"
    	FontPath     "/usr/share/fonts/TTF"
    	FontPath     "/usr/share/fonts/corefonts"
    	FontPath     "/usr/share/fonts/freefonts"
    	FontPath     "/usr/share/fonts/sharefonts"
    	FontPath     "/usr/share/fonts/terminus"
    	FontPath     "/usr/share/fonts/ttf-bitstream-vera"
    	FontPath     "/usr/share/fonts/unifont"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/artwiz"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	SubSection "extmod"
    		Option	    "omit xfree86-dga"
    	EndSubSection
    	Load  "type1"
    	Load  "freetype"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "kbd"
    	Option	    "AutoRepeat" "200 50"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de"
    	Option      "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Option      "Device" "/dev/input/mice"
    	Option      "Protocol" "auto"
    	Driver      "mouse"
    EndSection
    
    Section "ServerFlags"
    	Option "AllowMouseOpenFail" "on"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	DisplaySize 370 278
    EndSection
    
    Section "Device"
    	Identifier  "Standard VGA"
    	Driver      "vga"
    	VendorName  "Unknown"
    	BoardName   "Unknown"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Graphics Adapter"
    	Driver      "fglrx"
    	Option	    "no_accel" "no"
    	Option	    "no_dri" "no"
    	Option	    "mtrr" "off"
    	Option	    "DesktopSetup" "clone"
    	Option	    "ScreenOverlap" "0"
    	Option	    "GammaCorrectionI" "0x00000000"
    	Option	    "GammaCorrectionII" "0x00000000"
    	Option	    "Capabilities" "0x00000000"
    	Option	    "CapabilitiesEx" "0x00000000"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "CenterMode" "off"
    	Option	    "PseudoColorVisuals" "off"
    	Option	    "Stereo" "off"
    	Option	    "StereoSyncEnable" "1"
    	Option	    "FSAAEnable" "no"
    	Option	    "FSAAScale" "1"
    	Option	    "FSAADisableGamma" "no"
    	Option	    "FSAACustomizeMSPos" "no"
    	Option	    "FSAAMSPosX0" "0.000000"
    	Option	    "FSAAMSPosY0" "0.000000"
    	Option	    "FSAAMSPosX1" "0.000000"
    	Option	    "FSAAMSPosY1" "0.000000"
    	Option	    "FSAAMSPosX2" "0.000000"
    	Option	    "FSAAMSPosY2" "0.000000"
    	Option	    "FSAAMSPosX3" "0.000000"
    	Option	    "FSAAMSPosY3" "0.000000"
    	Option	    "FSAAMSPosX4" "0.000000"
    	Option	    "FSAAMSPosY4" "0.000000"
    	Option	    "FSAAMSPosX5" "0.000000"
    	Option	    "FSAAMSPosY5" "0.000000"
    	Option	    "UseFastTLS" "0"
    	Option	    "BlockSignalsOnLock" "no"
    	Option	    "UseInternalAGPGART" "no"
    	Option	    "KernelModuleParm" "agplock=0"
    	Option	    "ForceGenericCPU" "no"
    	BusID       "PCI:1:0:0"
    	Option	    "BackingStore" "on"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "ATI Graphics Adapter"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport 0 0
    		Depth    24
    		Modes    "1400x1050" "1280x960" "1024x768" "800x600"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group 27
    	Mode 0660
    EndSection
    
    Die ist für clone konfiguriert gewesen und das funktionierte auch. Sah auf dem externen Screen das Ebenbild meines Desktops. Das ist aber nicht das was ich will.

    Zuerst hab ich einfach mal mit aticonfig die xorg.conf angepasst, das xinerama useflag war zu dem Zeitpunkt noch überall deaktiviert.

    Herausgekommen ist diese:

    Code:
    Section "ServerLayout"
    	Identifier     "Server Layout"
    	Screen         "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	Option	    "AIGLX" "off"
    EndSection
    
    Section "Files"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/Type1/"
    	FontPath     "/usr/share/fonts/TTF"
    	FontPath     "/usr/share/fonts/corefonts"
    	FontPath     "/usr/share/fonts/freefonts"
    	FontPath     "/usr/share/fonts/sharefonts"
    	FontPath     "/usr/share/fonts/terminus"
    	FontPath     "/usr/share/fonts/ttf-bitstream-vera"
    	FontPath     "/usr/share/fonts/unifont"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/artwiz"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	SubSection "extmod"
    		Option	    "omit xfree86-dga"
    	EndSubSection
    	Load  "type1"
    	Load  "freetype"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AllowMouseOpenFail" "on"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "kbd"
    	Option	    "AutoRepeat" "200 50"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de"
    	Option	    "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "auto"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	DisplaySize  370	278
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig Monitor 1"
    EndSection
    
    Section "Device"
    	Identifier  "Standard VGA"
    	Driver      "vga"
    	VendorName  "Unknown"
    	BoardName   "Unknown"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Graphics Adapter"
    	Driver      "fglrx"
    	Option	    "no_accel" "no"
    	Option	    "no_dri" "no"
    	Option	    "mtrr" "off"
    	Option	    "DesktopSetup" "horizontal"
    	Option	    "ScreenOverlap" "0"
    	Option	    "GammaCorrectionI" "0x00000000"
    	Option	    "GammaCorrectionII" "0x00000000"
    	Option	    "Capabilities" "0x00000000"
    	Option	    "CapabilitiesEx" "0x00000000"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "CenterMode" "off"
    	Option	    "PseudoColorVisuals" "off"
    	Option	    "Stereo" "off"
    	Option	    "StereoSyncEnable" "1"
    	Option	    "FSAAEnable" "no"
    	Option	    "FSAAScale" "1"
    	Option	    "FSAADisableGamma" "no"
    	Option	    "FSAACustomizeMSPos" "no"
    	Option	    "FSAAMSPosX0" "0.000000"
    	Option	    "FSAAMSPosY0" "0.000000"
    	Option	    "FSAAMSPosX1" "0.000000"
    	Option	    "FSAAMSPosY1" "0.000000"
    	Option	    "FSAAMSPosX2" "0.000000"
    	Option	    "FSAAMSPosY2" "0.000000"
    	Option	    "FSAAMSPosX3" "0.000000"
    	Option	    "FSAAMSPosY3" "0.000000"
    	Option	    "FSAAMSPosX4" "0.000000"
    	Option	    "FSAAMSPosY4" "0.000000"
    	Option	    "FSAAMSPosX5" "0.000000"
    	Option	    "FSAAMSPosY5" "0.000000"
    	Option	    "UseFastTLS" "0"
    	Option	    "BlockSignalsOnLock" "no"
    	Option	    "UseInternalAGPGART" "off"
    	Option	    "KernelModuleParm" "agplock=0"
    	Option	    "ForceGenericCPU" "no"
    	Option	    "BackingStore" "on"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Graphics Adapter 1"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    	Screen      1
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "ATI Graphics Adapter"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth   24
    		Modes   "1400x1050" "1280x960" "1024x768" "800x600"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig Screen 1"
    	Device     "ATI Graphics Adapter 1"
    	Monitor    "aticonfig Monitor 1"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth   24
    		Modes	"1280x1024" "1024x768"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        27
    	Mode         0660
    EndSection
    Habe damit X neu gestartet. Mein interner Monitor hat das selbe angezeigt wie vorher, und auf dem zweiten war auch ein zweiter Desktop. Wenn ich mit der Maus an den rechten Rand des ersten Monitors ranbin, habe ich die Hälfte des Mauszeigers auf dem zweiten Screen sehen können - aber mehr nicht. Ich konnte meine Maus nicht auf den zweiten Screen ganz rüber bringen, und auch keine Fenster dahin verschieben oder sonst irgendwie auf den zweiten wechseln. Er zeigte einfach nen Desktop mit KDE-Standardkonfig (also auch ne zweite Taskleiste, anders konfiguriert als die auf dem ersten Screen, usw.).

    Da dachte ich mir, ok, ohne das xinerama useflag wird's wohl nicht gehen. Also das flag global aktiviert, einen Riesenhaufen Pakete neu kompiliert (KDE, Xgl, andere WMs, war einiges).

    Voller Hoffnung danach wieder neu gestartet, aber Pustekuchen. Erster Screen normal, zweiter nur blau mit einem Mülleimer drauf (diesmal ohne zweite Kicker Leiste). Effekt wieder der selbe: Ich kann den Mauszeiger am Rand sehen, aber mehr nicht. Ich komme nicht auf den zweiten Screen und kann ihn auf keine Art und Weise nutzen...

    Da fiel mir auf dass in der xorg.conf Xinerama noch nicht aktiviert war. Also hab ich es aktiviert in den Serverflags, und wieder neu gestartet.
    Da wollte dann nicht mal mehr der KDM starten. X selbst startet mit schwarzem Hintergrund, Mauszeiger kommt und wird zur Sanduhr, aber KDM startet nicht und bringt dummerweise auch keine Fehlermeldung.

    Dann hab ich mal selbst ein bisschen an meiner ursprünglichen xorg.conf gebastelt anstatt aticonfig zu benutzen, und anhand diverser Wikis (auch der boardeigene Wiki ist dabei eingeflossen...) und Googelei folgende probiert:

    Code:
    Section "ServerLayout"
    	Identifier     "Server Layout"
    	Screen         0 "Screen0" 0 0
    	Screen         1 "Screen1" RightOf "Screen0"
    	Option         "Xinerama" "On"
    	InputDevice    "Mouse0" "CorePointer"
    #	InputDevice    "Mouse1"
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	Option	       "AIGLX" "off"
    EndSection
    
    Section "Files"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/Type1/"
    	FontPath     "/usr/share/fonts/TTF"
    	FontPath     "/usr/share/fonts/corefonts"
    	FontPath     "/usr/share/fonts/freefonts"
    	FontPath     "/usr/share/fonts/sharefonts"
    	FontPath     "/usr/share/fonts/terminus"
    	FontPath     "/usr/share/fonts/ttf-bitstream-vera"
    	FontPath     "/usr/share/fonts/unifont"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/artwiz"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	SubSection "extmod"
    		Option	    "omit xfree86-dga"
    	EndSubSection
    	Load  "type1"
    	Load  "freetype"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "kbd"
    	Option	    "AutoRepeat" "200 50"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de"
    	Option      "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Option      "Device" "/dev/input/mice"
    	Option      "Protocol" "auto"
    	Driver      "mouse"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse1"
    	Driver      "evdev"
    	Option	    "Name" "Logitech USB Receiver"
    EndSection
    
    Section "ServerFlags"
    	Option "AllowMouseOpenFail" "on"
    #	Option "Xinerama" "on"
    EndSection
    
    Section "Device"
    	Identifier  "ATI X700 1"
    	Driver      "fglrx"
    	Option	    "no_accel" "no"
    	Option	    "no_dri" "no"
    	Option	    "mtrr" "off"
    	Option	    "DesktopSetup" "horizontal"
    	Option	    "ScreenOverlap" "0"
    	Option	    "GammaCorrectionI" "0x00000000"
    	Option	    "GammaCorrectionII" "0x00000000"
    	Option	    "Capabilities" "0x00000000"
    	Option	    "CapabilitiesEx" "0x00000000"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "CenterMode" "off"
    	Option	    "PseudoColorVisuals" "off"
    	Option	    "Stereo" "off"
    	Option	    "StereoSyncEnable" "1"
    	Option	    "FSAAEnable" "no"
    	Option	    "FSAAScale" "1"
    	Option	    "FSAADisableGamma" "no"
    	Option	    "FSAACustomizeMSPos" "no"
    	Option	    "FSAAMSPosX0" "0.000000"
    	Option	    "FSAAMSPosY0" "0.000000"
    	Option	    "FSAAMSPosX1" "0.000000"
    	Option	    "FSAAMSPosY1" "0.000000"
    	Option	    "FSAAMSPosX2" "0.000000"
    	Option	    "FSAAMSPosY2" "0.000000"
    	Option	    "FSAAMSPosX3" "0.000000"
    	Option	    "FSAAMSPosY3" "0.000000"
    	Option	    "FSAAMSPosX4" "0.000000"
    	Option	    "FSAAMSPosY4" "0.000000"
    	Option	    "FSAAMSPosX5" "0.000000"
    	Option	    "FSAAMSPosY5" "0.000000"
    	Option	    "UseFastTLS" "0"
    	Option	    "BlockSignalsOnLock" "no"
    	Option	    "UseInternalAGPGART" "no
    	Option	    "ForceGenericCPU" "no"
    	BusID       "PCI:1:0:0"
    	Option	    "BackingStore" "on"
    	Screen      0
    EndSection
    
    Section "Device"
    	Identifier  "ATI X700 2"
    	Driver      "fglrx"
    	Option	    "no_accel" "no"
    	Option	    "no_dri" "no"
    	Option	    "mtrr" "off"
    	Option	    "DesktopSetup" "horizontal"
    	Option	    "ScreenOverlap" "0"
    	Option	    "GammaCorrectionI" "0x00000000"
    	Option	    "GammaCorrectionII" "0x00000000"
    	Option	    "Capabilities" "0x00000000"
    	Option	    "CapabilitiesEx" "0x00000000"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "CenterMode" "off"
    	Option	    "PseudoColorVisuals" "off"
    	Option	    "Stereo" "off"
    	Option	    "StereoSyncEnable" "1"
    	Option	    "FSAAEnable" "no"
    	Option	    "FSAAScale" "1"
    	Option	    "FSAADisableGamma" "no"
    	Option	    "FSAACustomizeMSPos" "no"
    	Option	    "FSAAMSPosX0" "0.000000"
    	Option	    "FSAAMSPosY0" "0.000000"
    	Option	    "FSAAMSPosX1" "0.000000"
    	Option	    "FSAAMSPosY1" "0.000000"
    	Option	    "FSAAMSPosX2" "0.000000"
    	Option	    "FSAAMSPosY2" "0.000000"
    	Option	    "FSAAMSPosX3" "0.000000"
    	Option	    "FSAAMSPosY3" "0.000000"
    	Option	    "FSAAMSPosX4" "0.000000"
    	Option	    "FSAAMSPosY4" "0.000000"
    	Option	    "FSAAMSPosX5" "0.000000"
    	Option	    "FSAAMSPosY5" "0.000000"
    	Option	    "UseFastTLS" "0"
    	Option	    "BlockSignalsOnLock" "no"
    	Option	    "UseInternalAGPGART" "no
    	Option	    "ForceGenericCPU" "no"
    	BusID       "PCI:1:0:0"
    	Option	    "BackingStore" "on"
    	Screen      1
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "ATI X700 1"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport 0 0
    		Depth    24
    		Modes    "1400x1050" "1280x960" "1024x768" "800x600"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "Screen1"
    	Device     "ATI X700 2"
    	Monitor    "Monitor1"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport 0 0
    		Depth    24
    		Modes    "1280x1024" "1280x960" "1024x768" "800x600"
    	EndSubSection
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	DisplaySize 370 278
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor1"
    	DisplaySize 370 278
    EndSection
    
    Section "DRI"
    	Group 27
    	Mode 0660
    EndSection
    
    War unnütz, die hat ebensowenig funktioniert.

    Die einzige Fehlermeldung, die ich in /var/log/Xorg.0.log sehe ist folgende:
    Code:
    (EE) fglrx(0): === [swlDalHelperSetControllerConfigForRemap] === CWDDC ControllerSetConfig failed: 6 - 0
    Die sagt mir nichts, und die steht jedesmal da, auch wenn X scheinbar richtig startet und funktioniert :? Danach googeln bringt mir nur zwei unbeantwortete Fragen und irgendwas russisches ;)

    Also so langsam bin ich mit meinem Latein am Ende, und neige dazu Xorg immer mehr zu verfluchen... Hat jemand eine Idee, Rat, Vorschläge?

    Ach ja, ich habs auch schon ohne Xgl und Beryl probiert, geht ebensowenig, daran liegt's also leider nicht... Wär ja auch zu einfach gewesen. Der Beryl Splash erscheint übrigens auf beiden Screens, der funktioniert (so ziemlich als einziges leider)...
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 m0l0ch, 26.12.2006
    Zuletzt von einem Moderator bearbeitet: 26.12.2006
    m0l0ch

    m0l0ch Guest

    ähnlliches problem

    Hallo, ich habe ein ähnliches Problem mit der selben Grafikkarte. Ich kann zwar die dualscreens benutzen (mit MergedFB) aber wenn ich eine Xgl Session starte erhalte ich die selbe Fehlermeldung. Ich kann gerade meine xorg.conf nicht posten, werde das aber beizeiten nachholen.
    Viel Glück

    Hier noch die xorg.conf:

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "false"
    EndSection

    Section "Files"

    # path to defoma fonts
    # FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    Load "dbe"
    Load "v4l"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "ch"
    Option "XkbVariant" "de"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Monitor"
    Identifier "Monitor 1"
    VendorName "Plug 'n' Play"
    ModelName "Plug 'n' Play"
    Option "DPMS" "true"
    EndSection

    Section "Monitor"
    Identifier "Monitor 2"
    VendorName "Plug 'n' Play"
    ModelName "Plug 'n' Play"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410)"
    Driver "fglrx"
    BoardName "ati"
    BusID "PCI:1:0:0"
    Option "UseInternalAGPGART" "no"
    Option "KernelModuleParm" "agplock=0"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "DesktopSetup" "horizontal"
    Option "Mode2" "1280x1024"
    Screen 0
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies, Inc. Radeon Mobility X700 (RV410)"
    Monitor "Monitor 1"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "0"
    EndSection

    Wenn ich die Zeile mit DesktopSetup aus der Device Section entferne, startet Xgl auf einem geklonten Bildschirm, wenn ich DesktopSetup auf horizontal setze, startet Xgl nicht. Mit normalen KDE Sessions funktioniert alles.
    Nochmal viel glück!
     
Thema:

Notebook, ATI und zweiter Screen - ich verzweifle

Die Seite wird geladen...

Notebook, ATI und zweiter Screen - ich verzweifle - Ähnliche Themen

  1. Purism bietet »PureBoot Bundle« für neue Notebooks

    Purism bietet »PureBoot Bundle« für neue Notebooks: Purism bietet Käufern seiner Notebooks jetzt die Möglichkeit, die Geräte per »PureBoot Bundle« ab Werk mit einem abgesicherten Bootvorgang...
  2. Tuxedo kündigt Notebooks mit Intels »Comet Lake« CPU an

    Tuxedo kündigt Notebooks mit Intels »Comet Lake« CPU an: Tuxedo Computers rüstet seine »InfinityBook Pro«-Reihe mit aktuellen Prozessoren aus Intels 10. Chipgeneration aus. Weiterlesen...
  3. Tuxedo Computers rüstet Notebooks mit Deep Learning-Fähigkeiten aus

    Tuxedo Computers rüstet Notebooks mit Deep Learning-Fähigkeiten aus: Der Linux-Notebookausrüster Tuxedo Computers aus dem bayrischen Königsbrunn rüstet einige seiner Notebooks mit der Option für Deep Learning aus....
  4. Coreboot 4.10 unterstützt mehr Notebooks, Chromebooks, Mainboards und Chips

    Coreboot 4.10 unterstützt mehr Notebooks, Chromebooks, Mainboards und Chips: Coreboot 4.10 erweitert die Hardwarebasis der unterstützten Geräte um weitere Mainboards, Chromebooks, Notebooks und Chips. Zudem wurde im Rahmen...
  5. Leistungsstarkes Tuxedo Notebook mit Nvidia-Grafik

    Leistungsstarkes Tuxedo Notebook mit Nvidia-Grafik: Tuxedo Computers hat mit dem »Tuxedo Book XP1610« ein neues Notebook für Anwender im Angebot, die viel Rechen- und Grafikleistung benötigen....
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden