nginx+php-fpm problem

D

Dosenbier

Mitglied
Moin,

ich hab hier gerade ein Problem und keine Idee mehr woran es liegt.
Ich muss wie schon in der Überschrift erwähnt nginx dazu bringen php auszuliefern.
Das sollt eigentlich mit php-fpm ganz einfach sein.


Allerdings bekomme ich nur eine weiße seite wenn ich ne php site aufrufe.

Code:
user www-data;
worker_processes 4;
pid /run/nginx.pid;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;
}

#mail {
#    # See sample authentication script at:
#    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#    # auth_http localhost/auth.php;
#    # pop3_capabilities "TOP" "USER";
#    # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#    server {
#        listen     localhost:110;
#        protocol   pop3;
#        proxy      on;
#    }
#
#    server {
#        listen     localhost:143;
#        protocol   imap;
#        proxy      on;
#    }
#}

soweit ich die PHP-FPM einfüge geht nichts mehr

Code:
location ~* \.php$ {
    fastcgi_index   index.php;
    fastcgi_pass    127.0.0.1:9000;
    #fastcgi_pass   unix:/var/run/php-fpm/php-fpm.sock;
    include         fastcgi_params;
    fastcgi_param   SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param   SCRIPT_NAME        $fastcgi_script_name;
}

location ~ /\. {
    access_log off;
    log_not_found off;
    deny all;
}
 
M

marce

Kaiser
Was sagen denn die Logfiles?

... und poste mal die komplette Konfig, "die dann nicht tut"
 

Ähnliche Themen

nginx owncloud, php? Problem

nginx+php-fpm nur weiße php sites

Nginx redirect für darkstat

[SOLVED]Linux/W7 Dualboot efi problem

Linux "vergisst" Dateisystem?

Oben