Nach erneutem Login, kein DRI...

Diskutiere Nach erneutem Login, kein DRI... im KDE Forum im Bereich X Window; [GELÖST] ...siehe hier Hallo und schönes Wochende, mein Problem ist, wenn ich mich -in Gentoo/KDE 3.5- erneut anmelde bzw. die Session...

  1. #1 Gentfloo, 16.06.2007
    Zuletzt bearbeitet: 18.06.2007
    Gentfloo

    Gentfloo #470425

    Dabei seit:
    09.05.2007
    Beiträge:
    163
    Zustimmungen:
    0
    Ort:
    Hannover
    [GELÖST] ...siehe hier

    Hallo und schönes Wochende,

    mein Problem ist, wenn ich mich -in Gentoo/KDE 3.5- erneut anmelde bzw. die Session beende und mich mit KDM erneut einlogge,
    gibt "fglrxinfo" nichts gutes aus. --> Ich hab kein DRI.

    Weiss jemand Rat ?

    Danke schonmal für's Lesen.

    glxinfo

    Code:
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
        GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, 
        GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, 
        GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample, 
        GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_multisample
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
    OpenGL extensions:
        GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp, 
        GL_ARB_texture_cube_map, GL_ARB_texture_env_add, 
        GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, 
        GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color, 
        GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add, 
        GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, 
        GL_EXT_texture_lod_bias
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    0x25 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
    0x26 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
    0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
    0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
    0x29 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
    0x2a 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
    0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
    0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
    0x2d  8 pc  0 24  0 c  y  .  0  0  0  0  0 16  0  0  0  0  0  0 0 None
    0x2e  8 gs  0 24  0 c  y  .  0  0  0  0  0 16  0  0  0  0  0  0 0 None
    
    xorg.conf

    Code:
    ## ServerLayout ##
    Section "ServerLayout"
    	Identifier	"Simple Layout"
    	Screen		"Screen"
    	InputDevice	"Mouse1"	"CorePointer"
    	InputDevice	"Keyboard1"	"CoreKeyboard"  
    EndSection
    
    ## Fonts/Files ##
    Section "Files"
            FontPath	"/usr/share/fonts/misc/"
            FontPath	"/usr/share/fonts/Type1/"
            FontPath	"/usr/share/fonts/100dpi/"
            FontPath	"/usr/share/fonts/75dpi/"
    EndSection
    
    ## Module ##
    Section "Module"
    	Load		"dri"
    	Load		"dbe"
    
    	SubSection "extmod"
    		Option	"omit xfree86-dga"
    	EndSubSection
    
    	Load		"freetype"
    EndSection
    
    ## ServerFlags ##
    Section "ServerFlags"
    	Option		"blank time"	"10"
    EndSection
    
    ## Keyboard ##
    Section "InputDevice"
    	Identifier	"Keyboard1"
    	Driver		"kbd"
    	Option		"AutoRepeat"	"500 30"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    EndSection
    
    ## Mouse ##
    Section "InputDevice"
    	Identifier	"Mouse1"
    	Driver		"mouse"
    	Option		"Protocol"	"Auto"	# Auto detect
    	Option		"Device"	"/dev/input/mice"
    	Option		"ZAxisMapping"	"4 5 6 7"
    EndSection
    
    ## Monitor ##
    Section "Monitor"
    	Identifier	"Display"
    	HorizSync	30-69
    	VertRefresh	50-130
    	Option		"DPMS"		"TRUE"
    EndSection
    
    ## Videocard ##
    Section "Device"
    	Identifier	"ATI-Radeon"
    	Driver		"fglrx"
    	Option		"DPMS"		"TRUE"
    	Option		"UseInternalAGPGART"	"no"
    	Option		"AGPMode"	"8"
    	Option		"AGPFastWrite"	"true"
    	Option		"OpenGLOverlay"	"on"
    	Option		"no_accel"	"no"
    	Option		"no_dri"	"no"
    	#Option		"VideoOverlay"	"on"
    	#Option		"backingstore"	"true"
    EndSection
    
    ## Screen ##
    Section "Screen"
    	Identifier	"Screen"
    	Device		"ATI-Radeon"
    	Monitor		"Display"
    	DefaultDepth	24
    
    	Subsection "Display"
    		Depth		8
    		Modes		"1280x1024" "1024x768"
    		ViewPort	0 0
    	EndSubsection
    
    	Subsection "Display"
    		Depth		16
           		Modes		"1280x1024" "1024x768"
    		ViewPort	0 0
    	EndSubsection
    
    	Subsection "Display"
    		Depth		24
    		Modes		"1280x1024" "1024x768"
    		ViewPort	0 0
    	EndSubsection
    EndSection
    
    ## Composite ##
    Section "Extensions"
    	Option	"Composite"	"false"
    EndSection
    
    ## DRI ##
    Section "dri"
    	Mode 0666
    EndSection
    
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Wolfgang, 17.06.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Ein Blick in die Xorg.log ist hier wohl hilfreich.

    Gruß Wolfgang
     
  4. #3 Gentfloo, 17.06.2007
    Zuletzt bearbeitet: 17.06.2007
    Gentfloo

    Gentfloo #470425

    Dabei seit:
    09.05.2007
    Beiträge:
    163
    Zustimmungen:
    0
    Ort:
    Hannover
    Hi danke schonmal für Deinen Aufschluss...

    Okay, hier sind die Logs gleich nach dem erneutem Anmelden:

    # grep "WW" Xorg.0.log

    Code:
           (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    (WW) fglrx: No matching Device section for instance (BusID PCI:4:0:1) found
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled
    (WW) LoadModule: given non-canonical module name "glesx.so"
    (WW) fglrx(0): Option "AGPMode" is not used
    (WW) fglrx(0): Option "AGPFastWrite" is not used
    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    # grep "EE" Xorg.0.log

    Code:
    Current Operating System: Linux comp1-gentoo 2.6.20-gentoo-r8 #4 SMP PREEMPT Sat Jun 16 13:55:51 CEST 2007 i686
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering
    (EE) fglrx(0): Failed to initialize UMM driver.
    (EE) AIGLX: Screen 0 is not DRI capable
    --


    # grep "WW" kdm.log

    Code:
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) fglrx: No matching Device section for instance (BusID PCI:4:0:1) found
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) fglrx: No matching Device section for instance (BusID PCI:4:0:1) found
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    # grep "EE" kdm.log

    Code:
    Current Operating System: Linux comp1-gentoo 2.6.20-gentoo-r8 #4 SMP PREEMPT Sat Jun 16 13:55:51 CEST 2007 i686
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering
    (EE) fglrx(0): Failed to initialize UMM driver.
    (EE) AIGLX: Screen 0 is not DRI capable
    
    Current Operating System: Linux comp1-gentoo 2.6.20-gentoo-r8 #4 SMP PREEMPT Sat Jun 16 13:55:51 CEST 2007 i686
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering
    Ich glaub mir schwärmt da eine Idee, ich glaub man muss die Bus-ID von der Graka angeben,
    um evt. die Graka nicht nur beim Kernelstart ansprechen zu können... mhhh.

    Ach ich weiss es nicht --> werd mal nach den Meldungen in den Logs googeln...

    EDIT

    Also ich werde daraus einfach nicht schlüssig...

    Code:
    ## AIGLX ##
    Section "ServerFlags"
            Option  "AIGLX"         "off"
    EndSection
    Hab ich jetzt auch gesetzt, die Karte läuft mit 8x Geschwindigkeit (laut Kernel-sequenze).

    Ich weiss net mehr weiter... bei Gnome funtzt alles tadellos :(


    EDIT


    NEIN, unter Gnome funzts auch nicht ... aaaaaaaaaaaaaahhhhhhhhhhhhhhh
     
  5. #4 Gentfloo, 18.06.2007
    Gentfloo

    Gentfloo #470425

    Dabei seit:
    09.05.2007
    Beiträge:
    163
    Zustimmungen:
    0
    Ort:
    Hannover
    Juhu ich habs hinbekommen.

    Nach ein weilchen googeln, überflog ich dann doch mal das "ATI HOWTO" in der englischen Gentoo-Wiki.

    Und siehe da, diese Option hat geholfen :)

     
  6. Anzeige

    Vielleicht findest du in dieser Kategorie etwas passendes.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Nach erneutem Login, kein DRI...

Die Seite wird geladen...

Nach erneutem Login, kein DRI... - Ähnliche Themen

  1. Bootprobelem nach Installtion von obrevenge

    Bootprobelem nach Installtion von obrevenge: [gelöst]Hallo ich habe ein blödes Problem, das m.W. schon mehrfach bei Installationen (afaik nur bei Arch) von einer HDD installation per Livecd...
  2. Meldung nach initramfs update

    Meldung nach initramfs update: Hallo Was bedeutet die folgende Meldung nach einem initramfs update ---------- I: The initramfs will attempt to resume from /dev/sda15 I:...
  3. Keine Benachrichtigungen im Vollbild Modus

    Keine Benachrichtigungen im Vollbild Modus: Arch Linux Plasma 5.8 Weiss einer ob das gehen sollte, bzw kann mal einer testen ob es bei ihm geht, gerne auch mit anderen kde/plasma versionen....
  4. SRV Records nicht erstellt nach dcpromo

    SRV Records nicht erstellt nach dcpromo: Hallo zusammen, leider sind beim Join meines 2. DC in eine Samba 4 Domäne die SRV-DNS Records nicht erstellt worden... Hatte jemand schonmal das...
  5. CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot

    CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot: Hallo zusammen Ich möchte unseren existierenden SFTP Server durch einen neuen Server mit CentOS 7 ersetzen. Da der Server einerseits direkt via...