libGLcore , oder auch das Problem mit NVidia

DaSPi

daspi is daspi
Beiträge
57
Hallo. so, für das jetzt kommende problem habe ich etwas länger recherchieren müssen, um überhaupt zu verstehen was sache ist.
Um das problem erts mal kurz zusammen zu fassen: ich habe andauernd ein problem mit der datei libGLcore.so.x.x.x. immer wenn ich mir ein rpm installieren will, das anscheinend diese datei (libGLcore gehört zum NVidida Treiber-Packet) für die grafische Oberfäche (z.B. bei kgpg, knetscan o.ä.) brauch, sagt der rpm manager das er ein depend. problem hat, obwohl die datei an ihrem rechtmäßigen platz (/usr/lib/libGLcore.so.1.0.4363) ist. So wie es aussieht haben im Internet auch viele andere Leute Probleme mit dieser Datei. Lösungsvorschläge lassen jedoch auf sich warten, oder ich habe keine Gefunden. Das Problem besteht jetzt "irgendwie" darin, das mehre Softlinks im Verzeichnis /usr/X11R6/lib/modules/extensions/ anscheinend auf die falsche libGLcorexxx im Ordner /usr/lib/ oder so ähnlich verweisen. Hier gingen die Meinungen auseinander, leider.

Neues NVidia-FAQ für 2.75: Das NVidia-Treiber-Paket wird automatisch installiert in 2.75. Als root:
- Erstellen Sie ein Verzeichnis, das Dateien aufnehmen soll, die Sie verschieben werden:
mkdir /root/XFREE86.BACKUP
- Kopieren Sie die Dateien /usr/lib/libGL.so, /usr/lib/libGL.so.1 und /usr/lib/libGL.so.1.2.030402 nach /root/XFREE86.BACKUP.
- Kopieren Sie die Dateien /usr/X11R6/lib/modules/extensions/libGLcore.a und /usr/X11R6/lib/modules/extensions/libglx.a nach /root/XFREE86.BACKUP.
- Benennen Sie die Dateien mit der Endung .NVIDIA in /usr/X11R6/lib und /usr/X11R6/lib/modules/extensions um, indem Sie die Endung .NVIDIA entfernen.
- Ändern Sie die Symlinks /usr/X11R6/lib/libGL.so und /usr/X11R6/lib/libGL.so.1 damit sie auf /usr/X11R6/lib/libGL.so.1.0.2880 zeigen.
- Ändern Sie die Symlinks /usr/X11R6/lib/libGLcore.so und /usr/X11R6/lib/libGLcore.so.1 damit sie auf /usr/X11R6/lib/libGLcore.so.1.0.2880 zeigen.
- Ändern Sie die Symlinks /usr/X11R6/lib/modules/extensions/libglx.so und /usr/X11R6/lib/modules/extensions/libglx.so.1 damit sie auf /usr/X11R6/lib/modules/extensions/libglx.so.1.0.2880 zeigen.
- ldconfig ausführen.
- Editieren Sie die Konfigurationsdatei /etc/X11/XF86Config und ersetzen Sie Driver "nv" durch Driver "nvidia". Sie können den Konfig-Manager dazu nicht benutzen! Und auch noch Zeile 30 auskommentieren: #Load "dri".
- Ausloggen und gleichzeitig STRG + ALT + BACKSPACE drücken um X neu zu starten

Die Datei im Verzeichnis /usr/X11R6/lib/modules/extension liglx.so ist bei mir auch passenverlinkt, aber in diesem Verzeichnis habe ich KEINE libGLcore.so.1! Is das der Fehler?


Kann jemand helden? Aber bitte nur ernsthat, und nicht so like: "--force --nodeps Method" => ich weiß, es gibt heir gar keine rpm Packete, sollte nur son Vergleich sein ;-)






Systeminfos:
Distri: Red Hat 9
Grafikkarte: Hercules GeForce GTS PRO II
Treiber:Linux IA32 v. 1.0-4363
für Linux Suse/RedHat/Mandrake
 

Belkira

Routinier
Beiträge
255
Um das problem erts mal kurz zusammen zu fassen: ich habe andauernd ein problem mit der datei libGLcore.so.x.x.x. immer wenn ich mir ein rpm installieren will, das anscheinend diese datei (libGLcore gehört zum NVidida Treiber-Packet) für die grafische Oberfäche (z.B. bei kgpg, knetscan o.ä.) brauch, sagt der rpm manager das er ein depend. problem hat, obwohl die datei an ihrem rechtmä�igen platz (/usr/lib/libGLcore.so.1.0.4363) ist.
So? Na, dann zeig doch mal: rpm -qf /usr/lib/libGLcore.so.1.0.4363
 

DaSPi

daspi is daspi
Beiträge
57
wenn ich das ausführe, kommt kein ergebnis, als ob er sich aufhängen würde. Wieso das??
 

DaSPi

daspi is daspi
Beiträge
57
muss gerade mall das mit den umlauten ändern....
aber was soll ich jetzt machen, da er mir keine ausgabe bei dem befehl gibt??
 

DaSPi

daspi is daspi
Beiträge
57
lol: die Datei »/usr/lib/libGLcore.so.1.0.4363« gehört zu keinem Paket. warum steht dann ÜBERALL das diese datei zum nvidia packet gehört??
 

Belkira

Routinier
Beiträge
255
Das hatte ich vermutet.

Was Du nicht als RPM Paket installierst, wird auch nicht in der RPM Datenbank verankert. Darum weiß "rpm" nicht über die vorhandenen Dateien bescheid und berücksichtigt sie auch nicht bei der Auflösung von Abhängigkeiten.
 

DaSPi

daspi is daspi
Beiträge
57
das bedeutet dann doch, das ich dieses programm NICHT als RPM installieren kann, sondern mir die sources ziehen muss? oder kennst du ne andere möglichkeit
 

Belkira

Routinier
Beiträge
255
Wenn Du 100%-ig weißt, daß die geforderten Dateien auf Deinem System existieren und nur dann, installiere mit --nodeps (nicht mit --force!).

Alternativ schau Dir an, wie man RPM Pakete erstellt. :)
 

DaSPi

daspi is daspi
Beiträge
57
nun gut, dann lieber mit nodeps als nen rpm packet erstellen. vielen dank für die hilfe.
 

Ähnliche Themen

X startet nichtmehr

xserver startet nicht: no screens

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

Displayport + externer Monitor zeigt bei startx nichts erst bei DVI

verzeichniss suche funktioniert nicht

Oben