HDMI Soundausgabe 2

F

flammenflitzer

Routinier
Hallo,
ich habe jetzt meinen Rechner aufgerüstet. Jetzt mit HDMI Ausgang. Der funktioniert allerdings nur unter WindowsXP.
flammenflitzer olaf # uname -r
Code:
3.0.6-gentoo
flammenflitzer olaf # lspci | grep Audio
Code:
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
01:00.1 Audio device: nVidia Corporation Device 0e0c (rev a1)
flammenflitzer olaf # cat /proc/asound/cards
Code:
 0 [SAA7134        ]: SAA7134 - SAA7134
                      saa7134[0] at 0xefdff000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xefff0000 irq 20
 2 [NVidia_1       ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xedffc000 irq 16
Grafikkarte
Code:
 nVidia GeForce GTX560 Ti
flammenflitzer olaf # aplay -l
Code:
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 1: NVidia [HDA NVidia], Gerät 0: ALC888 Analog [ALC888 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 1: NVidia [HDA NVidia], Gerät 1: ALC888 Digital [ALC888 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 7: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 8: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 9: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
flammenflitzer linux # cat /usr/src/linux/.config | grep SND | grep -v \#
Code:
CONFIG_SND=y
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=
flammenflitzer olaf # lsmod | grep snd
Code:
snd_seq_dummy           1566  0 
snd_seq_oss            24382  0 
snd_seq_midi_event      5756  1 snd_seq_oss
snd_seq                44361  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5453  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            31178  0 
snd_mixer_oss          12805  1 snd_pcm_oss
snd_hda_codec_hdmi     21098  4 
snd_hda_codec_realtek   300931  1 
snd_hda_intel          21962  4 
snd_hda_codec          73076  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5638  1 snd_hda_codec
snd_pcm                65136  6 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,saa7134_alsa,snd_hda_codec
snd_timer              18677  2 snd_seq,snd_pcm
snd_page_alloc          7002  2 snd_hda_intel,snd_pcm
Nachladen der anderen Module bringt nichts
Code:
flammenflitzer olaf # modprobe snd-hda-codec-realtek
flammenflitzer olaf # lsmod | grep snd-hda-codec-realtek
flammenflitzer olaf # modprobe snd-hda-codec-analog
flammenflitzer olaf # modprobe snd-hda-codec-idt
flammenflitzer olaf # modprobe snd-hda-codec-via
flammenflitzer olaf # modprobe snd-hda-codec-hdmi
flammenflitzer olaf # modprobe snd-hda-codec-cirrus
flammenflitzer olaf # modprobe snd-hda-codec-conexant
flammenflitzer olaf # modprobe snd-hda-codec-ca0110
flammenflitzer olaf # modprobe snd-hda-codec-cmedia
flammenflitzer olaf # modprobe snd-hda-codec-si3054
flammenflitzer linux # lsmod | grep snd
Code:
snd_hda_codec_si3054     3432  0 
snd_hda_codec_cmedia     8228  0 
snd_hda_codec_ca0110     5481  0 
snd_hda_codec_conexant    45002  0 
snd_hda_codec_cirrus    10205  0 
snd_hda_codec_via      53574  0 
snd_hda_codec_idt      54732  0 
snd_hda_codec_analog    80473  0 
snd_seq_dummy           1566  0 
snd_seq_oss            24382  0 
snd_seq_midi_event      5756  1 snd_seq_oss
snd_seq                44361  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5453  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            31178  0 
snd_mixer_oss          12805  1 snd_pcm_oss
snd_hda_codec_hdmi     21098  4 
snd_hda_codec_realtek   300931  1 
snd_hda_intel          21962  4 
snd_hda_codec          73076  11 snd_hda_codec_si3054,snd_hda_codec_cmedia,snd_hda_codec_ca0110,snd_hda_codec_conexant,
snd_hda_codec_cirrus,snd_hda_codec_via,snd_hda_codec_idt,snd_hda_codec_analog,snd_hda_codec_hdmi,snd_hda_codec_realtek,
snd_hda_intel
snd_hwdep               5638  1 snd_hda_codec
snd_pcm                65136  7 snd_hda_codec_si3054,snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,saa7134_alsa,snd_hda_codec
snd_timer              18677  2 snd_seq,snd_pcm
snd_page_alloc          7002  2 snd_hda_intel,snd_pcm
alsa lässt sich nicht konfigurieren
flammenflitzer olaf #alsaconf
Code:
No supported PnP or PCI card found
...
No legacy drivers are avaiable
Code:
flammenflitzer olaf # cat /etc/modprobe.d/alsa.conf
cat: /etc/modprobe.d/alsa.conf: Datei oder Verzeichnis nicht gefunden
In /etc/make.conf ist USE=" ...pulseaudio ..." gesetzt. kde 4.7.3. Weitere Software
Code:
[ebuild   R   ~] media-sound/pulseaudio-1.1  USE="X alsa asyncns avahi caps dbus equalizer glib ipv6 libsamplerate lirc orc tcpd udev -bluetooth -doc -gnome -jack (-oss) -realtime (-system-wide) -test" 0 kB                
[ebuild   R    ] media-plugins/gst-plugins-pulse-0.10.30  0 kB
[ebuild   R   ~] media-libs/phonon-4.5.1-r1  USE="gstreamer pulseaudio (-aqua) -debug -vlc -xine" 0 kB
[ebuild   R   ~] media-libs/phonon-gstreamer-4.5.1  USE="alsa -debug" 0 kB
[ebuild   R   ~] kde-base/phonon-kde-4.7.3  USE="alsa pulseaudio (-aqua) -debug (-kdeenablefinal) -xine" 0 kB
Wird die Ausgabe von cat /etc/asound.state benötigt?
Ich weiß nicht, ob das eine Rolle spielt? Die Bildschirme sind konfiguriert als separate Monitore. xorg.conf kann ich bei Bedarf posten.
 
A

Anzeige

Ähnliche Themen

Ethernet wird nicht erkannt

HDMI Soundausgabe

HDMI Audio macht Probleme

OpenSuse 12.3 / Tiefschlaf funktioniert nicht

Hab da noch eine kleines Soundprqoblem

Oben