Ein vermutlich größeres Problem

embro

Mitglied
Beiträge
25
Ein vermutlich größeres Problem (gelöst)

Hallo,

ich habe gerade etwas dummes getan und kann nun nicht mehr Gentoo starten.

Folgendes ist passiert: Ich wollte eine größere Menge Daten nach /mnt/transfer verschieben. Vorher habe ich /dev/hdb6 als ext3 formatiert. Intelligenterweise habe ich aber vor dem Kopieren vergessen, /dev/hdb6 auf /mnt/transfer zu mounten, wie ich es vorhatte. Das Verzeichnis /mnt/transfer existierte aber schon...

Nun wurden also die Daten auf /dev/hda3 verschoben, welches meine Root Partition ist. Die war nur leider zu klein dafür und nun ist sie voll...

Wenn ich jetzt Gentoo starten will, bekomme ich folgende Meldung:

(...)
Configuring system to use udev...
Populating /dev with device nodes...
/sbin/rc: line 24: cannot redirect standard input from /dev/null: No such file or directory

The "tar" command failed with error:

Compressed file ends unexpectedly:
perhaps it is corrupted? *Possible* reason follows.
bzip2: Inappropriate ioctl for device
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted. You can use the -tvv option to test the integrity of such files.

You can use the `bzip2recover' program to attempt to recover data from undamaged sections of corrupted files.

tar: Child returned status 2
tar: Error exit delayed from previous errors

Since this is a critical task, startup cannot continue.

/dev/console: No such file or directory

Anschliessend kann ich das root Passswort eingeben... Aber dann weiß ich nicht weiter, wie ich mein System wieder hinkriege. Ich will nur wieder Gentoo booten können und das ohne Datenverlust auf anderen Partitionen. Die Daten, die ich verschoben habe sind nicht so wichtig. Allerdings habe ich auf anderen Partitionen, die mit der Geschichte an sich nichts zu tun haben, wichtige Daten. Aber denen sollte ja eigtl. nichts passiert sein.

Ich bitte dringend um Eure Hilfe :hilfe2:
 
Zuletzt bearbeitet:

DennisM

Moderator u. Newsposter
Beiträge
4.883
Kannst du /dev/hda3 mounten?
Wenn ja könntest du ja die überflüssigen Dateien löschen um wieder Platz auf der Platte zu bekommen. Ansonsten sehe ich schwarz.

MFG

Dennis
 

DennisM

Moderator u. Newsposter
Beiträge
4.883
Wie das hast du noch nie gemacht, das musst du uns jetzt mal erklären.

MFG

Dennis
 

name

Inactive user
Beiträge
592
embro schrieb:
Danke... Hab schon angefangen andere Foren mit meinem Problem zu belästigen, aber hier die erste Antwort :D

Hab ich noch nie gemacht, daher frag ich lieber vorher nach, bevor noch mehr schiefgeht...

Einfach mit Schritt 6 der Installtionsanleitung anfangen, oder wie?
http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?part=1&chap=6
live-cd rein, mount /dev/hda3 /mnt/gentoo && chroot /mnt/gentoo
dann env-update und alles loeschen
alles ueberflussige meinte ich natuerlich
 
Zuletzt bearbeitet:

DennisM

Moderator u. Newsposter
Beiträge
4.883
Du hast "mount -t proc none /mnt/gentoo/proc" vergessen :P

So ist's richtig: mount /dev/hda3 /mnt/gentoo && mount -t proc none /mnt/gentoo/proc && chroot /mnt/gentoo /bin/bash

MFG

Dennis
 

name

Inactive user
Beiträge
592
11dennis schrieb:
Du hast "mount -t proc none /mnt/gentoo/proc" vergessen :P

So ist's richtig: mount /dev/hda3 /mnt/gentoo && mount -t proc none /mnt/gentoo/proc && chroot /mnt/gentoo /bin/bash

MFG

Dennis
für was braucht er bitte zum löschen n proc fs?
 

DennisM

Moderator u. Newsposter
Beiträge
4.883
Hallo? /dev/hda3 ist seine Root Partition,soweit ich das verstanden habe, will er die doch gar nicht komplett löschen, sondern nur die überflüssigen Daten.

MFG

Dennis
 

name

Inactive user
Beiträge
592
11dennis schrieb:
Hallo? /dev/hda3 ist seine Root Partition,soweit ich das verstanden habe, will er die doch gar nicht komplett löschen, sondern nur die überflüssigen Daten.

MFG

Dennis
Alles löschen war vlt. etwas falsch formuliert :), das meinte ich natürlich eh ...
 

embro

Mitglied
Beiträge
25
Danke an euch, aber das ganze war doch wesentlich einfacher zu lösen :)

Ich hab in der /etc/conf.d/rc folgende Option auf "no" gesetzt:

Code:
# UDEV OPTION: 
# Set to "yes" if you want to save /dev to a tarball on shutdown 
# and restore it on startup.  This is useful if you have a lot of 
# custom device nodes that udev does not handle/know about. 

RC_DEVICE_TARBALL="no"

Den Inhalt von /mnt/transfer auf ne andere Partition verschoben und neu gestartet... Auf der root Partition ist nun wieder genügend Platz und die Datein sind auch noch da... Dann hab ich die Option wieder auf "yes" gesetzt und nochmal neu gestartet. Alles funzt.

Trotzdem vielen Dank
 

DennisM

Moderator u. Newsposter
Beiträge
4.883
Jop kein Problem, aber ist ja logisch, dass es nun wieder funktioniert. Hätte ich mal drauf kommen müssen :P

MFG

Dennis
 

Ähnliche Themen

Ich mag Dovecot nicht ...

X startet nichtmehr

MySQL startet nicht mehr

xrandr: cant open display

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

Oben