Anfänger: Internet Routen, aber wie?

Archmage

Grünschnabel
Beiträge
4
Hallo,

es tut mir leid, wenn ich euch mit einer Newbie Frage belästige, aber ich bin da jetzt schon eine Woche dran und kenne alle verfügbare HOWTOs schon fast auswendig, komme aber nicht weiter.

Ich habe drei Rechner und einem T-DSL-Anschluss. Zwei Debian ein Windows XP.

Ich habe auf den einen Windows XP drauf und habe den mal eine Zeit als Router verwendet, was ohne Probleme läuft. Jetzt will ich aber über Debian routen, weil das sowieso 24/7 an ist und ich mein XP-Rechner auch mal herunterfahren möchte.

Mein Debian-Rechner würde ich so beschreiben:

Debian 3.0 (immer mit apt-get auf dem neusten Stand), aktueller 2.4 Kernel, ZWEI unterschiedliche Netzwerkkarten.

Ich habe schon länger gekämpft und bin zu folgenden Ergebnis gekommen:

Beide Netzwerkkarte sind konfiguriert.

eth0 ist am T-DSL-Modem, hat IP-Adresse 192.168.10.1
eth1 hat IP-Adresse 192.168.0.1

Auf dem Gerät kann ich ins Internet

Pingen an 192.168.10.1, 192.168.0.1, 192.168.0.2 oder 192.168.0.3 (die anderen Rechner) und an die IP-Adresse, die mir T-Online gibt funktioniert.

Pingen externer Adressen (z.B. ping t-online.de) geht NICHT . ?(

Auf die anderen kommeich aber nicht ins Internet.

Pingen an 192.168.10.1, 192.168.0.1, 192.168.0.2 oder 192.168.0.3 und an die IP-Adresse, die T-Online dem anderen Rechner gibt funktioniert.

Pingen externer Adressen (z.B. ping t-online.de) geht NICHT . ?(

Kann sich jemand mal die Zeit nehmen und mit mir die möglichen Fehlerquellen durchgehen? Die HOWTOs sind alle bis zu den Punkt wo ich immer scheitere zwar sehr informativ, aber dann hört es auf.

Genau dann, wenn es darum geht die Pakete zu forwarden kappiere ich nicht mehr, was gemacht werden soll und ich gebe nur noch blind IPTABLES-Befehle ein, die alles weiterleiten sollen, aber trotzdem nicht funktionieren. :(
 

danielgoehl

Lehrling
Beiträge
96
erstmal kurz

Hi,

hier erstmal ein paar Fragen um genau zu wissen welchen Stand dein System ist.

Hast du über deinen T-DSL bereits eine Internetverbindung aufgebaut?? Ich mein kannst du mit deiner Debian Box Internetseiten ansehen?

Hast du das IP-Forwarding aktiviert??

Hast du entweder einen DNS-Server aufgestzt oder den T-Online DNS Server in der /etc/resolv.conf eingetragen??

Dann als letztes, hast du das Masquerading über die iptables aktiviert??
Das tust du mit

iptables -t nat -A POSTROUTING -o ppp0 -s 192.168.0.0/24 -j MASQUERADE

So ich hoffe ich konnte/kann dir noch helfen. Meld Dich einfach und dann klappt das schon!!

Gruß Daniel
 

Archmage

Grünschnabel
Beiträge
4
Ich hatte den DNS-Server in den anderen Boxen vergessen. Besten Dank für deine schnelle und ausführliche Hilfe. :)

Manchmal fehlt uns nur eine Kleinigkeit.

Danke noch einmal und jetzt feier ich erst einmal eine kleine Party.
 

Ähnliche Themen

Suse10.2 FRITZ!WLANUSB

Zweite Route will nicht

Debian als Gateway

Suse durchs Windows-Netzwerk ins Internet

ubuntu als router für mehrere rechner?

Oben