XServer startet nach Installation NVIDIA-Treiber nicht mehr

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Plinzen, 11.04.2007.

  1. #1 Plinzen, 11.04.2007
    Plinzen

    Plinzen Foren As

    Dabei seit:
    11.04.2007
    Beiträge:
    96
    Zustimmungen:
    0
    Hallo,

    muss gestehen ich bin Linux-Neuling und hab nicht unbedingt viel Plan.

    Hab mir auf meinem Rechner
    - AMD64 X2 4600
    - NVIDIA Geforce 7900GS
    openSuse 10.2 installiert.
    Kernel 2.6.18.2-34-default

    Danach habe ich ueber yast die NVIDIA-Treiber von download/nvidia.com/opensuse10.2 installiert. Dies waren folgende Pakete.
    - nvidia-gfx-kmp-default
    - x11-video-nvidia
    danach habe ich noch sax2 -r aufgerufen und den PC neu gebootet.

    Beim Start des X-Servers kommt ne Meldung in der Art No Device found oder so. Im Log steht am Ende folgendes.
    Code:
    	[47] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[48] -1	0	0x00001c40 - 0x00001c7f (0x40) IX[B]
    	[49] -1	0	0x00001c00 - 0x00001c3f (0x40) IX[B]
    	[50] -1	0	0x0000fc00 - 0x0000fc3f (0x40) IX[B]
    	[51] -1	0	0x00009c00 - 0x00009c7f (0x80) IX[B](B)
    	[52] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
    	[53] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
    (II) Setting vga for screen 0.
    (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    (==) NVIDIA(0): RGB weight 888
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) NVIDIA(0): Enabling RENDER acceleration
    (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
    (EE) NVIDIA(0):  *** Aborting ***
    (II) UnloadModule: "nvidia"
    (II) UnloadModule: "ramdac"
    (II) UnloadModule: "fb"
    (EE) Screen(s) found, but none have a usable configuration.
    
    Hoff es kann mir jemand weiterhelfen. Falls noch weiter Infos benoetigt werden, bitte melden.

    Danke schonmal
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
  4. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Mach mal in der xorg.conf aus "nvidia" wieder "nv", dann sollte zumindest der X-Server wieder starten^^
    Haste auch den "alternativen" Weg aus der Nvidia-Beschreibung probiert?

    Ich hatte heute unter Kubuntu denselben Fehler, und bei mir langs an http://wiki.unixboard.de/index.php/NVIDIA_und_Xorg7
     
  5. obec

    obec Foren As

    Dabei seit:
    02.07.2006
    Beiträge:
    86
    Zustimmungen:
    0
    Hi,

    spiel das mal durch; danach den nvidia-Treiber neuinstallieren.

    STRG+ALT+F2

    Einloggen als root
    Passwort eingeben

    Code:
    init 3
    In den dritten Runlevel wechseln

    Einloggen als root
    Passwort eingeben

    Code:
    sax2 -a
    Code:
    switch2nv
    Code:
    init 5
    Wieder in die grafische Oberfläche eingeloggen.

    Gruß

    obec
     
  6. #5 Plinzen, 12.04.2007
    Zuletzt bearbeitet: 12.04.2007
    Plinzen

    Plinzen Foren As

    Dabei seit:
    11.04.2007
    Beiträge:
    96
    Zustimmungen:
    0
    Treiberinstallation

    Hi,

    also der X-Server startet jetzt wieder, leider ohne 3D-Beschleunigung. Deshalb möchte ich jetzt trotzdem den nvidia-Treiber installieren. Habs jetzt "manuell" versucht.
    - Konsole
    - root anmelden
    - init 3
    - sh NVIDIA-Linux-x86_64-1.0-9755-pkg2.run -q

    Folgende Ausgabe im Log:
    Code:
    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Thu Apr 12 20:58:06 2007
    
    option status:
      license pre-accepted    : false
      update                  : false
      force update            : false
      expert                  : false
      uninstall               : false
      driver info             : false
      precompiled interfaces  : true
      no ncurses color        : false
      query latest version    : false
      OpenGL header files     : true
      no questions            : true
      silent                  : false
      no recursion            : false
      no backup               : false
      kernel module only      : false
      sanity                  : false
      add this kernel         : false
      no runlevel check       : false
      no network              : false
      no ABI note             : false
      no RPMs                 : false
      no kernel module        : false
      force SELinux           : default
      no X server check       : false
      force tls               : (not specified)
      force compat32 tls      : (not specified)
      X install prefix        : (not specified)
      X library install path  : (not specified)
      X module install path   : (not specified)
      OpenGL install prefix   : (not specified)
      OpenGL install libdir   : (not specified)
      compat32 install chroot : (not specified)
      compat32 install prefix : (not specified)
      compat32 install libdir : (not specified)
      utility install prefix  : (not specified)
      utility install libdir  : (not specified)
      doc install prefix      : (not specified)
      kernel name             : (not specified)
      kernel include path     : (not specified)
      kernel source path      : (not specified)
      kernel output path      : (not specified)
      kernel install path     : (not specified)
      proc mount point        : /proc
      ui                      : (not specified)
      tmpdir                  : /tmp
      ftp mirror              : ftp://download.nvidia.com
      RPM file list           : (not specified)
    
    Using: nvidia-installer ncurses user interface
    -> License accepted.
    -> No precompiled kernel interface was found to match your kernel; would you li
       ke the installer to attempt to download a kernel interface for your kernel f
       rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
    -> No matching precompiled kernel interface was found on the NVIDIA ftp site;
       this means that the installer will need to compile a kernel interface for
       your kernel.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    ERROR: The kernel header file
           '/lib/modules/2.6.18.2-34-default/build/include/linux/kernel.h' does not
           exist.  The most likely reason for this is that the kernel source path
           '/lib/modules/2.6.18.2-34-default/build' is incorrect.  Please make sure
           you have installed the kernel source files for your kernel and that they
           are properly configured; on Red Hat Linux systems, for example, be sure
           you have the 'kernel-source' or 'kernel-devel' RPM installed.  If you
           know the correct kernel source files are installed, you may specify the
           kernel source path with the '--kernel-source-path' command line option.
    ERROR: Installation has failed.  Please see the file
           '/var/log/nvidia-installer.log' for details.  You may find suggestions
           on fixing installation problems in the README available on the Linux
           driver download page at www.nvidia.com.
    
    Laut Yast habe ich die kernel-header installiert. Nur stehen die dummerweise unter /usr/include ??? Warum auch immer?!

    wenn ich sh NVIDIA-Linux-x86_64-1.0-9755-pkg2.run --kernel-source-path=/usr eingebe erhalte ich die Meldung, dass der kernel-source-path ungültig ist.

    Jetzt weiß ich nicht mehr weiter...

    Das openSuse System habe ich heut nocheinmal von DVD frisch installiert und noch keine Onlineupdates durchgeführt.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Noch ein Nachtrag.

    Es gibt zwar das Verzeichnis /lib/modules/2.6.18.2-34-default/build
    allerdings ist darin lediglich eine Datei "Module.symvers" enthalten.
     
  7. rasade

    rasade Eroberer

    Dabei seit:
    22.03.2004
    Beiträge:
    71
    Zustimmungen:
    0
    Ort:
    Runkel
    NVIDIA-Linux-x86_64-1.0-9755-pkg2.run --kernel-source-path=/usr eingebe erhalte ich die Meldung, dass der kernel-source-path ungültig ist.

    Hallo habe vor ein paar Wochen den Treiber (für einen Bekannten SuSE 10.2) auf einem Vaio installiert - meine keinen Pfad übergeben zu haben.
    ... Source liegt in /usr/src/...

    Gruß
     
  8. #7 Plinzen, 12.04.2007
    Plinzen

    Plinzen Foren As

    Dabei seit:
    11.04.2007
    Beiträge:
    96
    Zustimmungen:
    0
    Ja da gibts bei mir auch das Verzeichnis "/usr/src/linux-2.6.18.2-34-obj/x86_64/default"
    Auf dieses Verzeichnis wird auch von "/lib/modules/2.6.18.2-34-default/build" aus gelinkt. Also der Ordner build linkt auf das erst genannte Verzeichnis. Nur leider steht in diesem nur die Datei "Module.symvers" :hilfe2: :hilfe2:
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Plinzen, 13.04.2007
    Plinzen

    Plinzen Foren As

    Dabei seit:
    11.04.2007
    Beiträge:
    96
    Zustimmungen:
    0
    Hi,

    also hab soeben geschafft den Nvidia-Treiber zu installieren. Folgende Dinge musste ich allerdings anders machen als in der Beschreibung von nvidia.com:

    1. Installation der Linux-Kernel-Sourcen: Es hat nicht gereicht die Linux-Header zu installieren. Ich hab dann die Sourcen installiert und danach ließ sich der Treiber endlich installieren! :D :D :D

    2. anstatt
    Code:
    sax2 -r -m 0=nvidia
    habe ich irgendwann einfach
    Code:
    nvidia-xconfig
    probiert. Und siehe dann, jetzt läuft das System.

    Freude über Freude!
    So Java und Eclipse laufen schon, jetzt brauch ich nur noch Apache, Tomcat und nen guten Editor.
     
  11. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Nano für den Anfang, vi wenn du mehr Erfahrung hast

    für grafische Sachen Kate oder K/Gwrite die haben eine sehr gute Syntaxmarkierung
     
Thema: XServer startet nach Installation NVIDIA-Treiber nicht mehr
Besucher kamen mit folgenden Suchen
  1. debian startet nicht nvidea

    ,
  2. opensuse xserver startet nicht

Die Seite wird geladen...

XServer startet nach Installation NVIDIA-Treiber nicht mehr - Ähnliche Themen

  1. xserver startet nicht: no screens

    xserver startet nicht: no screens: Hallo Hab wohl bei einem meiner Debian-Sid System den xserver zerschossen. Screens not found. nvidia-kernel-dkms ist instaliert,...
  2. XServer startet nach fglrx installation nicht mehr

    XServer startet nach fglrx installation nicht mehr: OS: Ubuntu Jaunty Jackalope 9.04 64bit Notebook: A8JP C2D 2Ghz 2GB, ATI X1700 Problem: Nach dem Grub Loader kommen nur Grafikfehler und das...
  3. xserver startet nicht mehr

    xserver startet nicht mehr: Hallo ich habe wiedereinmal ein Problem was ich nicht alleine beheben kann. mein xserver startet nicht mehr, und ich komme nur noch in den...
  4. Xserver startet nicht nach Ubuntuinstallation

    Xserver startet nicht nach Ubuntuinstallation: Hallo zusammen habe heute versucht auf meinem Notebook Ubuntu zu installieren. Leider hat es nicht funktioniert weil wahrscheinlich keine Treiber...
  5. Xserver startet nach Nvidia updat nimmer

    Xserver startet nach Nvidia updat nimmer: Hallo hab hier gerade übelstes Grandos problemos :-I Hab gerade die neuen NVIDIA Treiber für die GraKa drauf gezogen, doch jetzt will der...