Xorg probleme mit Maus und Tastertur

Dieses Thema: "Xorg probleme mit Maus und Tastertur" im Forum "Arch Linux" wurde erstellt von Da1, 07.02.2009.

  1. Da1

    Da1 Jungspund

    Dabei seit:
    11.10.2008
    Beiträge:
    16
    Zustimmungen:
    0
    Hi
    ich hab Xorg mit pacman draufgemacht. Füher hat das immer ganz gut funktioniert aber irgentwie wird die Maus und die Tastertur nicht erkannt
    d.h. wenn ich xorg durch startx starte kann ich die weder Maus nicht bewgen noch werden Tastertureingaben angenommen.
    Ich habe hier mal 2 conf's gepostet obwohl ich weis das es daran nicht liegt.Wo muss ich denn die treiber eintragen wenn sie nicht automatisch erkannt werden bezw. wie kann ich das Problem beheben? ich hab Xorg zum zweiten mal "gemacht" also ein fehler ist es nicht.

    /etc/rc.conf
    PHP:
    #
    # /etc/rc.conf - Main Configuration for Arch Linux
    #

    # -----------------------------------------------------------------------
    # LOCALIZATION
    # -----------------------------------------------------------------------
    #
    # LOCALE: available languages can be listed with the 'locale -a' command
    # HARDWARECLOCK: set to "UTC" or "localtime"
    # USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
    # TIMEZONE: timezones are found in /usr/share/zoneinfo
    # KEYMAP: keymaps are found in /usr/share/kbd/keymaps
    # CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
    # CONSOLEMAP: found in /usr/share/kbd/consoletrans
    # USECOLOR: use ANSI color sequences in startup messages
    #
    LOCALE="de_DE.utf8"
    HARDWARECLOCK="localtime"
    USEDIRECTISA="yes"
    TIMEZONE="Europe/Berlin"
    KEYMAP="de-latin1-nodeadkeys"
    CONSOLEFONT="default8x16"
    CONSOLEMAP=
    USECOLOR="yes" 
    #

    # -----------------------------------------------------------------------
    # HARDWARE
    # -----------------------------------------------------------------------
    #
    # MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
    # MOD_BLACKLIST: Prevent udev from loading these modules
    # MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
    #
    # NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
    #
    MOD_AUTOLOAD="yes"
    #MOD_BLACKLIST=() #deprecated
    MODULES=(8139cp 8139too mii slhc ac97_bus snd-mixer-oss snd-pcm-oss snd-seq-oss snd-seq-device snd-seq-midi-event snd-seq snd-hwdep snd-page-alloc snd-pcm snd-rawmidi snd-timer snd snd-mpu401-uart snd-opl3-lib snd-ac97-codec snd-azt3328 snd-intel8x0 soundcore)

    # Scan for LVM volume groups at startup, required if you use LVM
    USELVM="no"

    # -----------------------------------------------------------------------
    # NETWORKING
    # -----------------------------------------------------------------------
    #
    # HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
    #
    HOSTNAME="myhost"

    # Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
    #
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES
    #   - prefix an entry in INTERFACES with a ! to disable it
    #   - no hyphens in your interface names - Bash doesn't like it

    # DHCP:     Set your interface to "dhcp" (eth0="dhcp")
    # Wireless: See network profiles below
    #
    eth0="dhcp"
    INTERFACES=(eth0)

    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(!gateway)
     
    # Enable these network profiles at boot-up.  These are only useful
    # if you happen to need multiple network configurations (ie, laptop users)
    #   - set to 'menu' to present a menu during boot-up (dialog package required)
    #   - prefix an entry with a ! to disable it
    #
    # Network profiles are found in /etc/network.d
    #
    # This now requires the netcfg package
    #
    #NETWORKS=(main)

    # -----------------------------------------------------------------------
    # DAEMONS
    # -----------------------------------------------------------------------
    #
    # Daemons to start at boot-up (in this order)
    #   - prefix a daemon with a ! to disable it
    #   - prefix a daemon with a @ to start it up in the background
    #
    DAEMONS=(syslog-ng network netfs crond)


        
    /etc/x11/xorg.conf
    PHP:
    Section "ServerLayout"
        
    Identifier     "X.org Configured"
        
    Screen      0  "Screen0" 0 0
        InputDevice    
    "Mouse0" "CorePointer"
        
    InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection

    Section 
    "Files"
        
    ModulePath   "/usr/lib/xorg/modules"
        
    FontPath     "/usr/share/fonts/misc"
        
    FontPath     "/usr/share/fonts/100dpi:unscaled"
        
    FontPath     "/usr/share/fonts/75dpi:unscaled"
        
    FontPath     "/usr/share/fonts/TTF"
        
    FontPath     "/usr/share/fonts/Type1"
    EndSection

    Section 
    "ServerFlags"
       
    Option "AutoAddDevices" "True"
       
    Option "AutoEnableDevices" "true"
    EndSection

    Section 
    "Module"
        
    Load  "glx"
        
    Load  "extmod"
        
    Load  "xtrap"
        
    Load  "dbe"
        
    Load  "dri"
        
    Load  "freetype"
    EndSection

    Section 
    "InputDevice"
        
    Identifier     "Keyboard0"
        
    Driver         "keyboard"
        
    Option         "XkbLayout" "de"
        
    Option         "XkbVariant" "nodeadkeys"
    EndSection

    Section 
    "InputDevice"
        
    Identifier  "Mouse0"
        
    Driver      "mouse"
        
    Option        "Protocol" "auto"
        
    Option        "Device" "/dev/input/mice"
        
    Option        "ZAxisMapping" "4 5 6 7"
    EndSection

    Section 
    "Monitor"
        
    Identifier   "Monitor0"
        
    VendorName   "Monitor Vendor"
        
    ModelName    "Monitor Model"
    EndSection

    Section 
    "Device"
            
    ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "ShadowFB"               # [<bool>]
            #Option     "DefaultRefresh"         # [<bool>]
            #Option     "ModeSetClearScreen"     # [<bool>]
        
    Identifier  "Card0"
        
    Driver      "vesa"
        
    VendorName  "ATI Technologies Inc"
        
    BoardName   "RV570 [Radeon X1950 Pro]"
        
    BusID       "PCI:1:0:0"
    EndSection

    Section 
    "Screen"
        
    Identifier "Screen0"
        
    Device     "Card0"
        
    Monitor    "Monitor0"
        
    SubSection "Display"
            
    Viewport   0 0
            Depth     1
        EndSubSection
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     4
        EndSubSection
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     8
        EndSubSection
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     15
        EndSubSection
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     16
        EndSubSection
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     24
        EndSubSection
    EndSection

     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    585
    Zustimmungen:
    0
    Ort:
    bremen
    mach mal

    Option "AutoAddDevices" "False"

    dann sollte es gehen, die neueren xorgversionen laden viele hardwareeinstellungen über hal, also entweder configurierst du hal entsprechend, oder eben mittels der obigen option die config per xorg.conf wieder einschalten.
     
  4. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.482
    Zustimmungen:
    1
    Ort:
    Bruchsal
    X erkennt die Peripherie mittlerweile über evdev. Für dich heißt das, das du jetzt entweder evdev in der xorg.conf deaktivierst, oder die Konfiguration richtig machst.

    Zu ersterem schreibst du das in die xorg.conf:
    Code:
    Section "ServerFlags"
        Option "AutoAddDevices" "False"
    EndSection
    
    Und zu dem zweiten Punkt:
    Code:
    cp /usr/share/hal/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/10-keymap.fdi
    
    Die 10-keymap.fdi im /etc/hal/fdi/policy Verzeichnis musst du dann noch vom us-Layout auf das deutsche Layout umstellen.

    Code:
     <merge key="input.xkb.layout" type="string">us</merge>
    
    ändern in..
    Code:
    <merge key="input.xkb.layout" type="string">de</merge>
    
    Danach musst du hal und X neustarten.
     
  5. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    585
    Zustimmungen:
    0
    Ort:
    bremen
    jo so wie in 2 würde ichs auch machen, nur mit einer änderung

    Code:
    <merge key="input.xkb.layout" type="string">de</merge>
    <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
     
  6. #5 Da1, 07.02.2009
    Zuletzt bearbeitet: 07.02.2009
    Da1

    Da1 Jungspund

    Dabei seit:
    11.10.2008
    Beiträge:
    16
    Zustimmungen:
    0
    Danke ich werds ausprobieren und dann posten wens geklappt hat.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    es geht danke
     
  7. #6 Rittler, 08.02.2009
    Rittler

    Rittler Stümper

    Dabei seit:
    06.12.2007
    Beiträge:
    132
    Zustimmungen:
    0
    Ort:
    FS near MUC
    du solltest mit evdev und dem neuen xorg auf jeden Fall auch hal in dein demons array aufnehmen...
     
Thema:

Xorg probleme mit Maus und Tastertur

Die Seite wird geladen...

Xorg probleme mit Maus und Tastertur - Ähnliche Themen

  1. xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus

    xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus: Hi also der Betreff sagt schon des meiste. Hab mein Gentoo-System seit längerer Zeit mal wieder aktualisiert, was 2 größere Änderungen mit sich...
  2. 0-laenge Pakete und Xorg Probleme

    0-laenge Pakete und Xorg Probleme: Hallo. Nachdem ich nun langsam in meinem bisher reinen ueber Konsole betriebenen Arch einen X-Server benutzen will haeufen sich die Probleme...
  3. Probleme bei der installation von Xorg.

    Probleme bei der installation von Xorg.: Ich habe Arch erfolgreich installiert (core.iso) und nund wollte ich eigentlich Xorg installieren. Wenn ich pacman -S xorg eingebe kommt folgende...
  4. xorg.conf Probleme nach Treiber-Installation

    xorg.conf Probleme nach Treiber-Installation: Hallo zusammen!! Nachdem ich den Nvidiatreiber 1.0-8776 installiert hab, besteht das problem, dass ich nur noch die auflösungen 1024*768 und...
  5. Probleme mit Mobile Intel 915GM, Xorg, Debian, Auflösung, Laptop Sony VGN-TX2XP

    Probleme mit Mobile Intel 915GM, Xorg, Debian, Auflösung, Laptop Sony VGN-TX2XP: Hallo, ich möchte die Auflösung auf einem Laptop Sony VGN-TX2XP unter Debian (Testing) anpassen. Optimale Auflösung ist 1366x768. Die Lösung...