x60 atheros - ath0

Dieses Thema im Forum "Gentoo" wurde erstellt von schuhbus, 31.12.2007.

  1. #1 schuhbus, 31.12.2007
    schuhbus

    schuhbus Mitglied

    Dabei seit:
    08.10.2005
    Beiträge:
    40
    Zustimmungen:
    0
    hi.
    ich habe gentoo 2.6.23 auf einem ibm x60 laufen.
    die wlancard ist eine atheros.
    habe im kernel folegndes:

    [*] Wireless extensions

    [*] Wireless LAN (IEEE 802.11)

    net-wireless/madwifi-ng und madwifi-ng-tools habe ich gemered.
    "modprobe ath_pci" ging problemlos, aber mein ath0 taucht nicht auf.

    lsmod spuckt folgendes aus:

    Module Size Used by
    ath_pci 75808 0
    wlan 151492 1 ath_pci
    ath_hal 191696 1 ath_pci


    und dmesg:

    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    wlan: 0.8.4.2 (0.9.3.3)
    ath_pci: 0.9.4.5 (0.9.3.3)
    ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 21
    PCI: Setting latency timer of device 0000:03:00.0 to 64
    Unable to load needed module: ath_rate_sample; no support for automatic module loading<3>Error loading module "ath_rate_sample"

    was ist das problem. wieso bekomme ich kein ath0 device


    gruss schuhbus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Ferchault, 31.12.2007
    Ferchault

    Ferchault Eroberer

    Dabei seit:
    19.06.2007
    Beiträge:
    61
    Zustimmungen:
    0
    Ort:
    localhost
    "Unable to load needed module: ath_rate_sample; no support for automatic module loading<3>Error loading module "ath_rate_sample""
    Erstmal testen, ob modprobe ath_rate_sample funktioniert. Wenn ja entweder bei den Kerneloptionen "automatic module loading" einschalten oder das Modul in der Datei /etc/modules.autoload.d/kernel-2.6 eintragen.
     
  4. #3 schuhbus, 31.12.2007
    schuhbus

    schuhbus Mitglied

    Dabei seit:
    08.10.2005
    Beiträge:
    40
    Zustimmungen:
    0
    hi. also modprobe ath_rate_sample ging.
    im kernel habe ich nun automatik module loading aktiviert aber dmesg spuckt immer noch den selben fehler aus.

    gruß sebastian
     
  5. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    kernel danach auch neu kompiliert ?
    modul in die von Ferchault angesprochene datei eingetragen ?
     
  6. #5 schuhbus, 01.01.2008
    schuhbus

    schuhbus Mitglied

    Dabei seit:
    08.10.2005
    Beiträge:
    40
    Zustimmungen:
    0
    hi.

    jo. kernel neu gebacken und auch in grub eingetragen.
    ebenso steht ath_rate_sampel in /etc/modules.autoload/kernel2.6

    auch lsmod spuckt aus dass:

    Module Size Used by
    ath_rate_sample 13440 0
    ath_pci 75808 0
    wlan 151492 2 ath_rate_sample,ath_pci
    ath_hal 191696 2 ath_rate_sample,ath_pci

    und dmesg: das gleiche wie vorher

    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    wlan: 0.8.4.2 (0.9.3.3)
    ath_pci: 0.9.4.5 (0.9.3.3)
    ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 21
    PCI: Setting latency timer of device 0000:03:00.0 to 64
    Unable to load needed module: ath_rate_sample; no support for automatic module loading<3>Error loading module "ath_rate_sample"
     
  7. #6 schuhbus, 11.01.2008
    schuhbus

    schuhbus Mitglied

    Dabei seit:
    08.10.2005
    Beiträge:
    40
    Zustimmungen:
    0
    hi...

    also nachdem mit den gentoo-sources meine atheros nicht wollte habe ich nun mal die suspend2-sources genommen.

    im kernel nur "wireless extensions drin!!!

    #
    # Wireless
    #
    # CONFIG_CFG80211 is not set
    CONFIG_WIRELESS_EXT=y
    # CONFIG_MAC80211 is not set
    # CONFIG_IEEE80211 is not set
    # CONFIG_RFKILL is not set

    # Device Drivers
    #
    # Wireless LAN
    #
    # CONFIG_WLAN_PRE80211 is not set
    # CONFIG_WLAN_80211 is not set


    und dann

    emerge -av net-wireless/madwifi-ng net-wireless/madwifi-ng-tools

    und

    modprobe ath_pci

    und alles hat wunderbar geklappt

    lsmod:

    Module Size Used by
    wlan_scan_sta 12800 0
    ath_rate_sample 13440 1
    ath_pci 75808 0
    wlan 151748 4 wlan_scan_sta,ath_rate_sample,ath_pci
    ath_hal 191696 3 ath_rate_sample,ath_pci


    iwconfig:

    eth0 no wireless extensions.

    lo no wireless extensions.

    sit0 no wireless extensions.

    wifi0 no wireless extensions.

    ath0 IEEE 802.11b ESSID:"" Nickname:""
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power:0 dBm Sensitivity=1/1
    Retry:off RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off
    Link Quality=0/70 Signal level=0 dBm Noise level=0 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

x60 atheros - ath0

Die Seite wird geladen...

x60 atheros - ath0 - Ähnliche Themen

  1. Atheros gibt Firmware für WLAN-Chips frei

    Atheros gibt Firmware für WLAN-Chips frei: Atheros hat die Firmware für einige seiner WLAN-Chips freigegeben und den Quellcode veröffentlicht. Weiterlesen...
  2. Treiber für Atheros AR8152 kompilieren

    Treiber für Atheros AR8152 kompilieren: Hallo, ich habe es nun endlich geschafft mir Gentoo auf mein Netbook (Asus EeePC R011PX) zu installieren. Jedoch habe ich nun das Problem, dass...
  3. [Ubuntu 8.10] Atheros W-Lan funktioniert nicht

    [Ubuntu 8.10] Atheros W-Lan funktioniert nicht: Hiho, Ich habe in meinem Laptop eine Atheros W-Lan Karte. Nun habe ich mir Ubuntu 8.10 installiert doch ein "iwlist scanning" bringt keinen...
  4. Atheros mit Kernel 2.6.25

    Atheros mit Kernel 2.6.25: Im neuen Kernel (2.6.25) ist nun der Atheros-Treiber integriert und soll madwifi ersetzen. Ich habe den Kernel mit dieser Option kompiliert, es...
  5. Atheros 5001x+ (Nec Warpstar WL54AG) scannt nur / verbindungsabbrüche

    Atheros 5001x+ (Nec Warpstar WL54AG) scannt nur / verbindungsabbrüche: Hallo Community, meine ersten schritte mit linux liegen schon etwas zurück. Aber das dauerhafte arbeiten ist immer daran gescheitert, dass...