X-Server verhindert kompletten Shutdown

Dieses Thema im Forum "Linux OS" wurde erstellt von supersucker, 12.05.2007.

  1. #1 supersucker, 12.05.2007
    Zuletzt bearbeitet: 12.05.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe auf meinem Laptop (HP nx6325, Kubuntu Feisty) folgendes Problem:

    Versuche ich meinen Laptop über das shutdown-Menü von KDE herunterzufahren, komme ich zwar bis zum letzten Screen vor dem Ausgehen des Gerätes (also der wo das Kubuntu-Logo zu sehen ist und ein rollender Balken anzeigt, dass irgendwas passiert), aber dann passiert folgendes:

    - der Balken hält kurz an
    - der screen wird kurz komplett schwarz
    - danach erscheint der screen wieder, der Balken rollt wieder
    - dann beginnt das Spiel von vorne

    Auf die Konsolen mit ALT + F* komme ich dann auch nicht mehr, bzw. nur ganz kurz, danach springt der Screen sofort wieder zum oben beschriebenen Screen. Sprich, ich kann auch nicht mehr "ps" und Konsorten nachschauen, welcher Prozess genau da gerade nicht klarkommt.

    Mache ich jedoch ein

    Code:
    /etc/init.d/kdm stop
    und gebe danach in der Konsole ein

    Code:
    shutdown -h now
    fährt der Laptop runter und geht aus.

    Demzufolge geh ich davon das der X-Server beim shutdown über das KDE-Menü niemals terminiert.

    Nur warum weiss ich eben nicht, ein
    Code:
    grep EE /var/log/Xorg.0.log
    bringt keine Ergebnisse (ausser den obligatorischen wacom-Kram).

    Auch in der

    Code:
    .xsession-errors
    finde ich nichts Auffälliges.

    Jemand ne Idee wie man dem eigentlichen Problem auf die Schliche kommen kann bzw. den X-Server zwingen kann zu terminierenn?

    Bei google hab ich diesbezüglich nur Beiträge gefunden, bei denen es um andere Problematiken ging.

    Bin für jeden Tip dankbar!

    Edit:

    Evtl. ist das ein ATI-Problem?

    lspci sagt diesbzgl.

    Code:
    01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
    
    Treiber ist installiert:

    Code:
    fglrxinfo 
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON XPRESS Series
    OpenGL version string: 2.0.6334 (8.34.8)
    
    Und hier noch die xorg.conf (wacom-Kram hab ich jetzt mal rausgeschmissen):

    Code:
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"i2c"
    	Load	"bitmap"
    	Load	"ddc"
    #	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbVariant"	"nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizScrollDelta"	"0"
    EndSection
    
    
    Section "Device"
    	Identifier	"ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
    	Driver		"fglrx"
    	BusID		"PCI:1:5:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1024x768"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1024x768"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1024x768"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1024x768"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1024x768"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice     "stylus"	"SendCoreEvents"
    	InputDevice     "cursor"	"SendCoreEvents"
    	InputDevice     "eraser"	"SendCoreEvents"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    Section "Extensions"
            Option "Composite" "Disable"
    EndSection
    Section "ServerFlags"
            Option  "AIGLX" "off"
    EndSection
    
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 12.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Mach doch einfach einen entsprechenden Kill-Befehl in ein Init-Skript, das du beim Runterfahren als erstes ausführen läßt.
     
  4. #3 supersucker, 13.05.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ja,

    so hab ich es jetzt auch gelöst, aber so wirklich befriedigend finde ich diesen Workaround nicht.

    Besser hätte ich es gefunden, die Ursache des Problems rauszufinden und __das__ dann zu lösen.

    Naja, was solls.........
     
  5. #4 bitmuncher, 13.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Dann schau doch mal in die xorg.1.log, denn normalerweise sind ja dort die Sachen vom letzten X-Server-Lauf gespeichert und in der xorg.0.log nur die des aktuell laufenden X-Servers. Evtl. findet sich ja dort ein Hinweis.
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

X-Server verhindert kompletten Shutdown

Die Seite wird geladen...

X-Server verhindert kompletten Shutdown - Ähnliche Themen

  1. Buch-Weitergabe: Linux-Server mit Debian 6 (Squeeze)

    Buch-Weitergabe: Linux-Server mit Debian 6 (Squeeze): Autor des Buches: Eric Amberg ISBN: 3-8266-5534-0 Praxisumpfang: Backoffice-Server, Root-Server, Linux als Gateway, Server-Security Viele...
  2. Linux-Server im Smartphone-Format

    Linux-Server im Smartphone-Format: Die amerikanische Firma iCracked stellt einen Linux-Server für die Hosentasche vor, der im Bedarfsfall auch als Powerpack das Smartphone aufladen...
  3. X-Server 1.18 freigegeben

    X-Server 1.18 freigegeben: Das X.org-Team hat den X-Server in Version 1.18 freigegeben. X-Server 1.18 sah umfangreiche Aufräumarbeiten, Erweiterungen und Korrekturen....
  4. Linux-Server Zentyal 4.2 freigegeben

    Linux-Server Zentyal 4.2 freigegeben: Die spanische Firma Zentyal hat ihren Linux-Unternehmens-Server in Version 4.2 freigegeben. Der Server, der eine sehr gute Interoperabilität mit...
  5. IBM stellt drei neue Linux-Server vor

    IBM stellt drei neue Linux-Server vor: IBM will noch in diesem Jahr drei neue Linux-Server nach der OpenPOWER-Spezifikation ausliefern. Die Server sind für BigData und Cloud-Computing...