X-server und Nvidia treiber problem

Dieses Thema im Forum "KDE" wurde erstellt von Death_X, 02.03.2007.

  1. #1 Death_X, 02.03.2007
    Zuletzt bearbeitet: 07.03.2007
    Death_X

    Death_X Grünschnabel

    Dabei seit:
    02.03.2007
    Beiträge:
    5
    Zustimmungen:
    0
    [Gelöst] X-server und Nvidia treiber problem

    Ich habe ein Problem welches folgendes ist:
    Ich habe eine Nvidia Gforce 7600GT und benutze Debian mit KDE und Xorg mit dem offiziellen "nvidia" Treiber. Das alles funktioniert jedoch liefert der Xserver nach dem reboot einen schwarzen Bildschirm. Ich kann aber in die Konsole wechseln.
    Von da aus habe ich dann den Nvidia Treiber Installer nochmal ausgeführt und kdm neu gestartet.
    Jetzt funktioniert zwar alles aber es ist nervig alles jedesmal neu zu installieren nachdem ich reboote.
    Ich hab schon einiges probiert aber nichts hat geholfen:
    1. Ich habe im Kernel Eintrag beim boot-loader (grub) das "splash=silent" gelöscht. aber kein Ergebnis
    2. Ich habe bevor ich den Treiber neu installiert habe das modul nvidia neu geladen ("rmmod nvidia && modprobe nvidia") aber auch hier kein Ergebnis.
    3. Um zu testen ob der Xserver gerade deswegen nichts anzeigt hab ich das ganze nach der neu Installation gemacht. Jetzt bekomme ich nur eine Zeile die mir sagt das kein Modul namens "nvidia" in "/proc/mdules"ist.
    3.1. Deshalb hab ich mir mal angeschaut was drin steht und siehe da: /proc/modules ist ganz leer. Vor der neu Installation stand da noch viel mehr drin.
    4. Ich habe andere Treiber ausprobiert ("nv","vesa") und die funktionieren nach dem reboot noch ganz normal.
    (5. Meine xorg.conf habe ich natürlich schon upgedatet)

    Was soll ich tun ? Ich weiß mir nicht mehr zu helfen :hilfe2:
    Meine xorg.conf:
    Code:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"bitmap"
    	Load	"ddc"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
    	Load	"dbus"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbVariant"	"nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    EndSection
    
    Section "Device"
    	Identifier	"NVIDIA GeForce 7600GT"
    	Driver		"nvidia"
    	BusID		"PCI:3:0:0"
    	VideoRam	128
    	Option "XAANoOffscreenPixmaps" "true"# Optional if NVIDIA drivers are used
    	Option "AddARGBGLXVisuals" "On"
    	Option "TripleBuffer"      "True" # Dreifacher Buffer für flüssigere Animationen
    EndSection
    
    Section "Monitor"
    	Identifier	"Standardbildschirm"
    	Option		"DPMS"
    	HorizSync	28-64
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"NVIDIA GeForce 7600GT"
    	Monitor		"Standardbildschirm"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    
    Section "Extensions"
       Option "Composite" "Enable"
    EndSection
    
    "lsmod | grep nvidia"gibt folgendes aus (bevor und! nachdem ich den Treiber neu Installiert habe)
    Code:
    nvidia               6820244  32
    i2c_core               19472  6 nvidia,dvb_usb_dibusb_mb,dvb_usb,dvb_pll,dib3000_common,i2c_nforce2
    nvidia_agp              8092  1
    agpgart                29360  2 nvidia,nvidia_agp
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 0mx, 02.03.2007
    Zuletzt bearbeitet: 02.03.2007
    0mx

    0mx Mitglied

    Dabei seit:
    01.12.2006
    Beiträge:
    25
    Zustimmungen:
    0
    Kommt das nVidia-logo wenn xorg versucht zu starten? Kommt keine Fehlermeldung von Xorg? (Bei mir kommt immer eine Fehlermeldung wenn etwas nicht stimmt) Und poste bitte mal die /var/log/Xorg.log.

    g 0mx

    PS:Wieso postest du dieses Thema ins KDE-Forum? Das ist kein problem vom Window Manager bzw Desktop Umgebung
     
  4. #3 Death_X, 02.03.2007
    Death_X

    Death_X Grünschnabel

    Dabei seit:
    02.03.2007
    Beiträge:
    5
    Zustimmungen:
    0
    1. Nein ich sehe kein Nvidia Logo beim booten
    2.
    Code:
    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: UNKNOWN 
    Current Operating System: Linux Philipp 2.6.18-3-486 #1 Mon Dec 4 15:59:52 UTC 2006 i686
    Build Date: 17 February 2007
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar  2 15:35:13 2007
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Default Layout"
    (**) |-->Screen "Default Screen" (0)
    (**) |   |-->Monitor "Standardbildschirm"
    (**) |   |-->Device "NVIDIA GeForce 7600GT"
    (**) |-->Input Device "Generic Keyboard"
    (**) |-->Input Device "Configured Mouse"
    (WW) The directory "/usr/X11R6/lib/X11/fonts/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/Type1" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
    	Entry deleted from font path.
    (**) FontPath set to:
    	/usr/share/fonts/X11/misc,
    	/usr/share/fonts/X11/100dpi/:unscaled,
    	/usr/share/fonts/X11/75dpi/:unscaled,
    	/usr/share/fonts/X11/Type1,
    	/usr/share/fonts/X11/100dpi,
    	/usr/share/fonts/X11/75dpi
    (==) RgbPath set to "/etc/X11/rgb"
    (==) ModulePath set to "/usr/lib/xorg/modules"
    (**) Extension "Composite" is enabled
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.3
    	X.Org Video Driver: 1.0
    	X.Org XInput driver : 0.6
    	X.Org Server Extension : 0.3
    	X.Org Font Renderer : 0.5
    (II) Loader running on linux
    (II) LoadModule: "bitmap"
    (II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
    (II) Module bitmap: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	Module class: X.Org Font Renderer
    	ABI class: X.Org Font Renderer, version 0.5
    (II) Loading font Bitmap
    (II) LoadModule: "pcidata"
    (II) Loading /usr/lib/xorg/modules/libpcidata.so
    (II) Module pcidata: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Video Driver, version 1.0
    (++) using VT number 7
    
    (II) PCI: PCI scan (all values are in hex)
    (II) PCI: 00:00:0: chip 10de,01e0 card 0000,0000 rev a2 class 06,00,00 hdr 80
    (II) PCI: 00:00:1: chip 10de,01eb card 1297,f541 rev a2 class 05,00,00 hdr 80
    (II) PCI: 00:00:2: chip 10de,01ee card 1297,f541 rev a2 class 05,00,00 hdr 80
    (II) PCI: 00:00:3: chip 10de,01ed card 1297,f541 rev a2 class 05,00,00 hdr 80
    (II) PCI: 00:00:4: chip 10de,01ec card 1297,f541 rev a2 class 05,00,00 hdr 80
    (II) PCI: 00:00:5: chip 10de,01ef card 1297,f541 rev a2 class 05,00,00 hdr 80
    (II) PCI: 00:01:0: chip 10de,0060 card 1297,f541 rev a4 class 06,01,00 hdr 80
    (II) PCI: 00:01:1: chip 10de,0064 card 1297,f541 rev a2 class 0c,05,00 hdr 80
    (II) PCI: 00:02:0: chip 10de,0067 card 1297,f541 rev a4 class 0c,03,10 hdr 80
    (II) PCI: 00:02:1: chip 10de,0067 card 1297,f541 rev a4 class 0c,03,10 hdr 80
    (II) PCI: 00:02:2: chip 10de,0068 card 1297,f541 rev a4 class 0c,03,20 hdr 80
    (II) PCI: 00:04:0: chip 10de,0066 card 1297,f541 rev a1 class 02,00,00 hdr 00
    (II) PCI: 00:05:0: chip 10de,006b card 1297,f541 rev a2 class 04,01,00 hdr 00
    (II) PCI: 00:06:0: chip 10de,006a card 1297,f541 rev a1 class 04,01,00 hdr 00
    (II) PCI: 00:08:0: chip 10de,006c card 0000,0000 rev a3 class 06,04,00 hdr 01
    (II) PCI: 00:09:0: chip 10de,0065 card 1297,f541 rev a2 class 01,01,8a hdr 00
    (II) PCI: 00:0d:0: chip 10de,006e card 1297,f541 rev a3 class 0c,00,10 hdr 00
    (II) PCI: 00:1e:0: chip 10de,01e8 card 0000,0000 rev a2 class 06,04,00 hdr 01
    (II) PCI: 03:00:0: chip 10de,02e0 card 0000,0000 rev a2 class 03,00,00 hdr 00
    (II) PCI: End of PCI scan
    (II) Host-to-PCI bridge:
    (II) Bus 0: bridge is at (0:0:0), (0,0,3), BCTRL: 0x0008 (VGA_EN is set)
    (II) Bus 0 I/O range:
    	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) Bus 0 non-prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) Bus 0 prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) PCI-to-ISA bridge:
    (II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
    (II) PCI-to-PCI bridge:
    (II) Bus 1: bridge is at (0:8:0), (0,1,1), BCTRL: 0x0202 (VGA_EN is cleared)
    (II) PCI-to-PCI bridge:
    (II) Bus 3: bridge is at (0:30:0), (0,3,3), BCTRL: 0x000a (VGA_EN is set)
    (II) Bus 3 non-prefetchable memory range:
    	[0] -1	0	0xe8000000 - 0xeaffffff (0x3000000) MX[B]
    (II) Bus 3 prefetchable memory range:
    	[0] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B]
    (--) PCI:*(3:0:0) nVidia Corporation unknown chipset (0x02e0) rev 162, Mem @ 0xe8000000/24, 0xd0000000/28, 0xe9000000/24
    (II) Addressable bus resource ranges are
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) OS-reported resource ranges:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) PCI Memory resource overlap reduced 0xe0000000 from 0xe7ffffff to 0xdfffffff
    (II) Active PCI resource ranges:
    	[0] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[1] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[2] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[3] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[4] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[5] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[6] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[7] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[8] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[9] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[10] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[11] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[12] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[13] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[14] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[15] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[16] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    (II) Active PCI resource ranges after removing overlaps:
    	[0] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[1] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[2] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[3] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[4] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[5] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[6] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[7] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[8] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[9] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[10] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[11] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[12] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[13] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[14] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[15] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[16] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    (II) OS-reported resource ranges after removing overlaps with PCI:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) All system resource ranges:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[5] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[6] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[7] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[8] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[9] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[10] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[11] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[12] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[13] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[14] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[15] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[16] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[17] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[18] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[19] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[20] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[21] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[22] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    (II) LoadModule: "bitmap"
    (II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
    (II) Loading font Bitmap
    (II) LoadModule: "ddc"
    (II) Loading /usr/lib/xorg/modules/libddc.so
    (II) Module ddc: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Video Driver, version 1.0
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension SHAPE
    (II) Loading extension MIT-SUNDRY-NONSTANDARD
    (II) Loading extension BIG-REQUESTS
    (II) Loading extension SYNC
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XC-MISC
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-Misc
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension TOG-CUP
    (II) Loading extension Extended-Visual-Information
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "freetype"
    (II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
    (II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
    	compiled for 7.1.1, module version = 2.1.0
    	Module class: X.Org Font Renderer
    	ABI class: X.Org Font Renderer, version 0.5
    (II) Loading font FreeType
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
    	compiled for 4.0.2, module version = 1.0.9746
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.1
    (II) Loading extension GLX
    (II) LoadModule: "int10"
    (II) Loading /usr/lib/xorg/modules/libint10.so
    (II) Module int10: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Video Driver, version 1.0
    (II) LoadModule: "vbe"
    (II) Loading /usr/lib/xorg/modules/libvbe.so
    (II) Module vbe: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.1.0
    	ABI class: X.Org Video Driver, version 1.0
    (II) LoadModule: "nvidia"
    (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    (II) Module nvidia: vendor="NVIDIA Corporation"
    	compiled for 4.0.2, module version = 1.0.9746
    	Module class: X.Org Video Driver
    (II) LoadModule: "kbd"
    (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
    (II) Module kbd: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.1.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.6
    (II) LoadModule: "mouse"
    (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
    (II) Module mouse: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.1.1
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.6
    (II) NVIDIA dlloader X Driver  1.0-9746  Fri Dec 15 09:56:41 PST 2006
    (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    (II) Primary Device is: PCI 03:00:0
    (--) Chipset NVIDIA GPU found
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib/xorg/modules/libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org ANSI C Emulation, version 0.3
    (II) Loading sub module "wfb"
    (II) LoadModule: "wfb"
    (II) Loading /usr/lib/xorg/modules/libwfb.so
    (II) Module wfb: vendor="X.Org Foundation"
    	compiled for 7.1.99.2, module version = 1.0.0
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Loading /usr/lib/xorg/modules/libramdac.so
    (II) Module ramdac: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 0.1.0
    	ABI class: X.Org Video Driver, version 1.0
    (II) resource ranges after xf86ClaimFixedResources() call:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[5] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[6] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[7] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[8] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[9] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[10] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[11] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[12] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[13] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[14] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[15] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[16] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[17] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[18] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[19] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[20] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[21] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[22] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    (II) resource ranges after probing:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[5] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[6] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[7] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[8] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[9] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[10] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[11] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[12] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[13] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[14] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[15] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[16] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B]
    	[17] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B]
    	[18] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B]
    	[19] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[20] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[21] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[22] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[23] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[24] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[25] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    	[26] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
    	[27] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
    (II) Setting vga for screen 0.
    (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    (==) NVIDIA(0): RGB weight 888
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) NVIDIA(0): Option "TripleBuffer" "True"
    (**) NVIDIA(0): Option "AddARGBGLXVisuals" "On"
    (**) NVIDIA(0): Enabling RENDER acceleration
    (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) NVIDIA(0):     enabled.
    (II) NVIDIA(0): NVIDIA GPU GeForce 7600 GT at PCI:3:0:0 (GPU-0)
    (--) NVIDIA(0): Memory: 262144 kBytes
    (--) NVIDIA(0): VideoBIOS: 05.73.22.52.00
    (II) NVIDIA(0): Detected AGP rate: 8X
    (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) NVIDIA(0): Connected display device(s) on GeForce 7600 GT at PCI:3:0:0:
    (--) NVIDIA(0):     MED MD32119PR (CRT-1)
    (--) NVIDIA(0): MED MD32119PR (CRT-1): 400.0 MHz maximum pixel clock
    (II) NVIDIA(0): Assigned Display Device: CRT-1
    (WW) NVIDIA(0): No valid modes for "1280x854"; removing.
    (WW) NVIDIA(0): No valid modes for "1200x800"; removing.
    (II) NVIDIA(0): Validated modes:
    (II) NVIDIA(0):     "1280x1024"
    (II) NVIDIA(0):     "1280x960"
    (II) NVIDIA(0):     "1280x800"
    (II) NVIDIA(0):     "1280x768"
    (II) NVIDIA(0):     "1152x864"
    (II) NVIDIA(0):     "1152x768"
    (II) NVIDIA(0):     "1024x768"
    (II) NVIDIA(0):     "800x600"
    (II) NVIDIA(0):     "640x480"
    (II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
    (--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
    (--) NVIDIA(0):     option
    (--) Depth 24 pixmap format is 32 bpp
    (II) do I need RAC?  No, I don't.
    (II) resource ranges after preInit:
    	[0] 0	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B]
    	[1] 0	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B]
    	[2] 0	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B]
    	[3] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[4] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[5] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[6] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[7] -1	0	0xed085000 - 0xed08503f (0x40) MX[B]
    	[8] -1	0	0xed084000 - 0xed0847ff (0x800) MX[B]
    	[9] -1	0	0xed081000 - 0xed081fff (0x1000) MX[B]
    	[10] -1	0	0xed000000 - 0xed07ffff (0x80000) MX[B]
    	[11] -1	0	0xed087000 - 0xed087fff (0x1000) MX[B]
    	[12] -1	0	0xed086000 - 0xed0860ff (0x100) MX[B]
    	[13] -1	0	0xed083000 - 0xed083fff (0x1000) MX[B]
    	[14] -1	0	0xed080000 - 0xed080fff (0x1000) MX[B]
    	[15] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
    	[16] -1	0	0xe9000000 - 0xe9ffffff (0x1000000) MX[B](B)
    	[17] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
    	[18] -1	0	0xe8000000 - 0xe8ffffff (0x1000000) MX[B](B)
    	[19] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
    	[20] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
    	[21] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
    	[22] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[23] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[24] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
    	[25] -1	0	0x0000d800 - 0x0000d87f (0x80) IX[B]
    	[26] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
    	[27] -1	0	0x0000d000 - 0x0000d007 (0x8) IX[B]
    	[28] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
    	[29] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    	[30] 0	0	0x000003c0 - 0x000003df (0x20) IS[B](OprU)
    (II) NVIDIA(0): Setting mode "1280x1024"
    (II) Loading extension NV-GLX
    (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
    (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
    (==) NVIDIA(0): Backing store disabled
    (==) NVIDIA(0): Silken mouse enabled
    (**) Option "dpms"
    (**) NVIDIA(0): DPMS enabled
    (II) Loading extension NV-CONTROL
    (WW) NVIDIA(0): Option "XAANoOffscreenPixmaps" is not used
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (II) Initializing extension GLX
    (**) Option "CoreKeyboard"
    (**) Generic Keyboard: Core Keyboard
    (**) Option "Protocol" "standard"
    (**) Generic Keyboard: Protocol: standard
    (**) Option "AutoRepeat" "500 30"
    (**) Option "XkbRules" "xorg"
    (**) Generic Keyboard: XkbRules: "xorg"
    (**) Option "XkbModel" "pc105"
    (**) Generic Keyboard: XkbModel: "pc105"
    (**) Option "XkbLayout" "de"
    (**) Generic Keyboard: XkbLayout: "de"
    (**) Option "XkbVariant" "nodeadkeys"
    (**) Generic Keyboard: XkbVariant: "nodeadkeys"
    (**) Option "CustomKeycodes" "off"
    (**) Generic Keyboard: CustomKeycodes disabled
    (**) Option "Protocol" "ImPS/2"
    (**) Configured Mouse: Device: "/dev/input/mice"
    (**) Configured Mouse: Protocol: "ImPS/2"
    (**) Configured Mouse: Core Pointer
    (**) Option "Device" "/dev/input/mice"
    (==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
    (**) Configured Mouse: ZAxisMapping: buttons 4 and 5
    (**) Configured Mouse: Buttons: 9
    (II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
    (II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
        xkb_keycodes             { include "xfree86+aliases(qwertz)" };
        xkb_types                { include "complete" };
        xkb_compatibility        { include "complete" };
        xkb_symbols              { include "pc(pc105)+de(nodeadkeys)" };
        xkb_geometry             { include "pc(pc105)" };
    (II) Configured Mouse: ps2EnableDataReporting: succeeded
    (II) 3rd Button detected: disabling emulate3Button
    
     
  5. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Hi,

    1. Ist das Modul "nvidia" auch in /etc/autoload.modules.d/kernel.... eingetragen, so das es beim Booten geladen wird?
    2. Kommentier mal die letzten Zeilen mit "..dri" aus, die haben da nix zu suchen, da du "glx" benutzt und nicht "dri"
    3. In der "Screen" Section mal die Zeilen mit Depth 16 und 24 lassen, denn Rest auskommentieren. Ich glaube, dass ich irgendwo gelesen habe, dass das zu Probelem führen kann.
    4. evtl. in der Section Device die Options und BusID auskommentieren.

    So sieht es bei mir aus:

    Code:
    Section "Device"
    	Identifier  "MSI NX7600GS"
    	Driver      "nvidia"
    	Card        "MSI NX7600GS"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "MSI NX7600GS"
    	Monitor    "NFREN 19 Zoll TFT"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    		Modes    "1280x1024" "1024x768" "800x600"
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x1024" "1024x768" "800x600"
    	EndSubSection
    EndSection
     
  6. #5 0mx, 02.03.2007
    Zuletzt bearbeitet: 02.03.2007
    0mx

    0mx Mitglied

    Dabei seit:
    01.12.2006
    Beiträge:
    25
    Zustimmungen:
    0
    Komig in deiner Xorg.log steht nichts auffälliges.
    Es sieht so aus als ob der Xorg ordnungsgemäß "läuft", man jedoch nichts auf dem Bildschrim sieht.
    Eventuelle kannst du mal versuchen alle Module und die Composite Extension zu deaktivieren, und wenns dann klappt dann kannst du alles nacheinander wieder aktivieren, dann siehst du vllt was fehlerhaft ist.

    g 0mx

    @mali in Section "Module" ist kein dri ich denke nicht das das zu einem Problem führen könnte, aber es sollte trotzdem auskommentiert werden, da es einfach nicht gebraucht wird.
     
  7. #6 Death_X, 02.03.2007
    Death_X

    Death_X Grünschnabel

    Dabei seit:
    02.03.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Danke! Ich probiers gleich mal aus (das geht hier im Forum ziemlich zackig mit den antworten:D )
     
  8. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    so soll es doch auch sein !!!:headup:
     
  9. #8 Death_X, 02.03.2007
    Death_X

    Death_X Grünschnabel

    Dabei seit:
    02.03.2007
    Beiträge:
    5
    Zustimmungen:
    0
    mh... hat leider nicht geholfen.
    Kann es sein das es daran liegt dass ich Beryl benutze?
     
  10. #9 Wolfgang, 02.03.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Die Boardsuche würde dich sicher zu diesem Thread führen ... so du sie benutzt hättest. ;)

    Gruß Wolfgang
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. 0mx

    0mx Mitglied

    Dabei seit:
    01.12.2006
    Beiträge:
    25
    Zustimmungen:
    0
    Beryl ist eine mögliche Fehlerquelle.
    Hast du versucht die Composite Extension mal deaktiviert?

    g 0mx
     
  13. #11 Death_X, 02.03.2007
    Zuletzt bearbeitet: 07.03.2007
    Death_X

    Death_X Grünschnabel

    Dabei seit:
    02.03.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Ja aber dann geht Beryl nichtmehr und das "schwarze Bildschirm"-Problem ist immer noch da. Ich hab auch schon Beryl deinstalliert und rebootet aber da war wieder der gleiche effekt.

    @Wolfgang: Sry, dass ich die Boardsuche nicht verwendet habe, trotzdem kenne ich den Thread, ich bin nach 2 Stunden Googlen dazu gekommen. Aber ich verstehe nicht ganz was jetzt die Lösung des Problems ist. Brauche ich diese linux-restricted Zeugs? Oder muss ich einfach einen alten Treiber verwenden?

    Edit (2):
    Nochmal danke für eure hilfe nur wie ich bereits erwähnt habe hilft mir der Thread den Wolfgang angegeben hatte nicht weiter. linux-restricted-modules sind meinen Erkenntnissen nach nur für Ubuntu und nicht für Debian.
    Trozdem konnte ich nach langer zeit des rumprobierens des Problems Lösung finden (welche zugegebener maßen ein bisschen "zu einfach" ist):
    unter /etc/init.d/ (also dem autostart verzeichnis) liegt ein script das vom NVIDIA-installer erstellt wird und beim booten ausgibt: "Creating NVIDIA TLS links ..."
    komisch hab ich mir gedacht der erstellt ja gar nichts? Im gegenteil er löscht alles xD!
    also ist die Problemlösung klar
    => rm /etc/init.d/nvidia-glx
    (das dubiose Script löschen)
    für mich funktioniert es wunderbar. Danke nochmal ich hoffe das hilft anderen Leuten weiter.
     
Thema:

X-server und Nvidia treiber problem

Die Seite wird geladen...

X-server und Nvidia treiber problem - Ähnliche Themen

  1. openSuSE - Kein X-Server nach Installation des nVIDIA-Treibers

    openSuSE - Kein X-Server nach Installation des nVIDIA-Treibers: Hallo zusammen, habe nach der Installation von openSuSE 10.2 auch die proprietären GraKa-Treiber nach der Anleitung auf...
  2. nvidia und der x-server

    nvidia und der x-server: Hi, hab mir einen neuen Desktop-Rechner zugelegt und wollte für meine Geforce 7300 GS (laut Suse-Hardware-Db voll unterstützt)die...
  3. Debian, X-Server, nforce & nvidia

    Debian, X-Server, nforce & nvidia: Ich habe mir vor kurzem Debian auf meinem PC installiert und soweit hat auch alles wunderbar funktioniert nur mit dem installieren des X-servers...
  4. Buch-Weitergabe: Linux-Server mit Debian 6 (Squeeze)

    Buch-Weitergabe: Linux-Server mit Debian 6 (Squeeze): Autor des Buches: Eric Amberg ISBN: 3-8266-5534-0 Praxisumpfang: Backoffice-Server, Root-Server, Linux als Gateway, Server-Security Viele...
  5. Linux-Server im Smartphone-Format

    Linux-Server im Smartphone-Format: Die amerikanische Firma iCracked stellt einen Linux-Server für die Hosentasche vor, der im Bedarfsfall auch als Powerpack das Smartphone aufladen...