WxGtk 2.6 für OpenSuse 10.3

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von pucky, 18.01.2008.

  1. pucky

    pucky Grünschnabel

    Dabei seit:
    18.01.2008
    Beiträge:
    1
    Zustimmungen:
    0
    Ort:
    Mainz
    Hallo zusammen,
    für eine bestimmte Software brauche ich das wxGtk allerdings in der Version 2.6 und nicht 2.8.
    Gibt es einen Weg irgend ein geeignetes Repository zu den Packetquellen hinzuzufügen, in dem wxGtk in einer geeigneten Version vorliegt?

    Pucky
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Tomekk228, 18.01.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    normalerweise sollten diese abwärts kompatibel sein.

    Was für ein Programm braucht wxGtk in 2.6?

    Ich hatte mal so ein Problem mit zatto mit einer datei die eine höhere version hatte. Da hab ich einfach ein symlink gesetzt >
    Code:
    #!/bin/sh
    clear
    echo "###########zattoo installer by tomekk @ www.jeegeek.de###########"
    sleep 1
    echo "###########Das Script bitte als ROOT ausführen!!#################"
    sleep 1
    echo "###########Lade Zattoo herunter##################################"
    wget http://download.zattoo.com/zattoo-3.0.8.9191-1.i386.rpm
    sleep 1
    echo "###########Installiere Abhängigkeiten###########"
    yast2 --install gtkglext mozilla-xulrunner181 
    sleep 1
    echo "###########Installiere Zattoo###################"
    rpm -i zattoo-3.0.8.9191-1.i386.rpm
    sleep 1
    rm zattoo-3.0.8.9191-1.i386.rpm
    sleep 1
    echo "###########Setze Simlinks###########"
    ln -s -f /usr/lib/xulrunner-1.8.1/libgtkembedmoz.so /usr/lib/zattoo/libgtkembedmoz.so.0d
    ln -s -f /usr/lib/xulrunner-1.8.1/libxpcom.so /usr/lib/zattoo/libxpcom.so.0d
    ln -s -f /usr/lib/xulrunner-1.8.1/libmozjs.so /usr/lib/zattoo/libmozjs.so.0d
    ln -s -f /usr/lib/libplds4.so /usr/lib/zattoo/libplds4.so.0d
    ln -s -f /usr/lib/libplc4.so /usr/lib/zattoo/libplc4.so.0d
    ln -s -f /usr/lib/libnspr4.so /usr/lib/zattoo/libnspr4.so.0d
    ln -s -f /usr/lib/xulrunner-1.8.1/libxul.so /usr/lib/zattoo/libxul.so.0d
    ln -s -f /usr/lib/libcurl.so.4.0.0 /usr/lib/zattoo/libcurl.so.4.0.0
    [B]ln -s -f /usr/lib/libcurl.so.4 /usr/lib/zattoo/libcurl.so.3[/B]
    sleep 1
    echo "###########Fertig! Jetzt als User einfach z.b zattoo_player ausführen!######"
    echo "###########Wichtiger Hinweis: Es ist normal das er nach flash verlangt! Obwohl es installiert ist. Es ist ein Bug von Zattoo unter OpenSuse!#"
    
    Dann ging es mit zatto :)

    Vllt klappt es auch bei dir, wenn du eine Verknüpfung erstellst als version 2.6
     
  4. Gast1

    Gast1 Guest

    Code:
    webpin -d 10.3 -u wxgtk26
    ... performing request on http://api.opensuse-community.org/searchservice/Search/Simple/openSUSE_103/w   10 results (5 packages) found for "wxgtk26" in openSUSE_103
    * wxGTK26: C++ Framework for Cross-Platform Development
       - 2.6.3.3 [BS::home:/accAgon | BS::home:/jnweiger]
         @ http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.3
         @ http://download.opensuse.org/repositories/home:/jnweiger/openSUSE_10.3
    * wxGTK26-compat: wxWidgets Compatibility Package
       - 2.6.3.3 [BS::home:/accAgon | BS::home:/jnweiger]
         @ http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.3
         @ http://download.opensuse.org/repositories/home:/jnweiger/openSUSE_10.3
    * wxGTK26-devel: Everything needed for development with wxGTK
       - 2.6.3.3 [BS::home:/accAgon | BS::home:/jnweiger]
         @ http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.3
         @ http://download.opensuse.org/repositories/home:/jnweiger/openSUSE_10.3
    * wxGTK26-gl: OpenGl add-on for wxGTK
       - 2.6.3.3 [BS::home:/accAgon | BS::home:/jnweiger]
         @ http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.3
         @ http://download.opensuse.org/repositories/home:/jnweiger/openSUSE_10.3
    * python-wxGTK26: Cross Platform GUI Toolkit for Python Using wxGTK
       - 2.6.3.3 [BS::home:/accAgon | BS::home:/jnweiger]
         @ http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.3
         @ http://download.opensuse.org/repositories/home:/jnweiger/openSUSE_10.3
    
    Damit könnte es möglich sein, wxgtk 2.6 parallel zu 2.8 zu installieren, ein Ersetzen würde ich mir _tunlichst_ verkneifen.

    Greetz,

    RM
     
Thema:

WxGtk 2.6 für OpenSuse 10.3

Die Seite wird geladen...

WxGtk 2.6 für OpenSuse 10.3 - Ähnliche Themen

  1. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...
  2. Empfehlung für Server Distribution

    Empfehlung für Server Distribution: Hallo, ich habe hier zu Hause einen kleinen Heimserver, auf welchem ich ein paar Daten für den Zugriff im Haus, einen kleinen Web Service für...
  3. Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten

    Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten: Hallo, ich habe 2 Problemchen. Ich kann nichts mehr installieren. Ich brauche aber unbedingt ein Brenn-Programm. Ein schönen Partitionierer usw....
  4. Welche Distri für Programming from the Ground Up

    Welche Distri für Programming from the Ground Up: Hallo! Ich möchter gerne das Buch Programming from the Ground Up durcharbeiten. savannah_nongnu_org/projects/pgubook/ Da geht es um Programmieren...
  5. Zeichen an Zeilenanfang für bestimmten Zeilenbereich einfügen

    Zeichen an Zeilenanfang für bestimmten Zeilenbereich einfügen: Hallo, ich würde gerne in einem Textdokument, z.B. von Zeile 10 - 18, an den Zeilenanfang ein # einfügen. Habe mir schon diverse Seiten zu SED...