SuSE 10 / Laptop / Lüfter läuft ständig / Centrino 2.0 GH

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von hermy, 15.12.2005.

  1. hermy

    hermy Tripel-As

    Dabei seit:
    05.12.2005
    Beiträge:
    215
    Zustimmungen:
    0
    :frage:
    Hallo,

    Linux läuft auf meinem ACER ja relativ gut, aber der Lüfter läuft die ganze Zeit (was unter Windows nicht der Fall ist.) Ich habe es schon mit dem throtteling versucht, aber da geht der Lüfter auch nach einer Zeit lang an.
    Leider hat meine Google-Suche auch nichts produktives ergeben.
    Meine Wunschvorstellung wäre ein Tool, dass mir die Temperatur des Prozessors und einige anderen Daten auf dem Desktop anzeigt und womit ich auch den Lüfter runterregulieren kann. Es würde mir auch nichts ausmachen, wenn der Prozessor nur mit 50 % Leistung arbeiten würde und mich der Lüfter dafür nicht permanent "berauschen" würde.

    mfg
    hermy
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. mo_no

    mo_no Linux User seit 2.0.35

    Dabei seit:
    29.09.2004
    Beiträge:
    1.134
    Zustimmungen:
    0
    Ausgabe der Temperatur:
    cat /proc/acpi/thermal_zone/THM/temperature

    Es gibt auf kde-look.org auch nette Desklets für Superkaramba.

    Ein Programm zur Lüftersteuerung ist mir nicht bekannt.
     
  4. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
  5. hermy

    hermy Tripel-As

    Dabei seit:
    05.12.2005
    Beiträge:
    215
    Zustimmungen:
    0
    @mo_no: vielen Dank für den Tip - ist echt klasse mit Superkaramba (leider gibt es nichts für den Lüfter):(

    @devilz: Ich hab ein Acer Aspire 1694 - ich bin auch auf den von dir angegebenen Seiten gewesen, doch hab ich leider zu meinem Problem nichts gefunden. Gibt es sonst noch Tools bzw. Möglichkeiten, das Lüfterproblem zu lösen?
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich wüßte jetzt nichts womit du das Lösen könntest - höchstens mit einem BIOS Update.
    Einige IBM Serien hatten auch dieses Problem das der Lüfter dauernd an war, wurde dann mit nem Update gefixt.
     
  7. hermy

    hermy Tripel-As

    Dabei seit:
    05.12.2005
    Beiträge:
    215
    Zustimmungen:
    0
    Ich bezweifle, dass es am Bios hängt - unter Windows geht es ja auch ohne permaneten Lüften. Hat sonst noch jemand eine Idee??
     
  8. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Tja, dann isses nen ACPI Problem - aber das is halt das typische Problem von Windows-Notebooks.

    Schau mal z.B. hier -> http://staschke.de/linux/md5400.html#luefter
     
  9. Andrea

    Andrea Routinier

    Dabei seit:
    01.12.2003
    Beiträge:
    418
    Zustimmungen:
    0
    Ort:
    Bielefeld
    Hallo,

    ich hatte so ein aehnliches Problem, unter Debian lief bei mir der Luefter kaum, dementsprechend heiss war dann das Notebook.
    Dann hab ich Ubuntu installiert und alles laeuft perfekt =)
    Vielleicht einfach eine andere Distribution ausprobieren?

    Andrea
     
  10. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen

    Jup - die Idee is gar nich so verkehrt ;) - Vielleicht sogar einfach mal die allerneuste Testversion von Ubuntu testen.
    (http://www.unixboard.de/vb3/showthread.php?t=16637)
     
  11. hermy

    hermy Tripel-As

    Dabei seit:
    05.12.2005
    Beiträge:
    215
    Zustimmungen:
    0
    Problem ist, das bei mir die Graphikkarte von den (zumindest vielen) LiveCDs nicht unterstützt wird - d.h. ich sehe reichlich wenig. Aber vielleicht wäre das die Lösung. Vielleicht werde ich es mal probieren - Vielen Dank
     
  12. #11 Paule99, 07.01.2006
    Paule99

    Paule99 Grünschnabel

    Dabei seit:
    07.01.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hi,

    bin zufällig bei ner Google-Suche auf diesen Thread gelangt.

    Mit hw-sensors kannst du deinen Lüfter abhängig von der Temperatur regeln:
    -Sensors über Yast installieren
    -"sensors-detect" ausführen. Am Ende bekommst du ne ausgabe welche module in welcher Reihenfolge gestartet werden müssen.
    - nach dem laden der Module zum Testen "sensors" aufrufen, du bekommst dann die aktuellen Lüfterdrehzahlen, Temperaturen und Spannungen angezeigt
    -"pwmconfig" ausführen (hat bei mir zwei anläufe gebraucht bevor es funktioniert hat.
    -in pwmconfig die gewünschte Temperatur einstellen ab wann der Lüfter anfangen soll zu drehen und ab welcher Temperatur mit voller Drehzahl gearbeitet werden soll
    -"fancontrol /etc/fancontrol" starten /falls du dein config-file von fancontrol nicht unter /etc/fancontrol gespeichert hast natürlich entsprechend anpassen
    -leises Notebook geniessen

    Hab mich ziemlich kurz gefasst da das Problem vielleicht nicht mehr aktuell ist, bei fragen einfach nen kurzes Reply.

    Zusätzlich macht es noch Sinn die Core-Spannung von Prozessor zu senken, das senkt die Temperatur der CPU erheblich. Allerdings muss dafür ein neuer Kernel kompiliert werden.

    Gruß
    Paule
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 evgher, 19.01.2006
    Zuletzt bearbeitet: 19.01.2006
    evgher

    evgher Grünschnabel

    Dabei seit:
    19.01.2006
    Beiträge:
    8
    Zustimmungen:
    0
    ich hab vor kurzem einen Shell-skript geschrieben,
    dass die Lüftersteuerung unter SUSE 10
    auf Medion-Laptop vornimmt.

    Dabei benutzte ich die Tatsache, dass sobald der Lüfter sich abschaltet,
    Polling_frequenz deaktiviert werden muss

    echo -X > /proc/acpi/thermal_zone/THRM/polling_frequency

    dann wartet man bis der Prozessor bis 70°C warm wird,
    und aktiviert den Polling_frequenz.

    Das ganze wird bei Systemstart geladen.
    Und so hab ich schon Zeiten erlebt wo der Lüfter
    mehr als 30 Minuten keine lästige, unangenehme Geraüsche von sich gab.

    mit dem Konsolenbefehl:

    watch -n2 powersave -T

    kannst du die Temperatur zur Laufzeit beobachten.

    Überprüfe ob bei dir dieser Befehl funktioniert:
    echo -X > /proc/acpi/thermal_zone/THRM/polling_frequency
    Warte die Zeit wo der Lüfter ausgeht und führe ihn zu dieser Zeit aus.

    wenn der Rechner zu heiss wird:
    echo -1 > /proc/acpi/thermal_zone/THRM/polling_frequency

    -1 bzw standardmässig -60


    Sollte der Lüfter garnicht sich abschalten.

    probiere mal die Konsolenbefehle:

    echo -n 0 > /proc/acpi/thermal_zone/fan/FN2/state

    echo -n 3 > /proc/acpi/thermal_zone/fan/FN2/state

    nacheinander eintippen.



    Wenn alle Befehle so funktionieren, wie ich's beschrieben hab,
    so würde bei dir mein Skript auch funktionieren.

    MfG
     
  15. hermy

    hermy Tripel-As

    Dabei seit:
    05.12.2005
    Beiträge:
    215
    Zustimmungen:
    0
    Also, ich habe "sensors-detect" ausgeführt. Da habe ich folgende Ausgabe bekommen
    Ich hab

    "# I2C module options
    alias char-major-89 i2c-dev"

    in /etc/modprobe.conf hineinkopiert.

    Was ist allerdings mit /etc/rc* <--- Sternchen gemeint? Bei mir gibt es da einen /etc/rc.d ORDNER, in dem wieder x andere Dateien drin sind. Weiß jemand zufällig, wo ich die Sachen hineinkopieren muss?

    mfg
    hermy
     
Thema:

SuSE 10 / Laptop / Lüfter läuft ständig / Centrino 2.0 GH

Die Seite wird geladen...

SuSE 10 / Laptop / Lüfter läuft ständig / Centrino 2.0 GH - Ähnliche Themen

  1. OpenSuse 11.3, Lenovo X300 SSD - Laptop hängt sich ständig auf

    OpenSuse 11.3, Lenovo X300 SSD - Laptop hängt sich ständig auf: Hallo Leute, ich hab folgendes System: Ein Lenovo X300 inkl SSD Festplatte Die ganze Zeit war auf dem System OpenSuse 11.2 + KDE...
  2. Laptop wird unter SuSe super heiß und stürzt regelm. ab

    Laptop wird unter SuSe super heiß und stürzt regelm. ab: Hallo zusammen, ich hoffe, hier kann mir jemand weiter helfen. Ich nutze Open Suse auf meinem Laptop (Acer Aspire 4935g, 2 GHz, 4 GB Ram,...
  3. ALC660-VD und Alsa auf Suse 11.0 / Asus-Laptop - kein Sound

    ALC660-VD und Alsa auf Suse 11.0 / Asus-Laptop - kein Sound: Hallo, ich habe eine Asus Z83U Laptop mit einer Soundkarte die als ALC660-VD erkannt wird. Alsa (1.0.16-39.1) erkennt diese auch richtig und...
  4. Opensuse 10.2: Laptop soll primärer Monitor werden. WIE?

    Opensuse 10.2: Laptop soll primärer Monitor werden. WIE?: ich bin schon lange auf der Suche, wie ich endlich meinem Laptop bei bringe, dass dieses der Primäre Monitor ist und nicht der externe TFT....
  5. openSuse 10.1 auf Laptop installiert, bootet aber nicht

    openSuse 10.1 auf Laptop installiert, bootet aber nicht: Guten Morgen, ich wollte mal wieder eine Linux Dist. ausprobieren und dieses mal nicht Ubuntu nehmen (lief bei mir nie sonderlich gut). Also...