Starten von Apache2 in Kubuntu

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von hawo, 23.08.2010.

  1. hawo

    hawo Grünschnabel

    Dabei seit:
    21.08.2010
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Würenlos, Schweiz
    Hallo
    Ich bin Ende Juli 2010 von Windows auf KUBUNTU 10.04 umgestiegen. Ich wollte den Apache2 nutzen.
    Wenn ich den Apache2 Server starten will, erhalte ich fogende Fehlermeldung:
    ------------
    haschka@wolfgang:~$ /usr/sbin/apache2ctl start
    apache2: Syntax error on line 236 of /etc/apache2/apache2.conf: Syntax error on line 49 of /etc/apache2/sites-enabled/000-default: </VirtualHost> without matching <VirtualHost> section
    haschka@wolfgang:~$
    ------------
    Wenn ich die entsprechenden Files aufsuche, finde ich folgenden Code
    bei den entsprechenden Zeilen
    apache2.conf
    -------------
    235 # Include the virtual host configurations:
    236 Include /etc/apache2/sites-enabled/
    -------------
    der Code von 000-default lautet
    ------------

    i<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews




    AllowOverride all
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>
    -------------------------

    (Ich wundere mich über das "i" am Anfang des Textes)

    Was ist da nicht richtig?? Was mache ich falsch????
    Betsen Dank
    Wolfgang
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 HeadCrash, 23.08.2010
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Moin

    das steht ein "i" vor deiner VirtualHost-Anweisung

    Code:
    i<VirtualHost *:80>
    
    mfg
    HeadCrash
     
  4. hawo

    hawo Grünschnabel

    Dabei seit:
    21.08.2010
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Würenlos, Schweiz
    Danke für die rasche Antwort
    Fiel mir auch schon auf, aber leider ist es mir nicht möglich diesen Buchstaben aus dem Text zu entfernen. Ich habe als Administrator mit Kate keine Schreibberechtigung, ich kann praktische kein File ändern, auch beim Laden von einzelnen Programmen wartet er auf eine Berechtigung und stirbt dann am Timeout.
    Habe ich bei der Installation von Kubuntu etwas falsch gemacht??
    Gruss
    Wolfgang
     
  5. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Editiers doch mal ueber den Terminal.

    sudo kate /etc/apache2/sites-enabled/000-default

    oder mit einem anderen Editor wie vim oder nano.
     
  6. hawo

    hawo Grünschnabel

    Dabei seit:
    21.08.2010
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Würenlos, Schweiz
    Hallo
    Habe ich gemacht und das File ist jetzt ohne "i". hat funktioniert
    Nur habe ich in der Konsole diese Fhlermeldung erhalten? Ist das normal?
    --------------
    haschka@wolfgang:~$ sudo kate /etc/apache2/sites-enabled/000-default
    [sudo] password for haschka:
    Error: "/var/tmp/kdecache-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/tmp/kde-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/tmp/kde-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/tmp/ksocket-haschka" is owned by uid 1000 instead of uid 0.
    kdeinit4: Shutting down running client.
    kdeinit4: preparing to launch /usr/lib/libkdeinit4_klauncher.so
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    Error: "/tmp/ksocket-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/tmp/kde-haschka" is owned by uid 1000 instead of uid 0.
    kdeinit4: preparing to launch /usr/lib/libkdeinit4_kded4.so
    Error: "/var/tmp/kdecache-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/tmp/kde-haschka" is owned by uid 1000 instead of uid 0.
    kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
    kbuildsycoca4 running...
    Error: "/var/tmp/kdecache-haschka" is owned by uid 1000 instead of uid 0.
    Error: "/var/tmp/kdecache-haschka" is owned by uid 1000 instead of uid 0.
    kdeinit4: preparing to launch /usr/lib/libkdeinit4_kconf_update.so
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kate(3937)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
    kate(3937)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/home/haschka/.local/share/mime/magic"
    Error: "/tmp/ksocket-haschka" is owned by uid 1000 instead of uid 0.
    kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
    kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
    kio_file(3979) kdemain: Starting 3979
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /home/haschka/.config/ibus/bus
    Bus::open: Can not get ibus-daemon's address.
    IBusInputContext::createInputContext: no connection to ibus-daemon
    kate(3937)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
    kate(3937)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/home/haschka/.local/share/mime/magic"
    kate(3937)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libkonsolepart.so"
    haschka@wolfgang:~$
    ----------------------------
    Gruss
    Wolfgang
     
  7. hawo

    hawo Grünschnabel

    Dabei seit:
    21.08.2010
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Würenlos, Schweiz
    Danke an Hardcrash und Dizzi
    Ich konnte jetzt den Apache2 starten und stoppen und der Localhost meldet dass er funktioniert (wenn auch mit Reklamationen)
    Mit besten Dank
    Wolfgang
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Starten von Apache2 in Kubuntu

Die Seite wird geladen...

Starten von Apache2 in Kubuntu - Ähnliche Themen

  1. apache2 läßt sich auf 1blu vServer nicht mehr starten

    apache2 läßt sich auf 1blu vServer nicht mehr starten: Moin! Ich habe seit gestern morgen ein Problem mit einem vServer. Der Server Webserver war "plötzlich" - also ohne mein zutun - nicht mehr...
  2. Apache2 von der shell Konsole bei freeBSD starten

    Apache2 von der shell Konsole bei freeBSD starten: hi wie kann ich Apache2 von der shell Konsole bei freeBSD 5.2.1 starten ?
  3. DragonBox Pyra: Vorbestellungen starten

    DragonBox Pyra: Vorbestellungen starten: Der Nachfolger der OpenPandora, DragonBox Pyra, kann ab sofort vorbestellt werden. Die Konsole ist in verschiedenen Varianten verfügbar und...
  4. Vorbestellungen für OpenBSD 5.9 starten

    Vorbestellungen für OpenBSD 5.9 starten: Zahlreiche Neuerungen und Erweiterungen wurden in OpenBSD 5.9 in dem halben Jahr seit der Freigabe von OpenBSD 5.8 eingebracht. Nun steht die...
  5. Service oder Screen überwachen und ggf. Neustarten?!

    Service oder Screen überwachen und ggf. Neustarten?!: Hallo liebe Community. Leider habe ich nichts passendes gefunden, weshalb ich nun diesen Thread aufmache. Ich habe einen Gameserver den...