ssl und apache2

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von derfriese, 10.10.2005.

  1. #1 derfriese, 10.10.2005
    derfriese

    derfriese Grünschnabel

    Dabei seit:
    15.03.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Moin Moin Forum

    ich hoffe Ihr koennt mir weiterhelfen .. komme nicht weiter:

    habe hier n apache2


    ich habe die eintraege in sites-available/default-ssl gemacht

    die seite bekannt gemacht und ebenso das modul ssl, mit
    a2enmod a2ensite

    ich habe vorher die certifakte erstellt mit
    apache2-ssl-certificate

    dann war ich mir nicht sicher ab das so hin haut .. also hab ich nochmal private.key und crt mit openssl erstellt und diese auch in das apache2/ssl
    verzeichniss gelegt

    die pfade bei

    SSLCertificateFile /etc/apache2/ssl/XXXx.crt
    SSLCertificateKeyFile /etc/apache2/sslXXX.private.key

    natuerlich angepasst .. aber ich bekomme einfach kein https://localhost verbindung hin

    im log taucht nur sowas wie
    [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-16 mod_ssl/2.0.54 OpenSSL/0.9.7e configured -- resuming normal operations

    beim start des apache's auf :-//

    koennte nen TIP gebrauchen oder vieleicht ne schritt fuer schritt anleitung :-/

    die doku auf http://www.modssl.org hab ich am start
    aber leider hat mir das nicht viel geholfen ...

    vieleicht sehe ich auch nur n wald vor lauter baeumen nicht

    schon mal danke im vorraus hoffe ihr koennt mir helfen

    gruss Torben

    ps:bin ansonsten nach der anleitung vorgegangen
    http://www.debianhowto.de/de:howtos:sarge:lamp_suphp
    also halt nur der abschnitt zu apache2 und ssl
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 10.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  4. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Danke für den Tip mit der Anleitung . Ich hab alles so gemacht wie es im Tutorial stand und bei mir lief alles auf anhieb.

    Kann es sein , dass du vielleicht einen Schritt übersehen hast , oder den Webserver noch nicht neu geladen ?

    vielleicht ist es nur ein dummer Tippfehler , oder du hast irgdendwo noch nen Punkt zuviel oder so .

    Gruß Sono
     
  5. #4 derfriese, 10.10.2005
    derfriese

    derfriese Grünschnabel

    Dabei seit:
    15.03.2005
    Beiträge:
    3
    Zustimmungen:
    0
    ja die anleitung ist super ;-) ....

    ich hab das ganze auch nochmal auf nem anderen server gemacht ... da ging es auch ohne probleme :-/ ....

    jedoch auf dem wo es laufen soll nicht ist n debian mit 2.4 kernel ... koennte es daran liegen ?

    wenn ich es mit w3m https://localhost versuche

    kommt im browser folgende meldung

    SSL error: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
     
  6. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    hast du vielleicht Probeleme mit dem Zertifikat ?

    Mach mal ein neues , vielleicht ging da was schief . Hast du vielleicht vergessen dieses "zufallswert" für den Zertifikatsnamen zu ändern ?

    hast du apache2 qn den port 443 gebunden ?

    Ich glaube nicht dass es der 2.6 er Kernel ist . Ich hab nämlich auch nen 2.6er laufen.

    Vielleicht ging ja beim laden des moduls in apache was schief , lade das nochmal . Am besten du machst die anleitung schritt für schritt nochmal durch .

    Ist zwar lästig aber das hat mir persönlich geholfen als mein Xen beim installiere nicht so wollte ich dachte das es gehen sollte. Dann hab ich gesehen dass ich natürlich die hälfte vergessen habe und plötzlich gings auch.

    Was anderes kann ich dir leiter nicht raten , wie gesagt es ging bei mir ohne Probleme.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 damager, 10.10.2005
    Zuletzt bearbeitet: 10.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    was sagt den das error_log?
    irgendwas mit "invalid access method" oder so?

    poste mal die ausgabe von:
    openssl s_client -connect localhost:443 -state -debug
     
  9. #7 derfriese, 19.10.2005
    derfriese

    derfriese Grünschnabel

    Dabei seit:
    15.03.2005
    Beiträge:
    3
    Zustimmungen:
    0
Thema:

ssl und apache2

Die Seite wird geladen...

ssl und apache2 - Ähnliche Themen

  1. Apache2 mod_proxy

    Apache2 mod_proxy: Hallo Gemeinde, ich raff es einfach nicht. Ich habe mir den Apache2-Server als Proxy eingerichtet, damit ich mir hinter meiner Firewall über...
  2. Newbie:apache2/befehl htdigest Problem

    Newbie:apache2/befehl htdigest Problem: Hallo Leute, ich habe ein Problem mit diesem Befehl: htdigest -c /etc/apache2/passwords xxxxx xxxxx xxxx= usernamen sollen eingefügt werden...
  3. apache2: Virtualhost ohne subdomain

    apache2: Virtualhost ohne subdomain: Hi, ich möchte bei apache einen virtualhost für fqdn.de/testname einrichten. Folgendes habe ich (unter Anderem) in der entsprechenden Datei im...
  4. Problem mit Apache2 + MySQL Server

    Problem mit Apache2 + MySQL Server: Guten Mittag allen zusammen, ich möchte nun in ein Forum nachfragen bezüglich meines Problemes da ich leider derzeit einen Freund (der mir bisher...
  5. apache2 und ProxyPassReverse

    apache2 und ProxyPassReverse: Hey Leute, also irgendwas ist wieder im Busch :) vhost ausschnitt: ServerName fu.mydomain.com ProxyPass / http://localhost:7070/...