mod_ssl & openssl

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von aeson, 27.05.2007.

  1. #1 aeson, 27.05.2007
    Zuletzt bearbeitet: 27.05.2007
    aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,

    ich möchte ein bestimmtes Verzeichnis festlegen indem ich alle Dokumentre ablege die nur über SSL erreichbar sein sollen. Bisher habe ich folgendes gemacht:

    1. apt-get install openssl
    --> mit openssl ein Zertifikat zu testzwecken erstellt

    2. httpd.conf von apache2 im Verzeichniss /etc/apache2/ um folgendes erweitert:

    LoadModule ssl_module /usr/lib/apache2/modules/mod_ssl.so
    SSLMutex default
    SSLRandomSeed startup builtin
    SSLSessionCache none
    <VirtualHost *:443>
    SSLEngine On
    SSLCertificateFile etc/ssl/testzertifikat.cert
    SSLCertificateKeyFile etc/ssl/testzertifikat.key
    DocumentRoot /home/$username/sichere_seiten
    </VirtualHost>

    3. port.conf um folgendes erweitert:
    Listen 433


    Wenn ich jetzt den apache2 neu starten will gibt er mir folgende Meldung:
    Das SSL funktioniert zwar irgendwie und er zeigt mir auch mein Zertifikat an. Aber ich kann erstens nur noch über https zugreifen und gar nicht mehr über http und außerdem zeigt er mir nicht mehr den Inhalt an.

    Hab schon sämtliche Seiten durchforstet. Mit der bin ich bisher am weitesten gekommen:
    http://buecher.lingoworld.de/apache2/mod_ssl.html
    Die Seite von Apache2 hat mich mal wieder gar nicht weitergebracht.

    Wäre nett wenn mir einer von euch einen Tipp geben könnte :)
    Vielen Dank!
    aeson
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Mµ*e^13.5_?¿, 27.05.2007
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Du musst den normalen vhost so konfigurieren, dass er nur noch auf einem bestimmten Port lauscht (also für gewöhnlich 80).
    Wenn du an deinem Apache noch nicht sonderlich viel rum konfiguriert hast, sollte es reichen die Datei /etc/apache2/sites-enabled/000-default etwa so anzupassen:
    Code:
    NameVirtualHost *:80
    <VirtualHost *:80>
    [..] der Rest ist dafür irrelevant
     
  4. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,

    das hat leider auch nicht geholfen. Ist leider immer noch der selbe Fehler wie vorher. Um ein bisschen Licht in das Dunkel zu bringen Poste ich mal meine httpd.conf, 000-default & port.conf.

    httpd.conf im Verzeichnis /etc/apache2/:

    Bemerkung: Das Zertifikat "testzertifikat" existiert!
    Bemerkung2: linux ist der Username mit dem ich teste!

    000-default im Verzeichnis /etc/apache2/sites-enabled

    port.conf im Verzeichnis /etc/apache2/:


    Wenn alle Einstellungen so vorgenommen sind wir hier gezeigt bekomme ich folgendes Bild angezeigt wenn ich mit dem Konqueror die Adresse
    http://localhost/ aufrufe.

    [​IMG]

    Wenn ich hier dann auf den https verweis klicke bekomme ich folgendes Fenster zu sehen:

    [​IMG]

    Das Problem ist halt das sich ohne SSL halt Inhalt in diesem Fenster befindet.

    Ich freu mich auf jede Antwort! Vielen Dank!
    gruß
    aeson
     
  5. #4 Mµ*e^13.5_?¿, 28.05.2007
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Hm .. was soll der zweite vhost in der 000-default?
    Mir scheint das keinen Sinn zu machen, weil du für Port 80 ja schon einen definiert hast, also würd ich den zweiten da einfach mal komplett raus schmeißen.
    In der httpd.conf, würde ich mal versuchen noch NameVirtualHost *:443 davor einzutragen.
     
  6. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Ok ich hab es jetzt hinbekommen das ich wenigstens schon mal im SSL Modus alle Dateien sehen kann aber jetzt habe ich das Problem das ich nur im SSL Modus alles sehen kann und ohne bekomme ich den Screenshot von oben mit der Fehlermeldung Bad Request. Hat jemand eine Idee woran das liegen kann?
     
Thema:

mod_ssl & openssl

Die Seite wird geladen...

mod_ssl & openssl - Ähnliche Themen

  1. Problem mit Apache und mod_ssl bei Client Zertifikaten

    Problem mit Apache und mod_ssl bei Client Zertifikaten: Inzwischen bin ich am Verzweifeln. Ich versuche, einen durch SSL gesicherten Server zusätzlich durch die Überprüfung von Client-Zertifikaten...
  2. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  3. BSI-Audit findet keine akute Probleme in OpenSSL

    BSI-Audit findet keine akute Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  4. OpenSSL-Sicherheit im Rückblick

    OpenSSL-Sicherheit im Rückblick: Das OpenSSL-Projekt hat eine Bilanz der Sicherheitslücken der letzten zwölf Monate gezogen. Höhere Sicherheit ist das wichtigste Ziel des...
  5. Lizenzwechsel bei OpenSSL

    Lizenzwechsel bei OpenSSL: Das OpenSSL-Projekt will die eigene Lizenz ändern und die Quellen künftig unter den Bedingungen der Apache-2.0-Lizenz vertreiben. Zudem sollen...