Schriftgröße in virtueller Konsole zu klein

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von zst, 28.10.2010.

  1. zst

    zst Foren As

    Dabei seit:
    06.09.2006
    Beiträge:
    95
    Zustimmungen:
    0
    Hallo,
    nach dem opensuse-Update von 11.0 auf 11.3 ist die Schriftgröße der virtuellen Konsolen (STRG+ALT+F1 ...6) sehr klein. Bisher reichte es, im grub vga=normal zu setzen, das ändert aber leider nichts.

    Hat jemand eine Idee?

    DANKE!
    Gruß zst
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Gast123, 28.10.2010
    Gast123

    Gast123 Guest

    It's not a bug, it's a feature!
    Seit openSUSE 11.3 wird die Konsole automatisch an die Bildschirmauflösung angepasst, sodass diese insbesondere bei Breitbildschirmen nicht "verschwommen" aussieht.

    LG
    Schard
     
  4. #3 marcellus, 29.10.2010
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Natürlich ist eine konsole mit 640x480 auch etwas sucky. Du kannst aber nach belieben eine andere(größere) Schriftart einstellen, hier macht man das in /etc/conf.d/consolefont, aber ich hab keine Ahnung wo man das in suse macht.
     
  5. zst

    zst Foren As

    Dabei seit:
    06.09.2006
    Beiträge:
    95
    Zustimmungen:
    0
    Hallo,

    vielen Dank für die Infos.
    Kann mir jemand sagen, wie ich diese neue Automatik (Konsole wird automatisch an die Bildschirmauflösung angepasst) umgehen kann / abschalten kann?
    (Es geht um Server, ich benötige NUR die Konsolen, keine Grafik.)

    Danke+Gruß
    zst
     
  6. #5 Krotti, 29.10.2010
    Zuletzt bearbeitet: 30.10.2010
    Krotti

    Krotti Foren As

    Dabei seit:
    01.03.2007
    Beiträge:
    78
    Zustimmungen:
    0
    KMS ist hier der Übeltäter (Ist aber nicht negativ gemeint)...

    Anbei zwei Möglichkeiten, wobei ich letztere getestet habe:

    1)
    KMS deaktivieren (Kernelparameter bei Grub). Für genauere Details hilft die Suchmaschine deiner Wahl.

    2)
    In der Grub Config video=<gewünschte Auflösung> anstatt vga=<Parameter> eintragen.

    Beispiel:

    Code:
    title openSUSE 11.3 (64 Bit)
        root (hd1,2)
        kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_ST3160023A_3JS33YRE-part3 quiet showopts [B]video=1024x768[/B]
        initrd /boot/initrd
    
    Für Details:
    http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=d50ba256b

    Anmerkung:
    Ich habe nur eine Auflösung verwendet, die meine Grafikkarte laut hwinfo --framebuffer unterstützt. Diese Angaben hab ich
    von meinem derzeitigen Hauptsystem (openSUSE 11.0) übernommen, weil anscheinend dieses Verfahren (?noch?) keine
    Ausgabe unter 11.3 liefert.
    Das Schlimmste was passieren könnte ist, dass der Bildschirm bei einer falschen Einstellung schwarz bleibt.

    PS:
    Die Schriftart kann unter /etc/sysconfig/console --> CONSOLE_FONT geändert werden.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. zst

    zst Foren As

    Dabei seit:
    06.09.2006
    Beiträge:
    95
    Zustimmungen:
    0
    Hallo Krotti,

    vielen Dank für diese Infos. Ich werde deine Vorschläge in einer ruhigen Minute nachlesen und probieren.

    Zwischenzeitlich habe ich als Notlösung auf das Verändern der Schriftart zurück gegriffen.
    Da es keine Schriftart auf dem opensuse-System gab, die für mich in Frage kam, habe ich das Paket terminus_font runter geladen und in der von dir genannten CONSOLE_FONT geändert.
    PHANTASTISCH !!!
    Für alle, die hier nicht weiter probieren wollen, eine sehr akzeptable Lösung.

    DANKE und Gruß
    zst
     
  9. zst

    zst Foren As

    Dabei seit:
    06.09.2006
    Beiträge:
    95
    Zustimmungen:
    0
    Hallo Krotti,

    dein Vorschlag 2 ist ja doch ganz einfach.
    Ich habe video=800x600 gewählt und es sieht aus wie unter opensuse 11.0 (mit damals vga=normal).

    Vielen Dank an alle, die zur Lösung beigetragen haben!
    Gruß zst
     
Thema:

Schriftgröße in virtueller Konsole zu klein

Die Seite wird geladen...

Schriftgröße in virtueller Konsole zu klein - Ähnliche Themen

  1. Nach Grafiktreiber-Installation äußerst kleine Schriftgröße

    Nach Grafiktreiber-Installation äußerst kleine Schriftgröße: Hallo zusammen, ich bin neu hier und habe mir gestern openSUSE 13.1 parallel zu Windows installiert. Anschließend habe ich direkt den...
  2. Monitor getauscht, Schriftgrößen verstellt

    Monitor getauscht, Schriftgrößen verstellt: Hi, Bin mit Slackware 12.2 und Xfce4 unterwegs. Habe einen defekten LCD-Monitor gegen dasselbe Model getauscht (Flatron LCD 885LE). Die...
  3. Cygwin Schriftgröße in der GUI

    Cygwin Schriftgröße in der GUI: Hallo erstmal! Hoffe ich poste hier richtig. Habe ein Problem mit Cygwin. Habe mir das Programm Ghemical mittels Cygwin auf windows...
  4. Debian 4 - KDE - Schriftgröße

    Debian 4 - KDE - Schriftgröße: Nach längerem hin und her habe ich mir Debian so hergerichtet, dass ich damit arbeit kann. Einziger Fehler: Ich benutze ein Notebook mit 12800...
  5. Schriftgröße per Skript ändern

    Schriftgröße per Skript ändern: Hallo alle, ich suche eine Möglichkeit, die Schriftgröße des Desktops/der Desktopanwendungen per Skript zu ändern. Konkret geht es darum...