rpm dependencies

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von flashGordon, 23.06.2006.

  1. #1 flashGordon, 23.06.2006
    flashGordon

    flashGordon Grünschnabel

    Dabei seit:
    23.06.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Ort:
    Bremen
    Hi,

    bin Linux-Neuling — das sei vorweg gesagt...
    Ich beiße mir gerade die Zähne am RPM von Fedora Core 5 aus. Alles, was ich möchte, ist das java Paket updaten. Als Fehlermeldung beim Aufruf von
    Code:
    rpm -Uvh jre-1_5_0_07-linux-i586.rpm
    erhalte ich dann einen haufen dependency-errors. Ist ja auch irgendwie klar, wenn Programme darauf zugreifen. Aber was muss ich nun tun? Soll ich alle Programme vorher beenden (wie?) oder gibt's da einen einfacheren Weg?

    Hier die Ausgabe:
    Code:
    [root@fedora java]# rpm -Uvh jre-1_5_0_07-linux-i586.rpm
    error: Failed dependencies:
            jaas is needed by (installed) tomcat5-server-lib-5.5.15-1jpp_6fc.i386
            java >= 0:1.4 is needed by (installed) jessie-1.0.1-3.i386
            java is needed by (installed) wsdl4j-1.5.1-1jpp_4fc.noarch
            java is needed by (installed) axis-1.2.1-2jpp_2fc.noarch
            java >= 0:1.4.2 is needed by (installed) tomcat5-common-lib-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-logging-1.0.4-2jpp_10fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) xml-commons-apis-1.3.02-0.b2.7jpp_7fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-servlet-2.4-api-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-collections-3.1-2jpp_5fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-beanutils-1.7.0-2jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-digester-1.7-2jpp_10fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-jasper-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) gnu-crypto-2.1.0-1jpp_2fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-el-1.0-4jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) regexp-1.3-2jpp_7fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-jsp-2.0-api-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-daemon-1.0-2jpp_4fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) xerces-j2-2.7.1-6jpp_7fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) ant-1.6.5-1jpp_7fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) xalan-j2-2.6.0-3jpp_9fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) mx4j-3.0.1-1jpp_9fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-modeler-1.1-4jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-server-lib-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) geronimo-specs-1.0-0.M2.2jpp_7fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-common-lib-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) tomcat5-5.5.15-1jpp_6fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) jakarta-commons-validator-1.1.4-1jpp_5fc.i386
            java-gcj-compat >= 1.0.31 is needed by (installed) struts-1.2.8-2jpp_9fc.i386
            java-gcj-compat >= 1.0.43 is needed by (installed) eclipse-ecj-3.1.2-1jpp_15fc.i386
            java-sasl is needed by (installed) classpathx-mail-1.0-4jpp_5fc.noarch
            java-sasl is needed by (installed) gnu-crypto-2.1.0-1jpp_2fc.i386
            java-sasl is needed by (installed) jessie-1.0.1-3.i386
            java-sasl is needed by (installed) ldapjdk-4.17-1jpp_3fc.1.1.noarch
            jce is needed by (installed) classpathx-mail-1.0-4jpp_5fc.noarch
            jce is needed by (installed) gnu-crypto-2.1.0-1jpp_2fc.i386
            jce is needed by (installed) jessie-1.0.1-3.i386
            jce is needed by (installed) mx4j-3.0.1-1jpp_9fc.i386
            jdbc-stdext is needed by (installed) tomcat5-common-lib-5.5.15-1jpp_6fc.i386
            jdbc-stdext is needed by (installed) struts-1.2.8-2jpp_9fc.i386
            jndi is needed by (installed) ldapjdk-4.17-1jpp_3fc.1.1.noarch
            jndi is needed by (installed) tomcat5-common-lib-5.5.15-1jpp_6fc.i386
            jsse is needed by (installed) mx4j-3.0.1-1jpp_9fc.i386
            java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_83rh is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_83rh.i386
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 theton, 23.06.2006
    Zuletzt bearbeitet: 23.06.2006
    theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Und warum aktualisierst du nicht mit yum? Wenn du schon nen einzelnes RPM nimmst, wirst du nicht drumrum kommen alle anderen abhaengigen Pakete auch zu aktualisieren oder halt mit Force-Optionen installieren, aber das kann maechtig nach hinten losgehen und dann geht evtl. garnichts mehr, was du an Java-Kram installiert hast.
     
  4. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Das hat nichts damit zu tun, dass diese Programme laufen, sondern dass diese Programme auf Funktionen zugreifen die Bestandteil des java-Paketes sind.
    Einzelne RPM's zu installieren kann hin- und wieder schon zu Tobsuchtsanfällen führen, daher rate ich Dir das was theton schon sagte. Nimm yum odere installiere dir apt4rpm und nimm dann dieses.
     
  5. #4 flashGordon, 23.06.2006
    flashGordon

    flashGordon Grünschnabel

    Dabei seit:
    23.06.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Ort:
    Bremen
    Ah, ok. Danke. Ich wollte halt nur alles mal ausprobieren und dachte rpm wäre eine gängige Methode, ein Paket upzudaten. Jetzt weiß ich jedenfalls, wie's theoretisch funktioniert und werd weiterhin yum benutzen.
    Danke!
     
  6. #5 intelinsider, 23.06.2006
    intelinsider

    intelinsider coffee addicted

    Dabei seit:
    30.04.2005
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Tor zur Welt [Hamburg/Barmbek]
    Yum, Yumex, rpm

    Manuelle sich RPM zu installieren ist wie schon erwaehnt teilweise recht aufwendig, deswegen sollte man sich am besten mit Yum auseinander setzen als zusaetzliche Quelle wuerde ich noch unbedingt zu Livna raten http://rpm.livna.org, Yumex bietet dir eine Grafische Installer moeglichkeit ( yum install yumex ) hier bitte aufpassen das du dich nur auf 4 Quellen Core, Updates, Extras und Livna beziehst und nicht die Dev Quellen hinzuaktivierst so kann sich das System auch mal schnell verabschieden...
    Fuer RPM ansonsten http://www.tu-chemnitz.de/docs/lindocs/RPM/


    mfg ii
     
Thema:

rpm dependencies

Die Seite wird geladen...

rpm dependencies - Ähnliche Themen

  1. Opensuse 10.2 Update - unresolved dependencies?

    Opensuse 10.2 Update - unresolved dependencies?: Immer wenn ich Updaten bekomme ich diesen Fehler. Das Problem daran ist das er dadurch überhaupt keine Pakete updated. Wie kann ich das fixen oder...
  2. openSuse 10.3 Beta: error: Failed build dependencies: kernel-dummy is needed

    openSuse 10.3 Beta: error: Failed build dependencies: kernel-dummy is needed: Morgens, ich probiere gerade openSuse 10.3 und wollte mir nun die passenden Kernel-Sourcen von...
  3. apt4rpm - brocken dependencies

    apt4rpm - brocken dependencies: was ist das Pendant zu --force bei apt4rpm? (und ich meine nicht -o rpm::options::=--force) Ich habe folgendes Problem: Eigentlich wuerde...