pkgsrc - ezm3 kompiliert nicht unter (draco) Linux

Dieses Thema im Forum "Sonstige Linux Distributionen" wurde erstellt von akuta, 13.07.2008.

  1. akuta

    akuta Grünschnabel

    Dabei seit:
    13.07.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    ich weiss nicht ob das Thema hier richtig ist, oder unter NetBSD besser aufgehoben wäre, naja, wie auch immer.

    Ich habe mir mal Draco GNU/Linux installiert und habe jetzt ein Problem mit der Installation von cvsup. Draco benutzt pkgsrc als Paketmanager.

    Beim Installieren von cvsup wird auch ezm3 als Abhängigkeit installiert. Beim Kompilieren von ezm3 bricht pkgsrc aber mit ein paar Fehlermeldungen ab.

    Code:
    => No binary package found for ezm3>=1.2nb1; installing from source.
    => Bootstrap dependency digest>=20010302: found digest-20070803
    ===> Installing for ezm3-1.2nb2
    cd boot-LINUXLIBC6/m3core/LINUXLIBC6; /usr/bin/make -f make.boot "CC=gcc" "CFLAGS=" "AS=as" "ASFLAGS=" "AR=ar" "ARFLAGS=rv" "RANLIB=touch"
    "EXTRALIBS=-lm" "LDFLAGS=-Wl,-R/usr/local/lib"
    make[1]: Entering directory `/usr/pkgsrc/lang/ezm3/work/ezm3-1.2/boot-LINUXLIBC6/m3core/LINUXLIBC6'
    gcc    -c -o RTStackC.o RTStackC.c
    RTStackC.c: In function 'RTStack__GetThreadFrame':
    RTStackC.c:30: error: 'JB_PC' undeclared (first use in this function)
    RTStackC.c:30: error: (Each undeclared identifier is reported only once
    RTStackC.c:30: error: for each function it appears in.)
    RTStackC.c:31: error: 'JB_BP' undeclared (first use in this function)
    RTStackC.c:32: error: 'JB_SP' undeclared (first use in this function)
    RTStackC.c: In function 'RTStack__Unwind':
    RTStackC.c:52: warning: incompatible implicit declaration of built-in function 'abort'
    make[1]: *** [RTStackC.o] Error 1
    make[1]: Leaving directory `/usr/pkgsrc/lang/ezm3/work/ezm3-1.2/boot-LINUXLIBC6/m3core/LINUXLIBC6'
    make: *** [boot] Error 2
    *** Error code 2
    
    Stop.
    bmake: stopped in /usr/pkgsrc/lang/ezm3
    *** Error code 1
    
    Stop.
    bmake: stopped in /usr/pkgsrc/lang/ezm3
    *** Error code 1
    
    Stop.
    bmake: stopped in /usr/pkgsrc/lang/ezm3
    *** Error code 1
    
    Stop.
    bmake: stopped in /usr/pkgsrc/lang/ezm3
    *** Error code 1
    
    Stop.
    bmake: stopped in /usr/pkgsrc/devel/cvsup
    *** Error code 1
    
    Stop.
    bmake: stopped in /usr/pkgsrc/devel/cvsup
    
    Ich hab bis jetzt noch nichts mit pkgsrc zu tun gehabt. Und konnte zu dem Problem bis jetzt auch nichts finden. Ich hoffe hier kann mir jemand helfen. :)

    p.s.
    Die gcc Version ist 4.1.2
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Bâshgob, 13.07.2008
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    pkgsrc stable oder current?
     
  4. akuta

    akuta Grünschnabel

    Dabei seit:
    13.07.2008
    Beiträge:
    5
    Zustimmungen:
    0
    müsste pkgsrc-2007Q4 sein. Ist bei draco-0.3.0 dabei und ich habe nichts geändert.
     
  5. #4 Bâshgob, 13.07.2008
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Für mich sieht das Package kaputt aus. Ich würde auf pkgsrc-2008Q1 aktualisieren und es dann nochmal versuchen.
     
  6. akuta

    akuta Grünschnabel

    Dabei seit:
    13.07.2008
    Beiträge:
    5
    Zustimmungen:
    0
    ja,werde ich mich morgen dann mal dran machen. mal sehen obs funktioniert.
    danke erstmal
     
  7. akuta

    akuta Grünschnabel

    Dabei seit:
    13.07.2008
    Beiträge:
    5
    Zustimmungen:
    0
    ok, ich bin mir nicht sicher ob ich beim update auf pkgsrc-2008Q1 alles richtig gemacht habe, aber jedenfalls kompiliert das ezm3 damit auch nicht.

    Ist aber nich weiter schlimm, denn wie ich herausgefunden habe brauche das Paket scmcvs und nicht cvsup.

    Ausserdem habe ich ein draco cvs binaer-Paket gefunden.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

pkgsrc - ezm3 kompiliert nicht unter (draco) Linux

Die Seite wird geladen...

pkgsrc - ezm3 kompiliert nicht unter (draco) Linux - Ähnliche Themen

  1. 15 Jahre pkgsrc

    15 Jahre pkgsrc: Die Freigabe der neuen Version 2012Q4 von pkgsrc fällt mit dem 15. Geburtstag des plattformübergreifenden Paketverwaltungssystems zusammen....
  2. pkgsrc - gle - configure error

    pkgsrc - gle - configure error: Moin! Ich steh hier grad etwas auf dem Schlauch. Environment: # uname -a NetBSD herakles 2.1.0_STABLE NetBSD 2.1.0_STABLE (HERAKLES) #5:...
  3. Frage zu ports/pkgsrc und BSD

    Frage zu ports/pkgsrc und BSD: Hallo, *BSD benutzt ja ports/pkgsrc, das so ähnlich funktioniert wie gentoo. Außerdem gibt es Binärpkgs. pkgsrc ist ja schon schlimm genug...