PHP5-fcgi

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Stobe02, 01.04.2009.

  1. #1 Stobe02, 01.04.2009
    Stobe02

    Stobe02 Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo ich habe mal eine frage, ich habe einen apache2 mit mod_fcgi und php5 am laufen das klappt auch alles super nur eine sache will nicht funktionieren, und zwar greift fcgi nicht auf die php.ini für die jeweiligen user zu sonder auf /etc/php/cgi/php.ini leider weiß ich nicht wo mein fehler liegt. Vllt kann mir ja jemand von euch helfen.


    Hier die Konfiguration meines Servers.
    Vhost.conf
    Code:
    NameVirtualHost *:80
    
    <VirtualHost *:80>
            ServerAdmin info@example.com
            ServerName USER.example.com
    
            ServerSignature Off
            LogLevel warn
    
            DocumentRoot /var/www/USER/web
            DirectoryIndex Default.php Default.html Default.htm index.php index.html index.htm
            Options +Indexes
    
    
            #FCGI-Settings
            PHP_Fix_Pathinfo_Enable 1
    
            SuexecUserGroup USER web-user
    
            AddHandler fcgid-script .php
    
            <Directory /var/www/USER/web>
                    Options FollowSymLinks +ExecCGI
                    Options +Indexes
                    AllowOverride AuthConfig FileInfo
                    Order allow,deny
                    allow from all
    
                    #FCGID-PHP-Teil
                    FCGIWrapper /var/www/USER/php-fcgi/php-fcgi-starter .php
            </Directory>
    </VirtualHost>
    


    php-fcgi-starter
    Code:
    #!/bin/sh
    PHPRC=”/var/www/USER/conf”
    export PHPRC
    PHP_FCGI_CHILDREN=2
    export PHP_FCGI_CHILDREN
    PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_MAX_REQUESTS
    #exec nice -n 5 /usr/bin/php-cgi
    exec nice -n 1 /usr/bin/php-cgi
    
    Soweit ich das sehen kann müsste doch alles passen. Wie schon gesagt es funktioniert ja auch alles wunderbar, nur wird eben eine globale php.ini verwendet.

    Vielen Dank schon mal im Voraus für die Antworten.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Stobe02, 30.06.2009
    Stobe02

    Stobe02 Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    10
    Zustimmungen:
    0
    Lösung gefunden

    PHPRC=”/var/www/USER/conf”

    Der Fehler war hier. Hatte die Zeile 1zu1 aus nem Tutorial kopiert und da waren die Anführungszeichen geschwungen welche vom apache2 nicht interpretiert werden konnten.
    Normale rein nun gehts. Nur als Tipp für alle die evtl. den gleichen Fehler haben wie ich.
     
  4. @->-

    @->- Guest

    Ich hoffe es geht um einen Server der neben dir steht und nicht um eine neue Spawnschläuder mit 100 Mbit Anbindung.....

    .... Oder es war ein versehen.......

    ..... Ehm schlechtes Tutorial......

    Es gibt eine Kombination von Wörtern die nichts gutes Ahnen lassen: " ...meinem Server....", kombiniert mit "....aus einem Tutorial kopiert...."

    http://root-und-kein-plan.ath.cx/

    In diesem Sinne
     
Thema:

PHP5-fcgi