OpenSuse 10.2 & Video = crash

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von jesusleier, 13.02.2007.

  1. #1 jesusleier, 13.02.2007
    jesusleier

    jesusleier Grünschnabel

    Dabei seit:
    13.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,
    ich habe mir OpenSuse 10.2 frisch installiert.
    Wenn ich jetzt ein Video öffne, dann crasht der x-Server und ich kommt wieder zum Loginscreen. Egal, ob ich vlc oder einen anderen Player verwende. Installationsfehler sind nicht aufgetreten. Als Videotreiber habe ich den aktuellen offiziellen ATI-Treiber für meine Mobility Radeon X1400 installliert.

    Wenn ich nach dem Fehler google, dann finde ich diesen wieder, allerdings keine Lösung.

    Was wären die Ansatzpunkte, nach denen ich das Problem lokalisieren kann? Ist es eventuell der ATI-Treiber? Erschwerend kommt noch dazu, dass ich ein Suse x86_64 verwende.

    Zudem kommt leider noch, dass ich auch nach Installation von xine per smart keine MP3s in Amarok abspielen kann. Es kommt nur ein Rauschen und Knistern.

    Danke im Voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich würde den Xserver mal von Hand starten und eventl. schauen warum er abschmiert.

    Also Strg-Alt-F1 - dort als User einloggen ... dann mal per su root rechte ... ein freundliches init 3 ... exit ... und dann als user mit startx deinen Desktop starten und testen.
    Schau die beim Absturz die Fehlermeldungen an und poste sie ggf. hier ;)
     
  4. #3 jesusleier, 14.02.2007
    jesusleier

    jesusleier Grünschnabel

    Dabei seit:
    13.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Danke für den Tipp. Ich habe das ausprobiert und es ist ziemlich merkwürdig. Wenn ich das so starte, wie Du das beschrieben hast, dann läuft alles problemlos. Mit dem Runlevel 5 allerdings weiterhin nicht.
    Wenn ich nach so einem crash vom x-Server in eine Konsolen wechsle, dann sehe ich lustige Bildfragmente.
    Die Grafikkarte wird aber nicht schuld sein, da sie ansonsten einwandfrei funktioniert. Ich tippe da eher auf den Treiber.
    Oder sollte ich nach etwas anderem schauen?
     
  5. ebauke

    ebauke Jungspund

    Dabei seit:
    06.09.2004
    Beiträge:
    13
    Zustimmungen:
    0
    Wenn du sagst das mit startx alles ohne Probleme läuft, dann schau doch mal in Yast nach was in Runlevel 5 alles gestartet wird. Vieleicht findest du dort einen Anhaltspunkt. Um auf dein Amarok Poblem zurückzukommen hast du Lame und die Win32-Codec installiert am besten von Packman

    packman.links2linux.de
     
  6. #5 jesusleier, 14.02.2007
    jesusleier

    jesusleier Grünschnabel

    Dabei seit:
    13.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Dort werden nur x-Serverspezifische Prozesse gestartet.
    Ja, lame und w32 sind installiert.
     
  7. #6 Wizzkid, 29.12.2007
    Wizzkid

    Wizzkid Grünschnabel

    Dabei seit:
    29.12.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Gleiches Problem unter 10.3

    Hallo,

    ich habe das gleiche Problem unter 10.3, jedoch auf einem Notebook
    mit einem SIS M671MX Grafikchipsatz. Der 2D Treiber ist offiziell für Ubuntu 7.04, funktioniert jedoch bis auf die Video-Xserver-Crashes auch unter 10.3.

    Ich habe mal folgende Anleitung befolgt...

    ... und folgende Meldungen erhalten:

    Code:
    xauth:  creating new authority file /home/carsta/.serverauth.4174
    
    
    X Window System Version 7.2.0
    Release Date: Wed Oct 24 14:18:36 UTC 2007
    X Protocol Version 11, Revision 0, Release 7.2
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux blackbox 2.6.22.13-0.3-default #1 SMP 2007/11/19 15:02:58 UTC i686
    Build Date: 24 October 2007
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 29 01:29:14 2007
    (==) Using config file: "/etc/X11/xorg.conf"
    (II) Module already built-in
    (II) Module already built-in
    (EE) SIS(0): [dri] DRIScreenInit failed. Disabling the DRI.
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    > Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
    >                   Ignoring extra symbols
    Errors from xkbcomp are not fatal to the X server
    Synaptics DeviceInit called
    SynapticsCtrl called.
    Synaptics DeviceOn called
    /etc/X11/xim: Checking whether an input method should be started.
    /etc/X11/xim: user environment variable LANG=de_DE.UTF-8
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale de_DE.UTF-8 ...
    There is no default input method for the current locale.
    startkde: Starting up...
    kbuildsycoca running...
    DCOP Cleaning up dead connections.
    QObject::connect: No such signal Kicker::settingsChanged(SettingsCategory)
    QObject::connect:  (sender name:   'kicker')
    QObject::connect:  (receiver name: 'animtt')
    SynapticsCtrl called.
    sh: jackd: command not found
    akode: Guessed format: xiph
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    KNotify::playTimeout
    sh: jackd: command not found
    akode: Guessed format: xiph
    KNotify::playTimeout
    KNotify::playTimeout
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode:  19
      Minor opcode:  0
      Resource id:  0x2600249
    ESP Ghostscript 8.15.3: Unrecoverable error, exit code 1
    11
    AFD changed from -2 to -1
    
    Backtrace:
    0: X(xf86SigHandler+0x81) [0x80d5bb1]
    1: [0xffffe420]
    2: X [0x80bf3de]
    3: X [0x80bfeb5]
    4: X(miHandleValidateExposures+0x78) [0x813e9e8]
    5: X(MapWindow+0x3e7) [0x807bb67]
    6: X(ProcMapWindow+0x59) [0x808efc9]
    7: X [0x815800e]
    8: X(Dispatch+0x1af) [0x808f68f]
    9: X(main+0x47e) [0x807717e]
    10: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7ce9fe0]
    11: X(FontFileCompleteXLFD+0x1e5) [0x8076501]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    
    kdeinit: Fatal IO error: client killed
    kdeinit: sending SIGHUP to children.
    kicker: sighandler called
    klauncher: Exiting on signal 1
    *** kdesktop got signal 1 (Exiting)
    kdeinit: sending SIGTERM to children.
    kdeinit: Exit.
    kicker: sighandler called
    klauncher: Fatal IO error: client killed
    kwin: Fatal IO error: client killed
    kdeinit: Fatal IO error: client killed
    kdeinit: sending SIGHUP to children.
    xinit:  connection to X server lost.
    Aufgelegt
    GOT SIGHUP
    startkde: Shutting down...
    Warning: connect() failed: : No such file or directory
    Error: Can't contact kdeinit!
    kdeinit: Fatal IO error: client killed
    kdeinit: sending SIGHUP to children.
    kicker: sighandler called
    kicker: Fatal IO error: client killed
    startkde: Running shutdown scripts...
    xprop:  unable to open display ':0'
    usage:  xprop [-options ...] [[format [dformat]] atom] ...
    
    where options include:
        -grammar                       print out full grammar for command line
        -display host:dpy              the X server to contact
        -id id                         resource id of window to examine
        -name name                     name of window to examine
        -font name                     name of font to examine
        -remove propname               remove a property
        -set propname value            set a property to a given value
        -root                          examine the root window
        -len n                         display at most n bytes of any property
        -notype                        do not display the type field
        -fs filename                   where to look for formats for properties
        -frame                         don't ignore window manager frames
        -f propname format [dformat]   formats to use for property of given name
        -spy                           examine window properties forever
    
    startkde: Done.
    kdeinit: sending SIGTERM to children.
    kdeinit: Exit.
    kdeinit: sending SIGTERM to children.
    kdeinit: Exit.
    
    
    Kann jemand erkennen wo der Schuh drückt?


    Ich danke für eure Hilfe!
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

OpenSuse 10.2 & Video = crash

Die Seite wird geladen...

OpenSuse 10.2 & Video = crash - Ähnliche Themen

  1. OpenSUSE 10.1 64 bit - Radeon - SDL_SetVideoMode geht nicht

    OpenSUSE 10.1 64 bit - Radeon - SDL_SetVideoMode geht nicht: Hallo, ich nutze OpenSUSE 10.1 64 bit und habe das Problem, dass ein GPL 3D-Spiel, das ich maintaine, keinen OpenGL-Videomodus via SDL 1.2.11...
  2. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  3. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  4. OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed

    OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed: OpenSuse bietet zwei neue Images an, die die neuesten KDE-Pakete aus den Git-Repositories enthalten. Die Images basieren auf den Varianten Leap...
  5. Opensuse 13.1 erreicht Evergreen-Phase

    Opensuse 13.1 erreicht Evergreen-Phase: Version 13.1 der Linux-Distribution Opensuse hat jetzt das Ende ihrer regulären Lebensdauer erreicht. Doch im Rahmen des Evergreen-Projektes wird...