NVIDIA Geforce 2 GTS Suse 10

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von haugi1, 11.10.2005.

  1. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo

    wie kann ich bei suse 10 eine Geforce 2 GTS die im neuesten NVIDIA Installer nicht mehr unterstützt installieren.

    HAbe bereits einen älteren geladen, Kernel -source installiert bekomme aber die Fehlermeldung dass im Kernel rivafb implementiert wäre und ich deshalb keinen NVIDIA Treiber und sommit keine 3D unterstützung installieren kann.


    mfg
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Tja, brauchst du denn wirklich die NVIDIA Treiber, oder reicht dir bei der GF2 der NV ?

    Welche "ältere" Version hast du denn gesaugt ?

    Notfalls müßtest den Kernel neu bauen, damit rivafb raus is ...
     
  4. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    Habe
    Linux Grafiktreiber - IA32
    Version: 1.0-6629

    geladen , da neuere Versionen weiss nicht ab wann die Geforce 2GTS nicht mehr unterstützen.
    Brauche nach Möglichkeiten eben 3D unterstützung wie ist egal.

    mfg
     
  5. #4 DennisM, 11.10.2005
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Dann solltest du vielleicht einen eigenen Kernel ohne RivaFB erstellen.

    MFG

    Dennis
     
  6. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    ja jetzt sprechen die absoluten Profis. Ich bin froh dass die suse überhaupt mal nache einigem austauschen der Hardware stabil läuft.

    Habe mal bei Debian versucht einen Kernel zu kompilieren was auch nach einigen versuchen hingehauen hat.

    Bei Suse liest man diesbezüglich aber viel negatives und eine gute Anleitung ist leider auch nicht zu finden.

    mfg
     
  7. #6 ChrisMD, 11.10.2005
    ChrisMD

    ChrisMD Haudegen

    Dabei seit:
    30.06.2005
    Beiträge:
    619
    Zustimmungen:
    0
    Es funktioniert genauso wie unter Debian auch. Natürlich nicht wenn dort beschrieben wird wie man dann ein Paket herstellt aber brauch man auch nicht wirklich finde ich.
    Die Source muss halt nach /usr/src entpackt werden.
    Mit make menuconfig kann man erstmal das Modul rivafb rausnehmen.
    dann make.
    cp arch/i386/boot/vmlinuz /boot/vmlinuz-2.6.xx (wie er halt heißt)
    cp System.map /boot/System.map-2.6.xx
    make modules_install
    generate-modprobe.conf > /etc/modprobe.conf (bin mir bei der cmd nich so ganz sicher aber die wahr so ähnlich. ob das nötig ist weiß ich garnicht.)

    dann noch in lilo oder grub je nachdem was man halt benutzt den neuen kernel eintragen (/boot/vmlinux-2.6.13 z.B.) und dann müsste man den booten können (lieber einen neuen eintrag erstellen als den alten zu ersetzen sonst hat man wenn nix geht mehr aufwand beim booten des alten kernels.
     
  8. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo

    Habe mir nochmals den letzten verfügbaren NVIDIA-Installer der die geforce 2GTS unterstützt also Version 7174 geladen und folgendermaßen instaliert :

    Suse 10

    init 3
    sh nvidia-insta.........run -q
    sax2 -m O=nvidia

    in xorg.conf steht dann nicht mehr nv sondern nvidia.

    init 5 und alles läuft auch 3D


    Aber mache ich dann irgendwann einen reboot dann startet init 5 nicht mehr.

    Muss dann in der xorg.conf nvidia wieder in nv ändern und habe dann somit kein 3D mehr.


    was kann ich machen dass auch der reboot funktioniert ?


    mfg
     
  9. #8 DennisM, 12.10.2005
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Du musst festlegen, dass das nVidia Modul auch beim booten geladen wird, ich weiß allerdings nicht welche Datei das unter SuSE ist.

    MFG

    Dennis
     
  10. #9 Borderlinedance, 12.10.2005
    Borderlinedance

    Borderlinedance Tripel-As

    Dabei seit:
    09.09.2005
    Beiträge:
    171
    Zustimmungen:
    0
    Ort:
    Switzerland
    Ich hab eine GeForce 2 MX, die wurde bei der Installation von SuSE 10.0 Eval automatisch erkannt, und beim Update hat es dann auch noch was besseres dabei (NVIDIA Driver).
    :( ?
     
  11. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    ja die geforce 2 MX wird auch vom neuesten NVIDIA Treiber unterstützt der bei der suse 10 dabei ist.

    Die geforce 2 GTS wir von diesem Treiber aber nicht mehr unterstützt nur bis Version 7174.
     
  12. #11 Borderlinedance, 12.10.2005
    Borderlinedance

    Borderlinedance Tripel-As

    Dabei seit:
    09.09.2005
    Beiträge:
    171
    Zustimmungen:
    0
    Ort:
    Switzerland
    Geil! :(

    Neue GraKA? :think:
    (Muss ja nichts teures sein).
     
  13. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Also so wie ich das lese, ist doch derzeit einfach das Problem, dass das Modul nvidia vor dem X start nicht geladen wird, aber der Treiber 6629 grundsätzlich funktioniert?
    In dem falle öffne man einfach die Datei /etc/init.d/boot.local und trage dort
    Code:
    modprobe nvidia
    ein. Warum ers nicht selbst läd, is mir war ein Rätsel, aber so kommt mal wenigstens dahin wo man hin will.
     
  14. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    werde ich heute Abend wenn ich zuhause bin mal testen.

    Bei der Suse 9.3 funktioniert nach ausführen des nvidia-installers alles.

    mfg
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. haugi1

    haugi1 Jungspund

    Dabei seit:
    08.10.2005
    Beiträge:
    19
    Zustimmungen:
    0
    Hat nicht funktioniert mit "modprobe nvidia".

    Habe noch etwas gegoogelt und folgende funktionierende Lösung gefunden :

    Zuerst einfach einen Treiber von Nvidia.de runterladen und installieren, so wie das ganze auch in den Readmes für Suse beschrieben ist.
    Nach dem Konfigurieren von Sax2, habe ich die Datei /etc/udev/static_devices.txt geöffnet und ans Ende die zu erstellenden Dateien eingetragen:
    Code:

    nvidia0 c 195 0 666
    nvidia1 c 195 1 666
    ...
    nvidia7 c 195 7 666
    nvidiactl c 195 255 666


    Danach könnt ihr den Rechner neu starten und die Gerätedateien werden bei jedem Neustart manuell erstellt und alles geht .

    Für den Fall dass jemand das selbe Problem hat.

    mfg
     
  17. Bhaal

    Bhaal Grünschnabel

    Dabei seit:
    23.12.2005
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo zusammen.

    Ich habe das Problem, daß ich nach der Installation des Treibers Sax2 nicht starten kann. Ich erhalte immer den Fehler, daß ich einen unbekannten Chip hätte. Habe ein GeForce 1.

    Bitte daher um Rat.

    MfG Bhaal
     
Thema:

NVIDIA Geforce 2 GTS Suse 10

Die Seite wird geladen...

NVIDIA Geforce 2 GTS Suse 10 - Ähnliche Themen

  1. MSI NVIDIA GeForce 8400GS Problemlos unter Linux?

    MSI NVIDIA GeForce 8400GS Problemlos unter Linux?: Hi, hat jemand Erfahrung mit (MSI) NVIDIA GeForce 8400GS GraKas? laufen die Out-Of-The-Box? oder steht da erst noch Treiberbastelei an? Danke !
  2. Nvidia Geforce4 420go

    Nvidia Geforce4 420go: hallo zusammen, ich habe mir auf mein gericom x5 Notebook opensuse 10.3 installiert und würde gerne die 3D beschleunigung der Nvidia Geforce4...
  3. Nvidia GeForce 8500 GT keine 3D Unterstützung?

    Nvidia GeForce 8500 GT keine 3D Unterstützung?: Hi leute, habe mal eine richtig dämliche Frage :D Ich habe mir Suse installiert und nun muss ich sehen das dort steht: Graphikkarte...
  4. NVIDIA GeForce 8600

    NVIDIA GeForce 8600: HI! Ich suche ne PCI EXPRESS Grafikkarte für meinen neuen PC. Da meine Freunde alle mindestens ne GeForce 8600GT mit 256MB haben frage ich mich...
  5. MSI NVidia GeForce NX7600GT TD512Z mit Problemen...

    MSI NVidia GeForce NX7600GT TD512Z mit Problemen...: Guten Tag, Manche haben es vielleicht schon in anderen Foren gelesen, jedoch konnte man mir dort nicht helfen, deshalb frage ich jetzt hier:...