mplayer pkgs

Dieses Thema im Forum "Slackware" wurde erstellt von Franknborder, 15.09.2004.

  1. #1 Franknborder, 15.09.2004
    Franknborder

    Franknborder Doppel-As

    Dabei seit:
    14.08.2004
    Beiträge:
    109
    Zustimmungen:
    0
    Hallo,...


    ich habe mir hier http://linuxpackages.net/ den mplayer als tgz pkg gezogen
    erst installiert und anschliessend in der Konsole bei der Eingabe von mplayer
    folgende Meldung erhalten:

    mplayer: error while loading shared libraries: libdvdread.so.3: cannot open shared object file: No such file or directoryr

    Ich weiß jetzt nicht genau ob das eine dependencies Meldung ist, zeigt Slack überhaupt an wenn mir eine lib oder anderes zum ausführen einer Sache fehlen sollte ?


    Ansonsten, nach kleinen Einsteigerprobs, läuft die Sache echt super, vielen Dank Leute,...


    Gruß

    Franknborder :)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. ookami

    ookami Haudegen

    Dabei seit:
    06.07.2002
    Beiträge:
    543
    Zustimmungen:
    0
    http://www.linuxpackages.net/download.php?id=3256

    Nein - Slackware zeigt kein abhänigkeiten an, aber das von dir genutzte programm sagt schon wenn es eine lib nicht findet.
     
  4. #3 Franknborder, 15.09.2004
    Franknborder

    Franknborder Doppel-As

    Dabei seit:
    14.08.2004
    Beiträge:
    109
    Zustimmungen:
    0
    Re,...


    vielen Dank, super,...das heisst ja dann das man nie wirklich im dunkeln tappen würde bei evtl. Spezialfällen und zumindest auf das fehlende Element hingewiesen wird,...wie es hier jetzt der Fall war, ich konnte es nicht genau interpretieren.....



    Gruß

    Franknborder
     
  5. ookami

    ookami Haudegen

    Dabei seit:
    06.07.2002
    Beiträge:
    543
    Zustimmungen:
    0
    Ja, mit ldd bekommst du auch die abhänigkeiten raus - z.B.

    Code:
    406 /home/patty$ ldd /usr/bin/ruby
            libruby.so.1.8 => /usr/lib/libruby.so.1.8 (0x40024000)
            libpthread.so.0 => /lib/libpthread.so.0 (0x400e8000)
            libdl.so.2 => /lib/libdl.so.2 (0x40139000)
            libcrypt.so.1 => /lib/libcrypt.so.1 (0x4013c000)
            libm.so.6 => /lib/libm.so.6 (0x4016a000)
            libc.so.6 => /lib/libc.so.6 (0x4018c000)
            /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    
     
  6. #5 Franknborder, 15.09.2004
    Zuletzt bearbeitet: 15.09.2004
    Franknborder

    Franknborder Doppel-As

    Dabei seit:
    14.08.2004
    Beiträge:
    109
    Zustimmungen:
    0
    Re,...

    root@darkstar:~# ldd /usr/bin/mplayer
    /usr/bin/mplayer: /usr/lib/libpng12.so.0: no version information available (required by /usr/bin/mplayer)
    libfame-0.9.so.0 => not found
    libmad.so.0 => /usr/lib/libmad.so.0 (0x4002a000)
    libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x4003f000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0x40067000)
    libdv.so.2 => not found
    libfaad.so.0 => not found
    liblzo.so.1 => not found
    libmp3lame.so.0 => not found
    libxvidcore.so.4 => not found
    libm.so.6 => /lib/libm.so.6 (0x4006e000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0x40090000)
    libz.so.1 => /usr/lib/libz.so.1 (0x400c0000)
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x400d1000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0x400ee000)
    libdl.so.2 => /lib/libdl.so.2 (0x4019d000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x401a0000)
    libxmms.so.1 => /usr/lib/libxmms.so.1 (0x401f2000)
    libmatroska.so.0 => not found
    libebml.so.0 => not found
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x401ff000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x402b6000)
    libtinfo.so.5 => not found
    libcdda_interface.so.0 => /usr/lib/libcdda_interface.so.0 (0x4031c000)
    libcdda_paranoia.so.0 => /usr/lib/libcdda_paranoia.so.0 (0x40331000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x4033a000)
    libungif.so.4 => /usr/lib/libungif.so.4 (0x4034f000)
    libfontconfig.so.1 => /usr/X11R6/lib/libfontconfig.so.1 (0x40356000)
    libaa.so.1 => /usr/lib/libaa.so.1 (0x4037d000)
    libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x40397000)
    libXxf86dga.so.1 => /usr/X11R6/lib/libXxf86dga.so.1 (0x40424000)
    libXv.so.1 => /usr/X11R6/lib/libXv.so.1 (0x4042a000)
    libXxf86vm.so.1 => /usr/X11R6/lib/libXxf86vm.so.1 (0x4042f000)
    libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x40434000)
    libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40437000)
    libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40446000)
    libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x4050e000)
    libdirectfb-0.9.so.17 => not found
    libartsc.so.0 => /opt/kde/lib/libartsc.so.0 (0x4058a000)
    libesd.so.0 => /usr/lib/libesd.so.0 (0x40590000)
    libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0x4059a000)
    liblirc_client.so.0 => not found
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x405bf000)
    libc.so.6 => /lib/libc.so.6 (0x405c7000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x406f6000)
    libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x40814000)
    libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x40845000)
    libgthread-1.2.so.0 => /usr/lib/libgthread-1.2.so.0 (0x40849000)
    libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x4084c000)
    libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x4086d000)
    libexpat.so.0 => /usr/lib/libexpat.so.0 (0x40875000)
    libslang.so.1 => /usr/lib/libslang.so.1 (0x40895000)
    libgpm.so.1 => /lib/libgpm.so.1 (0x40907000)
    libncurses.so.5 => /lib/libncurses.so.5 (0x4090e000)
    root@darkstar:~#

    Auf der Pkgnet sind leider nur 3 der fehlenden zu finden...wo sollte ich suchen ?


    thx

    Franknborder
     
  7. #6 Bâshgob, 15.09.2004
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

mplayer pkgs

Die Seite wird geladen...

mplayer pkgs - Ähnliche Themen

  1. MPlayer 1.3 veröffentlicht

    MPlayer 1.3 veröffentlicht: Die Entwickler des freien Medien-Players MPlayer haben nicht einmal einen Monat nach MPlayer 1.2.1 eine neue Hauptversion der Anwendung...
  2. MPlayer 1.2 freigegeben

    MPlayer 1.2 freigegeben: Über drei Jahre nach der Freigabe der stabilen Hauptversion 1.1 haben die Entwickler des freien Multimedia-Players MPlayer die Anwendung in einer...
  3. SMPlayer 15.9 unterstützt mpv

    SMPlayer 15.9 unterstützt mpv: SMPlayer, eines der bekanntesten Frontends für den Mplayer, ist in einer neuen Version veröffentlicht worden. Zu den zahlreichen Neuerungen der...
  4. Mplayer-Fork »mpv«: Version 0.5 veröffentlicht

    Mplayer-Fork »mpv«: Version 0.5 veröffentlicht: Knapp ein Jahr nach der initialen Gründung des alternativen Players »mpv« kann das Projekt auf diverse Veröffentlichungen und zahlreiche...
  5. MPlayer: Neuer Fork, neuer Schwung?

    MPlayer: Neuer Fork, neuer Schwung?: Eine Gruppe von Entwicklern hat mit mpv einen neuen Fork von mplayer2 gestartet, der das Beste aus MPlayer und mplayer2 mit weiteren...