Mount USB-Disk Openuse 11.0 - Fehler

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Linux_starter, 05.11.2008.

  1. #1 Linux_starter, 05.11.2008
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Hallo zusammen,

    wieder zurueck bei SUSI und gleich geht es wieder Los. Ich habe eine USB-Disk welche als /dev/sdb1 erkannt wird und versucht wird zu mounten. Ich bekomme die folgenden Fehlermeldung:

    OK gesagt getan wie oben steht ausgefuehrt dmesg | tail:

    Code:
    sd 6:0:0:0: [sdb] Assuming drive cache: write through
     sdb: sdb1
    sd 6:0:0:0: [sdb] Attached SCSI disk
    sd 6:0:0:0: Attached scsi generic sg2 type 0
    usb-storage: device scan complete
    NTFS driver 2.1.29 [Flags: R/W MODULE].
    NTFS-fs error (device sdb1): parse_options(): Unrecognized mount option locale.
    NTFS-fs warning (device sdb1): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.
    NTFS-fs error (device sdb1): parse_options(): Unrecognized mount option locale.
    NTFS-fs warning (device sdb1): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.
    
    cat /etc/fstab

    Code:
    /dev/disk/by-id/scsi-SATA_Hitachi_HTS5425080219BB0F00WDCE1DUC-part5 swap                 swap       defaults              0 0
    /dev/disk/by-id/scsi-SATA_Hitachi_HTS5425080219BB0F00WDCE1DUC-part3 /                    ext3       acl,user_xattr        1 1
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/sda1            /media/Vista         ntfs-3g    defaults              0 0
    /dev/sda2            /media/Recovery      ntfs-3g    defaults              0 0
    rpm -qa | grep -i ntfs

    Code:
     ntfsprogs-1.13.1-80.1
    ntfs-3g-1.2506-5.1 
    mount

    Code:
    /dev/sda3 on / type ext3 (rw,acl,user_xattr)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/sda1 on /media/Vista type fuseblk (rw,allow_other,blksize=4096)
    /dev/sda2 on /media/Recovery type fuseblk (rw,allow_other,blksize=4096)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    
    ntfsfix /dev/sdb1

    Code:
    Mounting volume... OK
    Processing of $MFT and $MFTMirr completed successfully.
    NTFS volume version is 3.1.
    NTFS partition /dev/sdb1 was processed successfully.
    OK ich habe die Disk jetzt schon ueberprueft mit chkdsk in Windows - keine Fehler.

    Naja sda1 und sda2 sind auch NTFS die funktionieren auch. Wenn ich die Platte einstecke dann kommt die Meldung von Konqueror was ich damit machen und ich sage im neuen Fenster oeffnen -- > dann kommt die Fehlermeldung.

    Wenn ich es mit dem Befehl ntfs-3g /dev/sdb1 /media/sdb1 mounte, dann funktiniert es ohne Error und ich kann darauf zugreifen. Wie kann ich es jetzt so machen das diese automatisch gemounted wir wenn ich Sie anstecke ?

    mount

    Code:
    /dev/sda3 on / type ext3 (rw,acl,user_xattr)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/sda1 on /media/Vista type fuseblk (rw,allow_other,blksize=4096)
    /dev/sda2 on /media/Recovery type fuseblk (rw,allow_other,blksize=4096)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    /dev/sdb1 on /media/sdb1 type fuseblk (rw,allow_other,blksize=4096)
    jetzt sieht es so aus wie es soll :-( Was muss ich jetzt in fstab eintragen ?

    Vielen Dank
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 tuxlover, 05.11.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    gar nix wenn du keine ahnung hast, kannst du yast benutzen und den usbstick einen festen mountpunkt zuweisen. dann wird er auch automatisch eingehängt, vorrausgesetzt natürlich er ist angeschlossen.
     
  4. #3 Linux_starter, 05.11.2008
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Hey Danke fuer die nette Antwort.... bin ich eigentlich von hier nicht gewoeht.... ich denke eigentlich schon ein wenig das ich weiss wo es lang geht. habe es ja den mount auch hin bekommen....

    Wollte es ja nur fuer die Ewigkeit machen. Nicht mit YAST

    Aber Danke
     
  5. #4 tuxlover, 05.11.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    hallo Linux_starter,

    wieso yast macht doch meiner meinung das gleiche, wie das was du sonst per hand eintragen müsstest. :) ansonsten findest du hier nichts?
     
  6. #5 Linux_starter, 05.11.2008
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    naja ich hatte da schon verschiedenes gelesen. Ich bin momentan in der Phase alles manuell zu machen sonst lernt man ja nie dazu. Und da fehlt mir ein Stueck im Puzzel :-(

    Aber ich werde mal noch ein wenig googeln....
     
  7. #6 Gast1, 05.11.2008
    Zuletzt von einem Moderator bearbeitet: 05.11.2008
    Gast1

    Gast1 Guest

    ****Edit****

    Das waren ja die beiden Einträge für die interne Platte, also kein Problem mit dem auto aus defaults.

    Wie sieht eigentlich der jetzige Eintrag für die externe aus?

    Jedenfalls haben Wechselmedien in der fstab gar nichts zu suchen, das erledigen hal/udev.

    Diese Lösung hier funktioniert dann für jedes Wechselmedium mit NTFS und mit Partitionslabeln auch mit immer dem selben Mountpunkt /media/LABEL.

    http://www.pc-forum24.de/suse-syste...t-ntfs-3g-automatisch-schreibbar-mounten.html
     
  8. #7 Linux_starter, 05.11.2008
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Hallo,

    Rain_Maker danke fuer den Link, es ist genau das was ich gesucht habe um das ganze besser zu verstehen. Habe das jetzt mal glatt gemacht.

    Davon mal abgesehen hat Yast auch einen Eintrag in fstab gemacht.

    Die beiden folgenden Eintraege sind Partitionen im Laptop also duerfte das ja mal OK gehen denke ich

    Aber jetzt funktioniert das mal :-) Man lernt ja nie aus. Ich werde mir mal ein buch besorgen um dieses Detailiert durchzuackern.

    Danke mal euch beiden.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. Gast1

    Gast1 Guest

    Klar, wenn man mit angesteckter USB-Platte den Partitionierer aufruft und den Vorschlag annimmt (weil YaST die Partitionen natürlich automatisch erkennt), dann macht er das auch, nur muss man für externe Medien nichts im Partitionierungsmodul einstellen geschweige denn diesen dafür überhaupt nur aufrufen.

    Ja, intern ist OK, nur extern und defaults würde kräftig ins Auge gehen.
     
  11. #9 Linux_starter, 05.11.2008
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Nur so kann man lernen, DANKE :-)
     
Thema: Mount USB-Disk Openuse 11.0 - Fehler
Besucher kamen mit folgenden Suchen
  1. NTFS-fs error (device sdb3): parse_options(): Unrecognized mount option locale

Die Seite wird geladen...

Mount USB-Disk Openuse 11.0 - Fehler - Ähnliche Themen

  1. Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten

    Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten: Hallo, ich habe 2 Problemchen. Ich kann nichts mehr installieren. Ich brauche aber unbedingt ein Brenn-Programm. Ein schönen Partitionierer usw....
  2. Automounter konfigurieren

    Automounter konfigurieren: Moin, ich versuche relativ erfolglos den Automounter zu konfigurieren. OS ist Solaris 10 und Ziel ist es das beim z.B. cd /test der entsprechende...
  3. partition/mount point wo liegt das directory?

    partition/mount point wo liegt das directory?: Hallo zusammen! Wahrscheinlich eine 'ne blöde Frage: wie bekomme ich heraus, auf welcher Partition bzw. mount point ein Verzeichnis liegt....
  4. FTP-server frage - mount-nullfs

    FTP-server frage - mount-nullfs: Hallo ich habe einen kleinen FreeBSD-server mit pureftpd laufen. 4 lokale user + chroot_homes=yes in der conf. Klappt auch alles, jetzt würde...
  5. [CENTOS6] Gemountete Platte als Netzlaufwerk bereitstellen

    [CENTOS6] Gemountete Platte als Netzlaufwerk bereitstellen: Hey zusammen, ich bin neu in Linux und habe mir zum Lernen einen Server aufgesetzt. (32 Bit Centos 6). Nun möchte ich die gemountete...