Mailman auf Solaris

Dieses Thema im Forum "Unix Derivate & sonst. Unix Fragen" wurde erstellt von Mark, 07.01.2008.

  1. Mark

    Mark Grünschnabel

    Dabei seit:
    07.01.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo Freunde,

    ich versuche auf Solaris den Mailman zu installieren

    phyton 2.4 installiert

    Jedoch kann ich den mailman nicht zu ende compilieren. Er bricht mit der Meldung:
    PHP:
    Traceback (most recent call last):
      
    File "bin/update"line 46in ?
        
    import paths
      File 
    "/usr/local/mailman/bin/paths.py"line 60in ?
        
    import korean
    ImportError
    No module named korean
    gmake
    : *** [updateError 1

    Beim compilieren ist mir noch ein Fehler aufgefallen.
    PHP:
    /usr/local/lib/python2.4/distutils/dist.py:222UserWarning'licence' distribution option is deprecated; use 'license'
      
    warnings.warn(msg)
    src/hangul.c:33errorsyntax error before numeric constant
    src
    /hangul.c:34errorsyntax error before numeric constant
    error
    command 'gcc' failed with exit status 1
    gmake
    [1]: *** [install-packagesError 1

    Es fehlt im wohl das Modul korean. Hat jemand eine Idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 fabtagon, 07.01.2008
    fabtagon

    fabtagon somebody

    Dabei seit:
    20.07.2005
    Beiträge:
    28
    Zustimmungen:
    0
    Fehler 1: Richtig, der Mailman wünscht sich offenbar ein bei dir nicht installiertes Python-Modul/-Paket.

    Fehler 2: könnte z.B. eine andere GCC-Version sein als nötig.

    Hast du mal nachgesehen, welche Versionen von Python und GCC für diese Mailmanversion vorgesehen sind?

    Wie auch immer: Am einfachsten dürfte das besorgen von fertigen Binärpaketen über http://www.blastwave.org/ oder http://www.sunfreeware.com/ sein.
     
  4. Mark

    Mark Grünschnabel

    Dabei seit:
    07.01.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Erstmal danke!

    Also fehlt ein Python Modul/-Paket Ich habe Python davor selber gebaut. Laut mailman wird Python 2.4.4 benötigt. Diese Version habe ich auch installiert.
    Kann man das Paket nicht nachinstallieren?


    Mark
     
  5. Mark

    Mark Grünschnabel

    Dabei seit:
    07.01.2008
    Beiträge:
    6
    Zustimmungen:
    0
    hat jemand noch eine Idee, wie man den Fehler beheben kann?
     
  6. #5 supersucker, 14.01.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    ???

    Die Lösungen wurden dir schon genannt:

    1. Das Modul korean nachinstallieren, siehe z.B.: http://docs.python.org/inst/inst.html

    2.

     
  7. Mark

    Mark Grünschnabel

    Dabei seit:
    07.01.2008
    Beiträge:
    6
    Zustimmungen:
    0
    bei Python 2.4.4 sind diese aber bereits dabei.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Mailman auf Solaris

Die Seite wird geladen...

Mailman auf Solaris - Ähnliche Themen

  1. Problem mit Postings bei Mailman (bzw. Dovecot?)

    Problem mit Postings bei Mailman (bzw. Dovecot?): Moin, ich hab Lenny mit Postfix und Dovecot mit MySQL nach dem Tutorial hier eingerichtet - funzt alles bestens. Jetzt versuche ich gerade...
  2. mailman Paket hängt beim installieren oder konfigurieren

    mailman Paket hängt beim installieren oder konfigurieren: Hallo, ich habe mailman (dämlicherweise) per webmin versucht zu installieren, das ging ziemlich schief. Jetzt wollte ich das Paket mit...
  3. Mailman -> MHonArc

    Mailman -> MHonArc: Hallo, hat jemand von euch Erfahrung mit GNU Mailman im Zusammenspiel mit MHonArc? Wie bringe ich Mailman bei, dass jeder Post in einer...
  4. Webinterface von mailman nach Update funktioniert nicht mehr

    Webinterface von mailman nach Update funktioniert nicht mehr: Hallo, ich habe heute das Online-Update von suse durchgeführt. Ging sowie auch ganz gut, nur das Webinface von Mailman funktioniert nicht mehr,...
  5. POSTFIX MAILMAN Probleme

    POSTFIX MAILMAN Probleme: Hallo, Ich würde gerne Mailman zusammen mit Postfix nutzen. ##System## Suse Linux 9.1 Postfix 2.20 Apache2 2.0.49 Mailman 2.1.4 Ich...