Linux hängt beim booten bei 'setting up the hardware clock'

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Tom211, 22.02.2008.

  1. #1 Tom211, 22.02.2008
    Zuletzt bearbeitet: 22.02.2008
    Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Hallo Leute,

    habe leider folgendes Problem. Beim booten bleibt der Rechner bei der Meldung 'setting up the hardware clock' stehen. Was ist passiert? Nachdem die Batterie des Mainboards leer war, habe ich diese gewechselt und da ich gerade bei Win unterwegs war, habe ich dort die Uhrzeit angepasst. Und nun ist Linux beleidigt, obwohl ich 98 % der Dinge bei Linux erledige. Mein System ist OpenSuse 10.2, welches seit einem Jahr problemlos läuft. Hat jemand eine andere Idee als das System neu aufzusetzen? Ich meine das ist Linux und nicht Win, wo Neuinstallationen zum Hobby gehören muss...

    Das Rescue-System startet übrigens, mit dem Hinweis 'Failed' bei der Meldung mit der Hardware clock. Nur was soll ich wo retten?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Aqualung, 22.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    Bios reseten bzw. neu aufspielen?

    Gruß Aqualung
     
  4. Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Warum das Bios resetten? Die Angaben dort sehen in Ordnung aus, inkl. Systemzeit.
     
  5. #4 StyleWarZ, 22.02.2008
    StyleWarZ

    StyleWarZ Profi Daten Verschieber

    Dabei seit:
    05.03.2004
    Beiträge:
    1.929
    Zustimmungen:
    0
    Hmm, wenn du mit der Rescue-System startest kann dir vielleicht "dmesg" einen Hinweis geben.

    Gruss
     
  6. Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Wonach würdest du denn bei dmesg suchen? Sitze gerade nicht an dem Linux-Rechner.

    Ich habe im Netz etwas darüber gelesen, dass sich Linux die Boot- und Shutdownzeiten merkt und es Probleme gibt, wenn die aktuelle Boot-Zeit z. B. vor dem letzten Shutdown liegt.
     
  7. Gast1

    Gast1 Guest

    Versuche mit Failsafe in Runlevel 1 zu booten. In der Zeile "Boot Options" die 3 durch eine 1 ersetzen.

    Wenn das klappt, dann als root

    Code:
    hwclock --hctosys
    Wenn das nicht klappt, dann von einer Live-CD booten und die Datei

    Code:
    /etc/adjtime
    löschen/umbenennen.

    Greetz,

    RM
     
  8. #7 supersucker, 22.02.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Boote mal indem du im Grub-menü "e" drückst (für edit), dann acpi=off hinter die Kernelzeile schreibst.

    Keine Dauerlösung, aber hilft erstmal das Problem einzugrenzen.
     
  9. #8 Tom211, 22.02.2008
    Zuletzt bearbeitet: 22.02.2008
    Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Den Befehl hwclock --hctosys werde ich ausprobieren. Die Datei /etc/adjtime habe ich schon gelöscht, ohne Auswirkungen; acpi=off habe ich auch schon versucht.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    jetzt habe ich den Befehl hwclock --hctosys auch einmal ausprobiert - leider ohne Erfolg. Das Rescue-System fährt jetzt zwar ohne Fehlermeldung hoch (hatte vorher noch failed bei der Meldung 'setting up the hardware clock' gezeigt). Das Booten von Festplatte stoppt aber immer noch bei der Hardware-clock-Meldung. Falls jemand noch eine Idee hat... Sonst muss ich das System neu aufsetzen. :(
     
  10. #9 Bâshgob, 22.02.2008
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    BIOS resetten und neu einstellen. Eine Neuinstallation ist garantiert nicht nötig.
     
  11. #10 Aqualung, 23.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    Kannst Du mit Knoppix/ bzw. Rescue-Modus problemlos booten?

    Kernel-Parameter

    Code:
    noapic
    versuchen.

    HTH Aqualung
     
  12. Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Kernel-Parameter NOAPIC löst das Problem leider nicht; den Vorschlag das ganze Spiel in 3 Sekunden zu lösen, hilft auch nicht weiter, da ich nicht mit Debian unterwegs bin, sondern mit OpenSuse 10.2. Suse kennt leider die zu ändernden Dateien des Google-Links /ect/init.d/hwclock.sh und /etc/init.d/hwclockfirst.sh nicht. Knoppix und das Rescue-System starten einwandfrei. Somit ist das Problem leider noch nicht gelöst...
     
  13. #12 JBR, 23.02.2008
    Zuletzt bearbeitet: 23.02.2008
    JBR

    JBR Fichtenschonung

    Dabei seit:
    18.03.2007
    Beiträge:
    561
    Zustimmungen:
    0
    Ort:
    Nolop
    Schalte das init Script doch einfach aus. Schau mal in /etc/rc[0-9].d/
    Vermutlich gehört es zu Runlevel 0 also liegt es in /etc/rc0.d/ . Bei mir lautet der Pfad /etc/rc0.d/K25hwclock.sh
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. Gast1

    Gast1 Guest

    Stimmt fast, aber das Script boot.clock wird nicht in sondern vor dem Erreichen der Runlevels ausgeführt.

    Code:
    cd /etc/init.d/
    find . -iname "*clock*"
    ./boot.d/K13boot.clock
    ./boot.d/S09boot.clock
    ./rcS.d/S09boot.clock
    ./boot.clock
    Der Ansatz an sich bleibt aber der selbe.

    Greetz,

    RM
     
  16. Tom211

    Tom211 Jungspund

    Dabei seit:
    27.12.2006
    Beiträge:
    13
    Zustimmungen:
    0
    JBR und Rainmaker, vielen Dank, das wars. Ich komme wieder in mein Linux!!! Ich habe einfach alle Skripte lt. eurer Anleitung gelöscht. Obwohl ich mich jetzt natürlich frage, was diese Skripte machen bzw. was jetzt unter Umständen nicht mehr richtig funktioniert. Noch mal vielen Dank für die nett geschriebenen Tipps.
     
Thema:

Linux hängt beim booten bei 'setting up the hardware clock'

Die Seite wird geladen...

Linux hängt beim booten bei 'setting up the hardware clock' - Ähnliche Themen

  1. Suse Linux 11.4 hängt sich auf

    Suse Linux 11.4 hängt sich auf: Hallo, ich habe auf meinem Server Suse Linux 11.4 laufen, das Root Filesystem ist auf einer internen 80GB HDD, über eine SATA Backplane sind...
  2. USB-Stick rein - Linux aufgehängt

    USB-Stick rein - Linux aufgehängt: Hi Leute! Ich habe ein Problem mit meinem USB-Stick. Sobald ich den Stick anschliesse, hängt sich mein Linux auf... Ohne wenn und aber. Wenn...
  3. CDs Brennen unter Linux - System hängt und ruckelt !

    CDs Brennen unter Linux - System hängt und ruckelt !: Moin ! Also habe nen kleines aber sehr blödes problem mit dem CD brennen ! Wenn ich als root oder User ne CD brenne .. egal ob cdrecord oder...
  4. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...
  5. linux-firmware-nonfree in Centos 15.11 (64 Bit)

    linux-firmware-nonfree in Centos 15.11 (64 Bit): Hallo wie kann man linux-firmware-nonfree in Centos 15.11 (64 Bit) installieren?