Libcurl

Dieses Thema im Forum "Anwendungen" wurde erstellt von Sonic84, 21.09.2005.

  1. #1 Sonic84, 21.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    ich habe gerade versucht den Streamtranscoder zu installen leider bekomme ich bei der Libcurl immer folgenden fehler auch wenn ich es installiert habe:

    Code:
    checking for curl-config... /usr/local/bin/curl-config
    checking for CURL-LIB version >= 0.5.0... no
    *** Could not run CURL test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means CURL was incorrectly installed
    *** or that you have moved CURL since it was installed. In the latter case, you
    *** may want to edit the curl-config script: /usr/local/bin/curl-config
    configure: error: must have libcurl installed!
    Was mach ich falsch?

    Achja ich benutze Suse Linux 9.0
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bananenman, 21.09.2005
    bananenman

    bananenman Routinier

    Dabei seit:
    07.03.2004
    Beiträge:
    410
    Zustimmungen:
    0
    was sagt den das config.log?
     
  4. #3 carstenj, 21.09.2005
    Zuletzt bearbeitet: 21.09.2005
    carstenj

    carstenj Grünschnabel

    Dabei seit:
    09.09.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,

    möglicherweise ist es nicht die richtige Version? Oder es liegt nicht im Pfad?
    Kannst du denn /usr/local/bin/curl-config von Hand aufrufen?
     
  5. #4 Sonic84, 21.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    ja ich könnte von hand die curl-config editieren
     
  6. #5 Sonic84, 21.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    Welches das der libcurl oder des Streamtranscoder?
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    @Sonic84
    Sorry, aber bitte nutze in Zukunft die "Ändern" Funktion um mehre Postings hintereinander zu vermeiden, danke ;)
     
  8. #7 nikster77, 21.09.2005
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Libcurl ist entweder nicht installiert oder benoetigt ein Update.
    apt-cache search curl, emerge --search curl bzw. der Paketmanager deiner Distri sollte dir weiterhelfen.

    Gruss

    Niels
     
  9. #8 Sonic84, 21.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    libcurl: /usr/lib/libcurl.la /usr/local/lib/libcurl.so /usr/local/lib/libcurl.la /usr/local/lib/libcurl.a

    Also libcurl ist installiert. Wie mach ich den das Update? die beiden Befehle gehe mit Putty nicht
     
  10. #9 nikster77, 27.09.2005
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Welche Ditri verwendest du?
     
  11. #10 Sonic84, 27.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    SuSE Linux 9.0 (i586) verwend ich
     
  12. #11 nikster77, 27.09.2005
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Dann einfach ein Softwareupdate per YAST.
    Updateserver im YAST konfigurieren und libcurl neu vom Server ziehen.
     
  13. #12 Sonic84, 28.09.2005
    Sonic84

    Sonic84 Grünschnabel

    Dabei seit:
    21.09.2005
    Beiträge:
    6
    Zustimmungen:
    0
    Und wier mach ich dat. Hab mit yast noch gar keine Erfahrung *leider* :(
     
  14. #13 BreitglutMokel, 22.01.2008
    BreitglutMokel

    BreitglutMokel Grünschnabel

    Dabei seit:
    22.01.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo, ich hab das selbe problem, nur ich hab als OS Debian 4.o Etch

    habe apt-get was hier schon gepostet wurde ausprobiert, irgendwas hat der zwar gemacht, nur funzt ned *grummel*

    vlt kann mir einer weida helfen

    greez breitlgut
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. JBR

    JBR Fichtenschonung

    Dabei seit:
    18.03.2007
    Beiträge:
    561
    Zustimmungen:
    0
    Ort:
    Nolop
    Ist das Biliotheksverzeichnis in $PATH ?
    Test mit
    Code:
    whereis libcurl.so
    Welche Fehlermeldungen erhälst du ?
     
  17. #15 BreitglutMokel, 22.01.2008
    Zuletzt bearbeitet: 22.01.2008
    BreitglutMokel

    BreitglutMokel Grünschnabel

    Dabei seit:
    22.01.2008
    Beiträge:
    5
    Zustimmungen:
    0
    genau den selben wie der kolege der das Thread aufgemacht hat


    checking for curl-config... /usr/local/bin/curl-config
    checking for CURL-LIB version >= 0.5.0... no
    *** Could not run CURL test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means CURL was incorrectly installed
    *** or that you have moved CURL since it was installed. In the latter case, you
    *** may want to edit the curl-config script: /usr/local/bin/curl-config
    configure: error: must have libcurl installed!

    Ich habe Curl-7.17.1 instaliert
     
Thema:

Libcurl