lastfm blockiert Adept Manager und Firefox, help pls

Dieses Thema im Forum "Sonstige Linux Distributionen" wurde erstellt von Janonym, 28.01.2008.

  1. #1 Janonym, 28.01.2008
    Zuletzt bearbeitet: 28.01.2008
    Janonym

    Janonym Grünschnabel

    Dabei seit:
    07.02.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Graz
    Hallo erstmal :)
    Bin eher der Anfänger in Sachen Linux, also schon mal sorry für eventuelle Offensichtlichkeiten^^


    Da der lastfm-client seit einiger Zeit Probleme machte, entschloss ich mich ihn zu deinstallieren. Oder zumindest versuchte ich es... :/
    Beim Installieren von Software (nutze Adept Manager und KPackage) kommt seit kurzer Zeit ein Fehler mit einem gewissen Packet (oder so). Jedenfalls verzweifle ich schon langsam...^^

    Ich kann den Fehlercode nur vom KPackage posten, da unter Adept mir das Error-Fenster verbietet, den Code rauszukopieren:

    Dies kommt bei mir wenn es ich mit KPackage versuche:
    Code:
    DEBIAN_FRONTEND=readline; export DEBIAN_FRONTEND; apt-get remove --yes lastfm ;echo RESULT=$?
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED:
      lastfm
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    41 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 5018kB disk space will be freed.
    dpkg: error processing lastfm (--remove):
     Package is in a very bad inconsistent state - you should
     reinstall it before attempting a removal.
    Errors were encountered while processing:
     lastfm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    RESULT=100
    
    Anfangs dachte ich, es wäre egal, da ich lastfm eh nicht mehr nutze.
    Da aber seit diesem Vorfall NICHTS mehr de/re-installieren kann (egal ob KDMThemeManager oder Firefox 3.0), da immer ein Error mit lastfm auftaucht, muss ich wohl lastfm irgendwie aus meinem Linux Mint KDE 4 (Beta afaik) löschen :/
    (auffallend finde ich den namen lastfm_1%3a1.3.0.62-2_i386.deb der den Error auslöst)

    Naja wie gesagt, taucht der Fehler beim Installieren von z.B KDMTheme auf (obwohl lastfm ja eigentlich nichts mit KDMTheme Manager zu tun haben sollte?)
    Code:
    dpkg: error processing /var/cache/apt/archives/lastfm_1%3a1.3.0.62-2_i386.deb (--unpack):
    

    Adept Manager gibt mir nur aus:
    Code:
    Beim Festschreiben der Änderungen traten Fehler auf. Eventuell gab es beim Herunterladen einiger Pakete Probleme oder das Festschreiben würde Pakete zerstören. 
    

    Da ich jetz nichts mehr de/re-installieren kann, bitte ich um eure Hilfe :hilfe2:
    (teilweise spinnt sogar Firefox [Error:usr/lib/firefox/firefox-bin: symbol lookup error: /usr/lib/libgtk-x11-2.0.so.0: undefined symbol: g_hash_table_ref, das wird aber wahrscheinlich ein anderes Problem sein)

    Jedenfalls schon mal danke fürs Lesen :)

    mfg jan
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 28.01.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Das System gibt dir ja freundlichere Weise schon Hinweise...:-)

    1.

    Versuch mal ein

    Code:
    sudo apt-get install -f
    Das wird vermutlich eine hoffentlich saubere Reinstallation des lastfm-Clients versuchen.

    2.

    Dann mal ein

    Code:
    sudo dpkg --purge lastfm
     
  4. #3 Janonym, 28.01.2008
    Zuletzt bearbeitet: 28.01.2008
    Janonym

    Janonym Grünschnabel

    Dabei seit:
    07.02.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Graz
    Tja wie gesagt, kann den lastfm nicht de/re-installieren:

    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    41 not fully installed or removed.
    Need to get 0B/1651kB of archives.
    After unpacking 0B of additional disk space will be used.
    (Reading database ... 147510 files and directories currently installed.)
    Preparing to replace lastfm 1:1.3.0.62-2 (using .../lastfm_1%3a1.3.0.62-2_i386.deb) ...
    Unpacking replacement lastfm ...
    gconftool-2: symbol lookup error: gconftool-2: undefined symbol: g_option_context_new
    dpkg: warning - old post-removal script returned error exit status 127
    dpkg - trying script from the new package instead ...
    gconftool-2: symbol lookup error: gconftool-2: undefined symbol: g_option_context_new
    dpkg: error processing /var/cache/apt/archives/lastfm_1%3a1.3.0.62-2_i386.deb (--unpack):
     subprocess new post-removal script returned error exit status 127
    gconftool-2: symbol lookup error: gconftool-2: undefined symbol: g_option_context_new
    dpkg: error while cleaning up:
     subprocess post-removal script returned error exit status 127
    Errors were encountered while processing:
     /var/cache/apt/archives/lastfm_1%3a1.3.0.62-2_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    bzw:
    Code:
    dpkg: error processing lastfm (--purge):
     Package is in a very bad inconsistent state - you should
     reinstall it before attempting a removal.
    Errors were encountered while processing:
     lastfm
    
    hab auch schon versucht das komische File lastfm_1%3a1.3.0.62-2_i386.deb zu löschen, hat aber leider auch nichts genützt :/ (File wird einfach wieder erstellt)

    EDIT: Kann es sein dass es was mit lastmp zu tun hat? gehört glaube ich, zum lastfm client, aber hat schon mal früher Probleme gemacht...
     
  5. caba_

    caba_ (caba{_,}|manuw)

    Dabei seit:
    07.08.2007
    Beiträge:
    334
    Zustimmungen:
    0
    omg, bin garnichtmehr konform mit apt-get.

    Versuch mal:
    Code:
    apt-get -f remove
    bzw:
    Code:
    apt-get -f remove lastfm
     
  6. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Auch mal ein apt-get --reinstall lastfm versucht? (Schlägt http://www.selflinux.org/selflinux/html/apt03.html vor :"Wenn Sie ein installiertes Paket irgendwie beschädigt haben oder einfach die Dateien eines Paketes mit der aktuellsten verfügbaren Version neu installieren möchten, können Sie die Option --reinstall wie im folgenden nutzen" )
     
  7. #6 Janonym, 28.01.2008
    Zuletzt bearbeitet: 28.01.2008
    Janonym

    Janonym Grünschnabel

    Dabei seit:
    07.02.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Graz
    Erstmal danke für die Antworten :=)

    Leider keiner der geposteten Methoden funktioniert, das Lastfm Programm blockiert wohl wirklich ALLES :(

    z.B:
    Code:
    jan@jan-tuxmint:~$ sudo apt-get -f remove lastfm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
      lastfm
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    41 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 5018kB disk space will be freed.
    Do you want to continue [Y/n]? y
    dpkg: error processing lastfm (--remove):
     Package is in a very bad inconsistent state - you should
     reinstall it before attempting a removal.
    Errors were encountered while processing:
     lastfm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    

    oder generell beim reinstall:
    Code:
    jan@jan-tuxmint:~$ sudo apt-get --reinstall lastfm
    E: Invalid operation lastfm
    
    Was mich wundert ist, dass egal was ich installiere, lastfm das blockiert, selbst wenn die Datei im /var/cache/apt...etc gelöscht worden ist... Muss es dann nicht sowas wie eine Art "Registry" geben? anders kann ich mirs nicht erklären :(


    EDIT: Auch das purgen funktioniert komischerweise nicht, heißt dass ich muss mein Linux Mint neu aufsetzen? (Offenbar hat der lastfm-client sehr tief ins System geschnitten (Warum auch immer):
    Code:
    jan@jan-tuxmint:~$ sudo  apt-get --purge remove lastfm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
      lastfm
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    41 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 5018kB disk space will be freed.
    Do you want to continue [Y/n]? y
    dpkg: error processing lastfm (--remove):
     Package is in a very bad inconsistent state - you should
     reinstall it before attempting a removal.
    Errors were encountered while processing:
     lastfm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    


    MfG Jan
     
  8. #7 supersucker, 28.01.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Das sollte helfen -> wenn nicht resultierende Ausgabe hier posten.

    Würde wetten, das pre oder post-removal nicht klappt.

    Aber das kriegen wir dann auch noch hin.
     
  9. #8 Janonym, 28.01.2008
    Janonym

    Janonym Grünschnabel

    Dabei seit:
    07.02.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Graz
    Der Befehl klingt super (force), nur taucht wiedermal der gleiche error auf :/
    Code:
    jan@jan-tuxmint:~$ sudo dpkg --purge --force-all lastfm
    [sudo] password for jan:
    dpkg - warning, overriding problem because --force enabled:
     Package is in a very bad inconsistent state - you should
     reinstall it before attempting a removal.
    (Reading database ... 147509 files and directories currently installed.)
    Removing lastfm ...
    gconftool-2: symbol lookup error: gconftool-2: undefined symbol: g_option_context_new
    dpkg: error processing lastfm (--purge):
     subprocess post-removal script returned error exit status 127
    Errors were encountered while processing:
     lastfm
    
    und danke fürs dran arbeiten^^
     
  10. #9 supersucker, 28.01.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Code:
    dpkg: error processing lastfm (--purge):
     subprocess post-removal script returned error exit status 127
    -> /var/lib/dpkg/info/lastfm.postrm mit einen Editor öffnen
    -> In die zweite Zeile ein

    Code:
    exit 0
    schreiben.
    -> Nochmal "purgen".
    -> Feddich.
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 Janonym, 28.01.2008
    Zuletzt bearbeitet: 28.01.2008
    Janonym

    Janonym Grünschnabel

    Dabei seit:
    07.02.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Graz
    Nun ja das Problem ist, ich habe keinen /var/log/dpkg/info... Ordner, sondern nur ein logfile von dpgk gefunden (steht nichts interessantes drinn)

    Außerdem scheint sich mein Linux sowieso von selber aufzulösen, da ich nicht mal mehr Konqueror, Firefox, Kopete, etc mehr starten kann (irgendein Error mit fehlender libgtk-x11 oder so)

    Jedenfalls habe ich jetz schon alles probiert und kanns nur mehr aufgeben, da ich nur alles schlimmer mache^^ (schnell noch daten retten..)

    Vielen Dank für eure Hilfe :D

    muss jetz wohl Mint neu aufsetzen^^

    MfG Jan
     
  13. #11 Tomekk228, 28.01.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Also da hast du dir aber was übel zerschossen :>
     
Thema:

lastfm blockiert Adept Manager und Firefox, help pls

Die Seite wird geladen...

lastfm blockiert Adept Manager und Firefox, help pls - Ähnliche Themen

  1. Verhaegen: ARM blockiert freien Treiber für Mali

    Verhaegen: ARM blockiert freien Treiber für Mali: Luc Verhaegen, Entwickler des freien Mali-Grafiktreibers »Lima«, kritisiert ARM und fordert das Unternehmen auf, endlich für einen freien Treiber...
  2. Firestarter - google.tld blockiert - Rückgängig machen unmöglich

    Firestarter - google.tld blockiert - Rückgängig machen unmöglich: [erledigt]Firestarter - google.tld blockiert - Rückgängig machen unmöglich Hallo, ich habe mit Firestarter die letzten Tage ein wenig...
  3. socket() blockiert

    socket() blockiert: hallo! ich hab jetzt mit netzwerkprogrammierung angefangen, und hab versucht n kleinen 'server' zu schreiben, der im Grunde nur auf...
  4. Anzahl blockierter Signale

    Anzahl blockierter Signale: Hallo, mit sigpending() kann man ja die Menge der blockierten Signale erfragen und mit sigismember() ob ein bestimmtes Signal in dieser...
  5. quake 3 Sound Problem (Audioausgabe blockiert von Mediaplayer)

    quake 3 Sound Problem (Audioausgabe blockiert von Mediaplayer): Moin liebes Unixboard Hm. Also ich will Quake 3 mit Spielsounds spielen und dabei gleichzeitig Musik über einen Mediaplayer hören (im...