Kernel Problem

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Markus101, 16.06.2006.

  1. #1 Markus101, 16.06.2006
    Markus101

    Markus101 Jungspund

    Dabei seit:
    16.06.2006
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo Zusammen,

    ich hab mir den Kernel 2.4... herunterladen und konfiguriert
    Will neustarten und dann kommt folgende Meldung:

    ds: no socket drivers loaded!
    kmod: failed to exec /sbin/modprobe -s -k block major-33 errno = 2
    VFS: Cannot open root device "2101" or 21:01
    Please append a correct "root=" boot option
    Kernel panic: VFS: Unable to mount root fs on 21:01


    Ich hab eine ganz normale pata Platte angeschlossen!
    Das Board ist ein Commell LV667

    Wäre echt super wenn mir jemand helfen kann!

    Grüße Markus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 slasher, 16.06.2006
    slasher

    slasher König

    Dabei seit:
    22.03.2006
    Beiträge:
    827
    Zustimmungen:
    0
    du hast vergessen die Unterstützung für deinen Festplattencontroller fest in den Kernel zu bauen.
    Oder wenn du diesen Support als Modul gebaut hast, dann hast du es im initrd vergessen.
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Da hast du wohl die Module fuer die Block-Devices vergessen und/oder nicht in die initrd gepackt, wuerde ich mal sagen.

    Edit: Da war slasher mal wieder schneller. :D
     
  5. #4 Markus101, 16.06.2006
    Zuletzt bearbeitet: 16.06.2006
    Markus101

    Markus101 Jungspund

    Dabei seit:
    16.06.2006
    Beiträge:
    12
    Zustimmungen:
    0
    Funktioniert leider immer noch nicht!

    Bei denn Block Devices hab ich den Loopback Support hinzugefügt

    grüße
     
  6. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Was ist mit den Dateisystemtreibern?
    Sind die auch fest im Kernel?


    edit: Loopback ist dafür unerheblich.
     
  7. #6 slasher, 19.06.2006
    slasher

    slasher König

    Dabei seit:
    22.03.2006
    Beiträge:
    827
    Zustimmungen:
    0
    und sonst hast du nichts gemacht? In Beitrag #2 und #3 wurde dir schon die vermutliche Lösung präsentiert und nun fragt sich der slasher, ob der OP das auch geprüft hat :-).
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Bâshgob, 19.06.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    *hüstel*

    Das fragt sich nicht nur der slasher ;)
     
  10. #8 Wolfgang, 19.06.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Wenn du mit initrd arbeiten willst, solltest du cramfs fest einbinden.
    Ohne initrd müssen die FS deiner root fest eingebunden werden.

    Gruß Wolfgang
     
Thema:

Kernel Problem

Die Seite wird geladen...

Kernel Problem - Ähnliche Themen

  1. openSuse 13.2 mit Custom Kernel systemd Problem

    openSuse 13.2 mit Custom Kernel systemd Problem: Hallo, ich habe bei openSuse 13.2 einen neuen Custom Kernel (3.17.5) eingespielt. Leider kommt beim reboot des neuen Kernel folgende...
  2. LVS ARP-Problem mit Kernel 3.x

    LVS ARP-Problem mit Kernel 3.x: Hallo! Weiß jemand ob beim Kernel 3.x immernoch das "ARP-Problem" bei LVS-DR besteht? Wenn ja, gibt es dazu Abhilfen? Mfg
  3. Kernelboot Problem (ext4)

    Kernelboot Problem (ext4): Hallo, lang, lang ist's her, als ich das letzte mal gentoo auf meinem ersten amd64 Bit PC hatte und nun will ich endlich wieder zu meiner...
  4. Kernel 3 Kompilierungsproblem unter XEN

    Kernel 3 Kompilierungsproblem unter XEN: Hallo, Ich habe eine openSuse 12.1 und SLES 11 SP1 unter XEN 4.1.2 im HVM Modus laufen. Wenn ich für die beiden System einen neuen Kernel...
  5. Unbekanntes Netzwerkproblem [kernel?]

    Unbekanntes Netzwerkproblem [kernel?]: Moin, ich hab ein stranges Problem mit meiner Netzwerkkarte. Leider hab ich keine Idee woran es liegt. Das ganze ist nicht wirklich...