kein mounten nach Authentifizierung über LDAP-Slave

Dieses Thema im Forum "Samba" wurde erstellt von christian13, 22.09.2006.

  1. #1 christian13, 22.09.2006
    christian13

    christian13 Grünschnabel

    Dabei seit:
    25.07.2006
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo,

    ich habe ein Samba Server als PDC mit LDAP realisiert. Auf den Linux Clients werden die Freigaben nach der Authentifizierung über LDAP mit pam_mount gemountet. Das funktioniert bestens.

    Jetzt habe auf einem anderen Server eine zweite LDAP DB als Slave eingerichtet.
    Die LDAP Master und LDAP Slave werden repliziert. Alles soweit OK.
    Wenn ich jetzt auf dem Samba Server den LDAP Master stoppe, kann ich mich über den LDAP Slave authentifizieren.
    Aber es wird kein mount ausgeführt?!?

    wenn ich auf der Konsole
    mount -t cifs -o username=test,password=geheim //samba/Freigabe /Name
    eingebe, kommt folgende Fehlermeldung in /var/log/warn
    Sep 21 11:08:34 client kernel: CIFS VFS: Send error in SessSetup = -13
    Sep 21 11:08:34 client kernel: CIFS VFS: cifs_mount failed w/return code = -13

    Starte ich den LDAP Master funktioniert alles wieder.

    Wenn der LDAP Master gestartet ist, wird bei den Verzeichnissen und Dateien der Benutzername korrekt angegeben und als Gruppe Domain User.
    Stoppe ich den LDAP Master, wird die korrekte UID und GID angezeigt. Diese sind aber auf beiden Server identisch (geprüft mit getent passwd).
    Muss da noch irgendein mapping gemacht werden?

    Danke für Tipps

    christian13
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 AndreasMeyer, 24.09.2006
    AndreasMeyer

    AndreasMeyer FreeBSD 6.1

    Dabei seit:
    16.07.2005
    Beiträge:
    48
    Zustimmungen:
    0
    Wenn statt den Benutzer- und Gruppennamen nur die Nummern (UID und GID) angezeigt werden, so ist der name-service switch (kurz: NSS) falsch konfiguriert.

    Da ich nur FreeBSD einsetze, kann ich Dir für Linux nicht genau sagen, welche Konfigurationsdateien Du für NSS anpassen musst. Doch laut:
    http://de.gentoo-wiki.com/Samba_PDC_mit_LDAP-Backend#BDC_mit_eigenem_LDAP_server
    tipe ich auf /etc/ldap.conf
     
  4. #3 christian13, 27.09.2006
    christian13

    christian13 Grünschnabel

    Dabei seit:
    25.07.2006
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo,

    das Problem ist jetzt behoben.
    Es mussten noch ein paar zusätzliche Anpassungen in der ldap.conf von dem Master und Slave gemacht werden, die ich übersehen hatte.

    Danke für die Hilfe

    christian13
     
Thema:

kein mounten nach Authentifizierung über LDAP-Slave

Die Seite wird geladen...

kein mounten nach Authentifizierung über LDAP-Slave - Ähnliche Themen

  1. kein schreibrecht nach mounten

    kein schreibrecht nach mounten: hallo.. ich hab eine ntfs partition mit fstab dauerhaft gemountet. nur kann ich darauf nicht mal als root sachen ändern oder speichern.. fstab...
  2. kein autom. Mounten von hotplugs unter CentOS4.4

    kein autom. Mounten von hotplugs unter CentOS4.4: Hallo, wir haben hier zwei Maschinen stehen, auf der einen laeuft CentOS 4.3, auf der anderen 4.4 Unter 4.3 werden USB-Sticks automatisch auf dem...
  3. DVDLw nicht in /dev angezeigt--> kein mounten mögl.

    DVDLw nicht in /dev angezeigt--> kein mounten mögl.: tach auch... bin in linux (10.0) recht unerfahren deshalb auch neu hier ( quasi meine vorstellungsrunde) aber zum problem: nach der...
  4. Fat32 mounten: kein Schreibzugriff für user/root

    Fat32 mounten: kein Schreibzugriff für user/root: Nabend, wie der Titel schon sagt, ich kann weder als user noch als root auf meine Fat32 Partition schreiben. Der Eintrag in der fstab sieht so...
  5. Kein DVD mounten mehr möglich

    Kein DVD mounten mehr möglich: Also ich habe folgendes Problem ich kann auf einmal keine DVDs mehr mounten (Cds gehen) Es kommt keine Fehlermeldung und ich kann den...