Zugriff auf Samba-Server nur per IP möglich

Dieses Thema im Forum "Samba" wurde erstellt von dropped, 11.06.2012.

  1. #1 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo zusammen,
    ich habe auf einen Gentoosystem Cups (als Printserver) und Samba (zum Freigeben der Drucker / Treiber) eingerichtet.

    Allerdings habe ich folgendes Problem:
    Wenn ich mich als lokaler Administrator anmelde bekomme ich Zugriff über \\IP-Adresse UND \\Servername. Eine Freigabe muss ich hier nicht mehr mit anhängen.

    Wenn ich mich allerdings als Domänen-Benutzer anmelde, kann ich nur über \\IP-Adresse auf den Samba-Server zugreifen.
    Hier möchte ich gerne auch über \\ServerName zugreifen können.

    Meine smb.conf:
    Code:
    1  [global]
     2  smb ports = 139
     3 # smb ports = 445 139
     4  interfaces = 192.168.0.201
     5  bind interfaces only = Yes
     6  hosts allow = 192.168.0.0/24
     7  load printers = yes
     8  printing = cups
     9  printcap name = cups
    10 #guest ok = yes
    11 #guest account = nobody
    12  public = yes
    13  log file = /var/log/samba/log.%m
    14  security = share
    15  name resolve order = lmhosts wins bcast host
    16  log level = 3
    17
    18
    19  [printers]
    20  available = yes
    21
    22  comment = All Printers
    23  path = /var/spool/samba
    24  browseable = yes
    25  public = yes
    26  guest ok = yes
    27  writable = no
    28  printable = yes
    29
    30  [print$]
    31  comment = Printer Drivers
    32  path = /etc/samba/drivers/
    33  browseable = yes
    34  guest ok = yes
    35  read only = no
    36  write list = root
    
    Kann mir jemand weiterhelfen, wie ich Samba dazu bekomme auch Domänen-Benutern Zugriff zu gewähren?


    Gruß,
    dropped
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 11.06.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Wenn du über den Servernamen zugreifen willst, muss natürlich ein DNS im Netzwerk auch den Namen auflösen können und dieser muss von den Clients als Default-DNS verwendet werden. Alternativ kannst du WINS verwenden, wozu im Samba der WINS-Support aktiviert werden muss.
     
  4. #3 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo,
    da hast du natürlich recht.
    Ich hatte vergessen zu erwähnen das die DNS-Auflösung einwandfrei funktioniert. Sowohl von den Windows Clients als auch von Samba-Server selbst.
    Wenn ich dann als Domänen-User per \\ServerName auf die Freigabe zugreifen möchte erscheint im Windows Client folgende Fehlermeldung:
    win_error.png
     
  5. #4 bitmuncher, 11.06.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Wird denn der Samba-Server aufgelistet, wenn du auf der Windows-Kiste 'net view' verwendest?
     
  6. #5 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Ja, wird er:
    net_view.png
    Nur der Zugriff funktioniert nicht. Auch über die Netzwerkumgebung nicht...
     
  7. #6 bitmuncher, 11.06.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Dann ist die Namensauflösung also offenbar nicht das Problem, sondern eher die Authentifizierung des Rechners. Existiert ein Account für den entsprechenden Rechnernamen des Clients?
     
  8. #7 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Auf dem Samba-Server habe ich keine Accounts angelegt. Ich möchte auch nicht für jeden einzelnen Client dort einen Account erzeugen. Über die IP-Adresse funktioniert es ja auch so. Oder habe ich dich missverstanden?
     
  9. #8 bitmuncher, 11.06.2012
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Wenn Clients ohne Auth auf den Server zugreifen können sollen und das über den Namen, dann muss der Server wissen für welche Workgroup er zuständig ist. Ausserdem muss sichergestellt sein, dass der Server auch die Namen der Clients (z.B. über WINS) auflösen kann. Und NetBIOS muss korrekt funktionieren, was nur geht, wenn ein NetBIOS-Name in der Konfiguration angegeben wurde.
     
  10. #9 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Ich habe die beiden Einträge hinzugefügt. Allerdings kommt immer noch die Fehlermeldung, dass von diesem Computer mit diesem Konto da nicht drauf zugegriffen werden kann.

    Ich verzweifele...
     
  11. nighT

    nighT Guest

    Was steht denn im entsprechenden Samba-Log?

    Eventuell hilft dir auch das weiter. Stichwort "security" und "force user".
     
  12. #11 dropped, 11.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Beim Aufruf von \\dataprint erscheint diese Meldung im log:

    Code:
    [2012/06/11 14:20:03.769346,  3] smbd/negprot.c:386(reply_nt1)
      not using SPNEGO
    [2012/06/11 14:20:03.769414,  3] smbd/negprot.c:692(reply_negprot)
      Selected protocol NT LM 0.12
    [2012/06/11 14:20:17.085330,  3] smbd/sec_ctx.c:310(set_sec_ctx)
      setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2012/06/11 14:20:17.085405,  3] smbd/connection.c:31(yield_connection)
      Yielding connection to
    [2012/06/11 14:20:17.085629,  3] smbd/server.c:924(exit_server_common)
      Server exit (failed to receive smb request)
    [2012/06/11 14:20:26.507231,  3] smbd/process.c:1489(process_smb)
      Transaction 0 of length 159 (0 toread)
    [2012/06/11 14:20:26.507648,  3] smbd/process.c:1298(switch_message)
      switch message SMBnegprot (pid 26422) conn 0x0
    [2012/06/11 14:20:26.507844,  3] smbd/sec_ctx.c:310(set_sec_ctx)
      setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2012/06/11 14:20:26.508194,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [PC NETWORK PROGRAM 1.0]
    [2012/06/11 14:20:26.508396,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [LANMAN1.0]
    [2012/06/11 14:20:26.508589,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [Windows for Workgroups 3.1a]
    [2012/06/11 14:20:26.508763,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [LM1.2X002]
    [2012/06/11 14:20:26.508933,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [LANMAN2.1]
    [2012/06/11 14:20:26.509105,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [NT LM 0.12]
    [2012/06/11 14:20:26.509285,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [SMB 2.002]
    [2012/06/11 14:20:26.509456,  3] smbd/negprot.c:587(reply_negprot)
      Requested protocol [SMB 2.???]
    [2012/06/11 14:20:26.509915,  3] smbd/negprot.c:386(reply_nt1)
      not using SPNEGO
    [2012/06/11 14:20:26.510217,  3] smbd/negprot.c:692(reply_negprot)
      Selected protocol NT LM 0.12
    [2012/06/11 14:20:47.086347,  3] smbd/sec_ctx.c:310(set_sec_ctx)
      setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2012/06/11 14:20:47.086490,  3] smbd/connection.c:31(yield_connection)
      Yielding connection to
    [2012/06/11 14:20:47.086675,  3] smbd/server.c:924(exit_server_common)
      Server exit (failed to receive smb request)
    
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 dropped, 12.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    Bin ich der Einzige mit diesem Problem? Kann doch eigentlich gar nicht sein.

    PS: security MUSS zwangsläufig auf share stehen, sonst bekommt er überhaupt keine Verbindung.



    Gruß,
    dropped
     
  15. #13 dropped, 13.06.2012
    dropped

    dropped Grünschnabel

    Dabei seit:
    11.06.2012
    Beiträge:
    8
    Zustimmungen:
    0
    so, ich habe es gelöst:
    Im ActiveDirectory war noch ein Computer Names Dataprint vorhanden. Nachdem ich diesen rausgekickt habe, hat alles wunderbar funktioniert.

    Trotzdem danke für Eure Hilfe.

    PS: kann geclosed werden


    dropped
     
Thema: Zugriff auf Samba-Server nur per IP möglich
Besucher kamen mit folgenden Suchen
  1. smbnegprot

    ,
  2. samba zugriff ip

    ,
  3. windows 7 fileshare zugriff nur per ip

    ,
  4. scan to smb auf ip ok auf name nicht ok
Die Seite wird geladen...

Zugriff auf Samba-Server nur per IP möglich - Ähnliche Themen

  1. Windows 7 - Zugriff auf Samba-Server

    Windows 7 - Zugriff auf Samba-Server: Hallo, der Zugriff auf meinen Samba-Server funktioniert einwandfrei von einem Client mit Windows XP, aber nicht von einem Client mit Windows 7....
  2. zugriff auf Samba-Server hängt von Zeit zu Zeit

    zugriff auf Samba-Server hängt von Zeit zu Zeit: hi, ich habe einen Linux-Samba-Server eingerichtet, um mir unter Windows Dateien von der Linux-Kiste ansehen zu können. Jetzt habe ich aber das...
  3. Zugriff auf Samba-Server

    Zugriff auf Samba-Server: hallo zusammen, bin gerade dabei einen Samba Server aufzusetzen und bis jetzt treten zwei Probleme auf: 1. Wenn ich mich einmal mit einem...
  4. Samba-Server und Zugriffsrechte

    Samba-Server und Zugriffsrechte: Hi Ich hab nun schon längere Zeit nen Samba Server auf meinem System aufgesetzt und läuft auch alles wunderbar. Ne eingebundenen...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...