Installationsfehler bei SVGALIB

Dieses Thema im Forum "Gentoo" wurde erstellt von schleudertrauma, 06.11.2006.

  1. #1 schleudertrauma, 06.11.2006
    schleudertrauma

    schleudertrauma Jungspund

    Dabei seit:
    04.10.2006
    Beiträge:
    21
    Zustimmungen:
    0
    Ort:
    Wiesbaden
    Servus,

    ich habe mein Problem schon im englischen Forum gepostet aber bisher gabs darauf leider keine Antwort. Aaaalso. Ich würde gern Ammarok emergen aber leider wird dafür ja das Paket SVGALIB benötigt. So bald ich das aber installieren will bricht emerge mit folgendem Fehler ab:




    make[1]: Leaving directory `/var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/threeDKit'
    * Preparing svgalib_helper module
    make -C /usr/src/linux SUBDIRS=/var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper CLASS_CFLAGS= modules
    make[1]: Entering directory `/usr/src/linux-2.6.17-gentoo-r8'

    WARNING: Symbol version dump /usr/src/linux-2.6.17-gentoo-r8/Module.symvers
    is missing; modules will have no dependencies and modversions.

    CC [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.o
    CC [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/i810.o
    CC [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/interrupt.o
    CC [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/virtual.o
    CC [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/displaystart.o
    LD [M] /var/tmp/portage/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/svgalib_helper.o
    Building modules, stage 2.
    MODPOST
    /bin/sh: scripts/mod/modpost: No such file or directory
    make[2]: *** [__modpost] Error 127
    make[1]: *** [modules] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.17-gentoo-r8'
    make: *** [default] Error 2

    !!! ERROR: media-libs/svgalib-1.9.25 failed.
    Call stack:
    ebuild.sh, line 1546: Called dyn_compile
    ebuild.sh, line 937: Called src_compile
    svgalib-1.9.25.ebuild, line 78: Called linux-mod_src_compile
    linux-mod.eclass, line 482: Called die

    !!! Unable to make KDIR=/usr/src/linux default.
    !!! If you need support, post the topmost build error, and the call stack if relevant.



    Ich habe in keinem Forum was gefunden. Ich habe versucht, SVGALIB einzeln zu installieren, ich habe es mit --newuse versucht, habe testweise alle USE-Flags aus meiner make.conf gelöscht. Außerdem habe ich makeopts auf -j1 gesetzt in der Hoffnung, dass würde es klappen. Das alles hat nix gebracht. Ich weiss einfach nicht mehr weiter weil jedes zweite verdammte Programm dieses Paket braucht.

    Wäre super wenn jemand von Euch zumindest einen Anhaltspunkt hätte, was es sein könnte. Zumal ich mit der Fehlermeldung absolut nix anfangen kann. Google bringt mir dazu leider auch nichts.

    Danke schonmal.

    Gruß Daniel
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 webstar, 06.11.2006
    Zuletzt bearbeitet: 06.11.2006
    webstar

    webstar LFS-Junkie/ExRPMbuilder

    Dabei seit:
    12.04.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Ort:
    Aus dem schönen Elbflorenz
    Hab zwar keine Gentoo-Linux, aber wo steht das Amarok die SVGA-Libs braucht?!
    Meine Amarok-Install erforderte keine SVGA-Libs.

    Info's siehe auch im angehängten Config.log!

    Schönen Tag noch, man liest sich. :)
    Euer Jens Ornot alias Webstar
     

    Anhänge:

  4. #3 schleudertrauma, 06.11.2006
    schleudertrauma

    schleudertrauma Jungspund

    Dabei seit:
    04.10.2006
    Beiträge:
    21
    Zustimmungen:
    0
    Ort:
    Wiesbaden
    Hm seltsam... ist es vielleicht auch nicht normal, dass mir Firefox außerdem noch gnome-base auf die Platte gemacht hat?
     
  5. #4 schleudertrauma, 06.11.2006
    schleudertrauma

    schleudertrauma Jungspund

    Dabei seit:
    04.10.2006
    Beiträge:
    21
    Zustimmungen:
    0
    Ort:
    Wiesbaden
    Juhu! Problem gelöst. Hier die Erklärung:

    Die Datei Module.symvers und das Verzeichnis scripts/mod/modpost befinden sich in den Kernelquellen. Aber sie werden erst erzeugt, wenn mindestens einmal ein make modules gelaufen ist. Im Installationtutorial stand das aber für Genkernelnutzer nicht drin. Folglich habe ich nie ein make modules ausgeführt und die Verzeichnisse waren nicht da.

    Ich musst gar nicht den Kernel neu kompilieren. Das habe ich abgebrochen. Es reichte vollkommen aus ein make modules zu machen.
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Installationsfehler bei SVGALIB

Die Seite wird geladen...

Installationsfehler bei SVGALIB - Ähnliche Themen

  1. Installationsfehler: in the prefix, you've chosen, are no KDE headers installed

    Installationsfehler: in the prefix, you've chosen, are no KDE headers installed: Hi! Also ich möchte ein paar Programme installieren (kmyfirewall, kiso ......) Wenn ich jetzt allerdings ./configure eingebe, kommt immer...
  2. SuSE 10.2 : Cannot find the image Installationsfehler

    SuSE 10.2 : Cannot find the image Installationsfehler: Hallo zusammen! ich habe folgendes Problem bei der Installation von OpenSuse Linux 10.2. Ich habe mir die .iso Datein gesaugt und auf 5 CDs...
  3. openSUSE Installationsfehler

    openSUSE Installationsfehler: Hallo Linux User Wahrscheinlich habt ihr zu meinem problem schon 1000 threads gelesen, aber ich komme irgendwie nicht weiter. Habe gestern...
  4. Grundinstallationsfehler???

    Grundinstallationsfehler???: guten morgen versuche gerade ubuntu zu installieren bekomme während der installation folgende fehlermeldung: [!!] Grundsystem installieren...
  5. Kann svgalib nicht installieren

    Kann svgalib nicht installieren: Moin also ich bin nun auch mehr oder weniger fertig mit der Installation. Nun wollte ich KDE installieren, aber wenn svgalib installiert werden...