glib-2.0 neuste version wurde nicht registriert in einer $VARIABE

Dieses Thema im Forum "Linux OS" wurde erstellt von SubSonniC, 10.12.2006.

  1. #1 SubSonniC, 10.12.2006
    SubSonniC

    SubSonniC Mitglied

    Dabei seit:
    21.10.2006
    Beiträge:
    31
    Zustimmungen:
    0
    Hallo,

    hab das Problem, dass ich gtk+-2.10 installieren möchte und dafür aber glib-2.0 nötig ist in der Version >2.10. deswegen hab ich glib-2.0 in Version 2.12 installiert.

    nun bekomm ich aber dieses bei der configuration von gtk+-2.10

    checking for GLIB - version >= 2.12.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.10.3)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLIB 2.12.0 or better is required. The latest version of
    *** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

    § echo $LD_LIBRARY_PATH ergab keine einträge........sehr komisch???????

    welche Varable muss ich wohin zeigen lassen???

    § locate glib-2.0

    /usr/include/glib-2.0
    /usr/include/glib-2.0/glib-object.h
    /usr/include/glib-2.0/glib.h
    /usr/include/glib-2.0/glib
    /usr/include/glib-2.0/glib/gasyncqueue.h
    /usr/include/glib-2.0/glib/galloca.h
    /usr/include/glib-2.0/glib/garray.h
    /usr/include/glib-2.0/glib/gbacktrace.h
    /usr/include/glib-2.0/glib/gatomic.h
    /usr/include/glib-2.0/glib/gcompletion.h
    /usr/include/glib-2.0/glib/gcache.h
    /usr/include/glib-2.0/glib/gfileutils.h
    /usr/include/glib-2.0/glib/gconvert.h
    /usr/include/glib-2.0/glib/gdataset.h
    /usr/include/glib-2.0/glib/gdate.h
    /usr/include/glib-2.0/glib/gdir.h
    /usr/include/glib-2.0/glib/gerror.h
    /usr/include/glib-2.0/glib/gi18n-lib.h
    /usr/include/glib-2.0/glib/ghash.h
    /usr/include/glib-2.0/glib/ghook.h
    /usr/include/glib-2.0/glib/gi18n.h
    /usr/include/glib-2.0/glib/giochannel.h
    /usr/include/glib-2.0/glib/gkeyfile.h
    /usr/include/glib-2.0/glib/glist.h
    /usr/include/glib-2.0/glib/gmacros.h
    /usr/include/glib-2.0/glib/gmain.h
    /usr/include/glib-2.0/glib/gmappedfile.h
    /usr/include/glib-2.0/glib/gmarkup.h
    /usr/include/glib-2.0/glib/gmem.h
    /usr/include/glib-2.0/glib/gmessages.h
    /usr/include/glib-2.0/glib/gnode.h
    /usr/include/glib-2.0/glib/goption.h
    /usr/include/glib-2.0/glib/gpattern.h
    /usr/include/glib-2.0/glib/gprimes.h
    /usr/include/glib-2.0/glib/gqsort.h
    /usr/include/glib-2.0/glib/gquark.h
    /usr/include/glib-2.0/glib/gqueue.h
    /usr/include/glib-2.0/glib/grand.h
    /usr/include/glib-2.0/glib/grel.h
    /usr/include/glib-2.0/glib/gscanner.h
    /usr/include/glib-2.0/glib/gshell.h
    /usr/include/glib-2.0/glib/gslice.h
    /usr/include/glib-2.0/glib/gslist.h
    /usr/include/glib-2.0/glib/gspawn.h
    /usr/include/glib-2.0/glib/gstdio.h
    /usr/include/glib-2.0/glib/gstrfuncs.h
    /usr/include/glib-2.0/glib/gstring.h
    /usr/include/glib-2.0/glib/gthread.h
    /usr/include/glib-2.0/glib/gthreadpool.h
    /usr/include/glib-2.0/glib/gtimer.h
    /usr/include/glib-2.0/glib/gtree.h
    /usr/include/glib-2.0/glib/gtypes.h
    /usr/include/glib-2.0/glib/gunicode.h
    /usr/include/glib-2.0/glib/gutils.h
    /usr/include/glib-2.0/glib/gwin32.h
    /usr/include/glib-2.0/glib/gprintf.h
    /usr/include/glib-2.0/gobject
    /usr/include/glib-2.0/gobject/gparamspecs.h
    /usr/include/glib-2.0/gobject/gboxed.h
    /usr/include/glib-2.0/gobject/gclosure.h
    /usr/include/glib-2.0/gobject/genums.h
    /usr/include/glib-2.0/gobject/gobject.h
    /usr/include/glib-2.0/gobject/gparam.h
    /usr/include/glib-2.0/gobject/gsourceclosure.h
    /usr/include/glib-2.0/gobject/gsignal.h
    /usr/include/glib-2.0/gobject/gtypemodule.h
    /usr/include/glib-2.0/gobject/gtype.h
    /usr/include/glib-2.0/gobject/gvaluecollector.h
    /usr/include/glib-2.0/gobject/gtypeplugin.h
    /usr/include/glib-2.0/gobject/gvalue.h
    /usr/include/glib-2.0/gobject/gvaluearray.h
    /usr/include/glib-2.0/gobject/gobjectnotifyqueue.c
    /usr/include/glib-2.0/gobject/gvaluetypes.h
    /usr/include/glib-2.0/gobject/gmarshal.h
    /usr/include/glib-2.0/gmodule.h
    /usr/lib/pkgconfig/glib-2.0.pc
    /usr/lib/libglib-2.0.so.0
    /usr/lib/libglib-2.0.so.0.1000.3
    /usr/lib/libglib-2.0.la
    /usr/lib/libglib-2.0.a
    /usr/lib/glib-2.0
    /usr/lib/glib-2.0/include
    /usr/lib/glib-2.0/include/glibconfig.h
    /usr/lib/libglib-2.0.so
    /usr/lib32/libglib-2.0.so.0
    /usr/lib32/libglib-2.0.so.0.1000.3
    /usr/share/aclocal/glib-2.0.m4
    /usr/share/glib-2.0
    /usr/share/glib-2.0/gettext
    /usr/share/glib-2.0/gettext/po
    /usr/share/glib-2.0/gettext/po/Makefile.in.in
    /usr/share/glib-2.0/gettext/mkinstalldirs
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 patlkli, 10.12.2006
    patlkli

    patlkli Linux-Freak

    Dabei seit:
    23.11.2005
    Beiträge:
    158
    Zustimmungen:
    0
    Ort:
    Landshut
    Was hältst denn davon, mal das zu probieren, was dir das Skript vorschlägt - ldconfig ausführen. ;)

    Grüße,
    patlkli!
     
  4. #3 SubSonniC, 11.12.2006
    SubSonniC

    SubSonniC Mitglied

    Dabei seit:
    21.10.2006
    Beiträge:
    31
    Zustimmungen:
    0
    Tschuldige mal bitte.
    Aber glaubst Du ich hätte das nicht schon ausprobiert. Lesen kann ich. Hast Du vlleicht noch einen anderen Vorschlag.

    ldconfig hat sich ausgeführt ohne irgendeine meldung und fertig.
     
  5. #4 hoernchen, 11.12.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    uno : etwas freundlicher bitte, zumal du ja nicht schreibst was du alles schon gemacht hast. daraus folgt :

    due : *** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.10.3)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files

    das schon geprueft ?

    bzw. dritter hit von oben
     
  6. #5 SubSonniC, 12.12.2006
    Zuletzt bearbeitet: 12.12.2006
    SubSonniC

    SubSonniC Mitglied

    Dabei seit:
    21.10.2006
    Beiträge:
    31
    Zustimmungen:
    0
    Also ich habe das alles schon geprüft.

    pkg-config --modversion liegt richtig.

    /etc/ld.so.conf existiert nicht
    und die Variable

    $LD_LIBRARY_PATH hat keinen inhalt.

    Ich besitze ein Ubuntu 6.06 amd64



    die Frage die sich mir stellt ist nicht unbedingt wie ich die alte glib version deinstalliere sondern eher wie ich dem System sage, das eine neue version verfügbar ist.

    wenn ich glib deinstalliern will sagt er mir gleich , dass da noch über 500 MB mit deinstalliert werden. das wird wohl an den abhängigkeiten liegen.

    ich meine das ist warscheinlich nur eine kleine konsolen anweisung um irgend eine Variable zu setzen oder so. Das Problem kann doch nicht das erste mal irgendwo aufgetaucht sein.
     
  7. #6 hoernchen, 12.12.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    das steht unter garantie mehrmal auf der ersten ergebnis-seite des links den ich gepostet habe, oder in einem der anderen 1.730.000 ergebnisse.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

glib-2.0 neuste version wurde nicht registriert in einer $VARIABE

Die Seite wird geladen...

glib-2.0 neuste version wurde nicht registriert in einer $VARIABE - Ähnliche Themen

  1. Shell-Script > neustes Aenderungsdatum von mehreren Dateien auslesen

    Shell-Script > neustes Aenderungsdatum von mehreren Dateien auslesen: Hallo zusammen, Dies ist meiner erster Post, mit Boardsuche wurde ich leider nicht fündig, aber ich hoffe, jemand weiss Rat :)! Folgende...
  2. backtrack auf dehn neusten stand bringen???

    backtrack auf dehn neusten stand bringen???: hi habe die backtrack3 beta auf meine festplatte mit windoof xp instaliert. backtrack 3 ist dock slackware oder??? also kann ich slackware auf...
  3. Neuste C++ version

    Neuste C++ version: Habe grade versucht /configure auszuführen. bekomme nun follgende Fehlermeldung: checking if C++ programs can be compiled... no configure:...
  4. Kubuntu 5.10 auf die neuste Version updaten?

    Kubuntu 5.10 auf die neuste Version updaten?: Hallo, ich möchte mir mal Kubuntu installieren. Das problem ist zur Zeit ich habe nur Kubuntu 5.10 auf DVD. Ist es irgendwie möglich das wenn...
  5. Die 3 neusten/ältesten Dateien anzeigen

    Die 3 neusten/ältesten Dateien anzeigen: Hallo! Mit >ls -t | tail -n3 >ls -tr | tail -n3 werden mir die 3 neusten/ältesten Dateien/Ordner eines Verzeichnisses aufgelistet....