doppelt-NAT?

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von rikola, 13.01.2009.

  1. #1 rikola, 13.01.2009
    Zuletzt bearbeitet: 13.01.2009
    rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    doppelt-NAT? - "geloest"

    Hallo,

    ich habe einen PC zuhause, der so weit vom DSL-router entfernt steht, dass mein laengstes Netzwerkkabel nicht reicht. Daher wuerde ich ihn gerne mit dem Laptop verbinden, dass dann als router agiert.
    Der DSL-router (der als gateway agiert) hat 192.168.2.1. Die WLAN-Schnittstelle des Laptops 192.168.2.3.
    Ich dachte das sei recht einfach mit folgenden Schritten:
    Code:
    Laptop:
    #> sysctl net.ipv4.conf.all.forwarding=1  
    #> ifconfig eth0 192.168.1.1 up            
    #> route add 192.168.1.4 eth0             
    PC:
    #> ifconfig eth1 192.168.1.4 up 
    #> route add default gw 192.168.1.1 eth1
    
    Damit sind Laptop und PC verbunden, doch kommt der PC ueber das Laptop nicht hinaus (traceroute bleibt am Laptop haengen.

    Was muss ich noch einstellen, damit der PC ueber das Laptop ueber den DSL-router ins Netzwerk kommt?

    Vielen Dank fuer die Hinweise.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Akendo

    Akendo 4k3nd0

    Dabei seit:
    05.02.2008
    Beiträge:
    396
    Zustimmungen:
    0
    Bin mir nicht sicher, aber mir faellt so schnell nur das hier ein. Ich such auch mal, hatte auch so ein Problem vor einer Weile.
     
  4. hehejo

    hehejo blöder Purist

    Dabei seit:
    12.10.2003
    Beiträge:
    1.280
    Zustimmungen:
    0
    Ort:
    Stein (Mittelfranken)
    Warum so kompliziert?

    Kauf dir doch einfach einen Switch und pack in dazwischen!
    Einfacher, billiger und du kannst dein Notebook auch einmal wegtragen!
     
  5. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    ... oder ein laengeres Kabel. Heute morgen hatte halt noch kein Laden offen und mich interessiert die Loesung des Problems auf Software-Basis. Ist es moeglich, dass unter Linux die Weiterleitung nicht per se funktioniert, sondern dass man immer zusaetzlich mit iptables arbeiten muss? Unter OpenBSD dachte ich, reicht es jenen kernel-parameter zum forwarding auf 1 zu setzen, weswegen mich das Verhalten unter Linux verdutzt.
     
  6. rygar

    rygar Routinier
    Moderator

    Dabei seit:
    15.07.2002
    Beiträge:
    332
    Zustimmungen:
    0
    Ort:
    Kaarst
    Nein, Du musst zum routen nicht mit IPTables arbeiten.

    Kontrollier mal mit "cat /proc/sys/net/ipv4/ip_forward" ob's IP Forwarding enabled ist.

    Bekommst Du 0 zurück ist es aus. Mit "echo 1 > /proc/sys/net/ipv4/ip_forward" schaltest Du es ein.

    Guckst Du hier : http://blog.sven-lindenthal.de/ip-forwarding-unter-linux-aktivieren/

    Gruss,
    Martin
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 saeckereier, 13.01.2009
    Zuletzt bearbeitet: 13.01.2009
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Das was du versuchst ist Routing und kein NAT. NAT geht nur über iptables. Routing setzt voraus, dass der Router ins Internet deinen Laptop als Gateway benutzt um deinen PC zu erreichen. Lies dir einfach mal das LARTC durch.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Ein Hinweis noch zum WLAN: Eine einfache Bridge funktioniert nicht, ebensowenig Proxy ARP. Dies wären bei einer Konstellation mit zwei LAN Ports die einfachste Lösung.
     
  9. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Fuer den Moment habe ich das Problem geloest, indem ich den PC die 2m, die noch gefehlt haben, naeher an die DSL-Box gestellt habe.
    Beim naechsten mal werde ich den Effekt von net.ipv4.ip_forward ausprobieren. 'sysctl net.ipv4.conf.eth0.forwarding=1' laesst diesen Wert in der Tat unbeeindruckt.

    Danke fuer Vorschlaege und Aufklaerung.
     
Thema:

doppelt-NAT?