debian 3.1 - php5 / mysql 5

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von moev, 08.09.2007.

  1. #1 moev, 08.09.2007
    Zuletzt bearbeitet: 08.09.2007
    moev

    moev Eroberer

    Dabei seit:
    02.03.2007
    Beiträge:
    63
    Zustimmungen:
    0
    Hi ich versuche gerade auf meinem debian php5 zu installieren

    bei php bekomme ich irgendwann mal die mitteilung:
    "Unable to find MySql header files...."

    also hab ich mich aufgemacht und versucht mysql vom source her zu compilen
    dabei kommt dann aber wohl:

    checking for termcap functions library... configure: error: No curses/termcap library found


    jmd. ne ahnung was die alles brauchen um installiert zu werden ?

    kann mir vieleicht jmd. ne nützliche anleitung geben wie ich php5 ans laufen bekomme ??? :)


    edit - mysql:
    apt-get install gpc-2.95 libaca-dev
    und danach kommt make :)

    soweit hats funktioniert dann wieder mal im php dir ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
    und danach make ...

    beim make lief eigetnlich alles ok
    dann beim make test:

    =====================================================================
    FAILED TEST SUMMARY
    ---------------------------------------------------------------------
    Bug #38474 (getAttribute select attribute by order, even when prefixed) (OK to fail with libxml2 < 2.6.2x) [ext/dom/tests/bug38474.phpt]
    Bug #42082 (NodeList length zero should be empty) [ext/dom/tests/bug42082.phpt]
    Bug #16069 (ICONV transliteration failure) [ext/iconv/tests/bug16069.phpt]
    iconv stream filter [ext/iconv/tests/iconv_stream_filter.phpt]
    Test lstat() and stat() functions: usage variations - effects of touch() on link [ext/standard/tests/file/lstat_stat_variation6.phpt]
    money_format test [ext/standard/tests/strings/moneyformat.phpt]
    =====================================================================

    ...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 08.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Kurze Frage: Warum schlägst Du Dich noch mit oldstable rum? In Etch ist PHP5 schon vorhanden ...
     
  4. #3 moev, 08.09.2007
    Zuletzt bearbeitet: 08.09.2007
    moev

    moev Eroberer

    Dabei seit:
    02.03.2007
    Beiträge:
    63
    Zustimmungen:
    0
    die etch war 4 ?? und ich hab 3.1 naja anders gehts in diesem falle nich :///
    sorry
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    gibsn da irgendne möglichkeit das neue mysql, den neuen apache unds php5 per apt-get zu ziehen ?
     
  5. #4 nequiquam, 08.09.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
  6. moev

    moev Eroberer

    Dabei seit:
    02.03.2007
    Beiträge:
    63
    Zustimmungen:
    0
    na danke aber ich glaub das is nix für mich :)
     
  7. #6 z-shell, 09.09.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Ja.
    Die sources.list editieren, und ein dist-upgrade machen.
     
  8. #7 DJ BlackEagle, 09.09.2007
    DJ BlackEagle

    DJ BlackEagle Grünschnabel

    Dabei seit:
    09.09.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Hi,
    diese Package nutze ich auch. Funktioniert auch ohne Probleme. :)
     
  9. moev

    moev Eroberer

    Dabei seit:
    02.03.2007
    Beiträge:
    63
    Zustimmungen:
    0
    so hab mich jetz auch mal mit dem howto beschäftigt
    (hab nix anderes gefunden)

    bei mir kommt allerdings dann das:

    # apt-get install php5 libapache2-mod-php5 php5-curl php5-gd
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
    Depends: libdb4.4 but it is not installable
    Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
    Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
    Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed
    php5-curl: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
    Depends: libcurl3 (>= 7.15.5-1) but 7.13.2-2sarge5 is to be installed
    Depends: libidn11 (>= 0.5.18) but 0.5.13-1.0 is to be installed
    Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
    Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
    php5-gd: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
    Depends: libfreetype6 (>= 2.2) but 2.1.7-8 is to be installed
    Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-1 is to be installed
    E: Broken packages

    jmd. ne idee was ich installen muss ?
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Sind das nicht Pakete aus etch? So rein von den Versionsnummern her...
     
  12. #10 moev, 09.09.2007
    Zuletzt bearbeitet: 09.09.2007
    moev

    moev Eroberer

    Dabei seit:
    02.03.2007
    Beiträge:
    63
    Zustimmungen:
    0
    so ich hab jetz irgendwas gemacht und denk php5 is nun auf meinem system :devil::headup:?(8):)):D:oldman:oldman:oldman:oldman
    sorry den post vor mir hab ich ers jetz gesehen
    hab debian 3.1

    Code:
    Not Found
    
    The requested URL /asdkfjsadf was not found on this server.
    Apache/2.2.4 (Debian) PHP/5.2.3-1+b1 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_perl/2.0.3 Perl/v5.8.8 Server at xxx Port xxx
     
Thema:

debian 3.1 - php5 / mysql 5

Die Seite wird geladen...

debian 3.1 - php5 / mysql 5 - Ähnliche Themen

  1. PHP5.x + 5.3 parallel? (Apache, Debian)

    PHP5.x + 5.3 parallel? (Apache, Debian): Hi, ich wollte zum Testen auf meinen Webserver PHP5.3 installieren, damit ich die Seiten nach und nach umziehen kann, brauche aber für einige...
  2. Apache2 mit PHP4 und PHP5 (Debian Etch)

    Apache2 mit PHP4 und PHP5 (Debian Etch): Hallo, ich suche nun schon seit einiger Zeit im Internet eine gute Anleitung wie ich unter Debian Etch mit Apache2 mit der PHP-Version 4 und 5...
  3. debian 3.1: php5.2.5 - php5-imap php5-cli php5-curl

    debian 3.1: php5.2.5 - php5-imap php5-cli php5-curl: hi, ich habe php5.2.5 installed über deb http://dotdeb.pimpmylinux.org/ stable all deb-src http://dotdeb.pimpmylinux.org/ stable all nun brauch...
  4. Debian, Apache & PHP5

    Debian, Apache & PHP5: Hallo Gemeinschaft, ich bin eigentlich nicht von der döseligen Sorte, komme aber seit Tagen, wahrscheinlich wegen schlafmangels/schlechtem...
  5. [S] php5(.2.3) sources für debian etch

    [S] php5(.2.3) sources für debian etch: Tag die Damen, ich suche php5 sources, vlt auch mit mysql und anderen features, für apt. Mein OS: Debian Etch. Gegoogelt habe ich, aber...