PHP 5.2.3 Update Problem!

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von Steppengewächs, 16.08.2007.

  1. #1 Steppengewächs, 16.08.2007
    Zuletzt bearbeitet: 16.08.2007
    Steppengewächs

    Steppengewächs Jungspund

    Dabei seit:
    12.08.2007
    Beiträge:
    24
    Zustimmungen:
    0
    Ort:
    .at
    Hallo Linuxer!

    Mein erster Post hier und dann gleich ein technisches Problem. :think:

    Und zwar wollte ich gerade mittels SSH bei meiner Fedora (7.0) Maschine das PHP von 5.2.2 auf 5.2.3 updaten, leider erfolglos.

    Nachdem ./configure mach ich ein make und bekomme jedesmal:
    Code:
    /root/dl/php-5.2.3/Zend/zend_compile.c -o Zend/zend_compile.lo
    /root/dl/php-5.2.3/Zend/zend_compile.c:3433:4: warning: no newline at end of file
    /root/dl/php-5.2.3/Zend/zend_compile.c: In function 'zend_do_list_end':
    /root/dl/php-5.2.3/Zend/zend_compile.c:3432: error: expected declaration or statement at end of input
    /root/dl/php-5.2.3/Zend/zend_compile.c:3432: error: expected declaration or statement at end of input
    /root/dl/php-5.2.3/Zend/zend_compile.c:3432: error: expected declaration or statement at end of input
    /root/dl/php-5.2.3/Zend/zend_compile.c:3432: error: expected declaration or statement at end of input
    make: *** [Zend/zend_compile.lo] Fehler 1
    ./configure:
    Code:
    ./configure --with-apxs2=/usr/sbin/apxs --with-mysql
    Die ganzen Pakete ala httpd-devel, mm-devel usw. sind installiert, Apache habe ich Apache/2.2.4.

    Also vielleicht kennt jemand von euch das Problem und kann mir damit weiter helfen.

    Danke!

    PS: Ich bin erst vor kurzem von Windows auf Linux umgestiegen, bitte nicht gleich Kernel kompilieren :headup: :P

    Nachtrag:
    Hab jetzt vorhin wieder Zeit gefunden mich dem Problem zu widmen.
    Ich habe die *.tar.gz noch einmal heruntergeladen und frisch entpackt, danach hat es auch mit dem kompilieren und installieren geklappt! :D

    Kann also als erledigt angesehen werden, vielleicht hilft der Thread ja trotzdem irgend jemanden.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

PHP 5.2.3 Update Problem!

Die Seite wird geladen...

PHP 5.2.3 Update Problem! - Ähnliche Themen

  1. Fedora mit Problem bei Paket-Updates

    Fedora mit Problem bei Paket-Updates: Die Paketverwaltung von Fedora 21 weist einige Fehler auf, die den Standardweg des Paket-Updates scheitern lassen können. Auf der Kommandozeile...
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. Probleme nach Update auf Suse 12.1

    Probleme nach Update auf Suse 12.1: Hallo Leute, Ich habe heute per Netzwerk-CD mein Sytem von 11.4 auf 12.1 upgegradet. Die Installtion ging ohne Fehlermeldungen von statten....
  4. xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus

    xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus: Hi also der Betreff sagt schon des meiste. Hab mein Gentoo-System seit längerer Zeit mal wieder aktualisiert, was 2 größere Änderungen mit sich...
  5. Pacman Updateproblem

    Pacman Updateproblem: Hi, bin noch Archanfänger und hab ein kleines Problem. Hab auch schon im Wiki gesucht, jedoch nichts passendes gefunden :/ sudo pacman -Syu...