Berechtigungen verändern aber nur von Ordnern

Dieses Thema im Forum "Anwendungen" wurde erstellt von BenjiX, 24.05.2005.

  1. BenjiX

    BenjiX Eroberer

    Dabei seit:
    13.04.2004
    Beiträge:
    55
    Zustimmungen:
    0
    Hi!
    Geht es, dass ich die Berechtigungen mit chmod verändere aber nur die Ordner und Unterordner sollten davon betroffen sein, nicht die Dateien in den Ordnern?
    Würde diesen Befehl benutzen
    Code:
    chmod -cR +x *
    Jedoch werden hier auch die Dateiberechtigungen verändert ich will aber nur die Berechtigungen der Ordner verändern.
    Kann auch ein kleines Script sein.

    MfG Stefan
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DaMutz, 24.05.2005
    Zuletzt bearbeitet: 24.05.2005
    DaMutz

    DaMutz Doppel-As

    Dabei seit:
    18.10.2003
    Beiträge:
    149
    Zustimmungen:
    0
    Ort:
    Giebenach / Schweiz
    Code:
    find ./ -type d -exec chmod 744 "{}"\;
    mit find sucht er nach d Directory Ordner und verändert oder ändert den chmod auf 744, dies kannst du ja auch anpassen. Pfad und so kannst du auch anpassen.
     
  4. BenjiX

    BenjiX Eroberer

    Dabei seit:
    13.04.2004
    Beiträge:
    55
    Zustimmungen:
    0
    Wenn ich den Befehl so angebe, dann kommt folgender Fehler:
    Code:
    find: Fehlendes Argument für "-exec".
    Werden bei deinem Befehl, wenn ich ihn z.b. unter /home/bla/test ausführe nur die Unterordner von /home/bla/test geändert oder was wird da alles geändert?
     
  5. Gronau

    Gronau Doppel-As

    Dabei seit:
    28.02.2004
    Beiträge:
    113
    Zustimmungen:
    0
    find . -type d -exec chmod 744 {} \;
     
  6. DaMutz

    DaMutz Doppel-As

    Dabei seit:
    18.10.2003
    Beiträge:
    149
    Zustimmungen:
    0
    Ort:
    Giebenach / Schweiz
    gib nur "find ./ -type d" ein und du siehst welche Ordner mit dem erweitertem Befehl geändert werden. Normalerweise ändert er vom aktuellen Verzeichnis (.) abwärts alles.

    Gronau: die Gansefüsse sind nötig sonst gibt es Fehler bei Ordner mit Leerschlag.

    so geht es bei mir (zsh):
    find ./ -type d -exec chmod 744 "{}" \;
     
  7. #6 SkydiverBS, 25.05.2005
    SkydiverBS

    SkydiverBS Tripel-As

    Dabei seit:
    15.01.2005
    Beiträge:
    207
    Zustimmungen:
    0
    Ort:
    Freising
    Hi Stefan!

    Wenn du ein Leerzeichen vor dem Backslash (\) einfügst sollte es gehen.

    Code:
    find ./ -type d -exec chmod 744 "{}" \;
    Gruss,
    Philip
     
  8. Gronau

    Gronau Doppel-As

    Dabei seit:
    28.02.2004
    Beiträge:
    113
    Zustimmungen:
    0
    Der slash nach dem punkt ist unnötig, genau wie die quotes um die geschweiften klammern. Exec gibt ja nur die ausgabe von find an ein anderes programm weiter (genau wie xargs), und da ändern quotes nichts. Ich hatte ohne jedenfalls nie probleme.
     
  9. #8 Havoc][, 25.05.2005
    Havoc][

    Havoc][ Debian && Gentoo'ler

    Dabei seit:
    27.07.2003
    Beiträge:
    898
    Zustimmungen:
    0
    Ort:
    GER/BaWü/Karlsruhe (bzw. GER/NRW/Siegen)
    Allerdings, damit du fürs nächstemal auch einzelne Ordner mit Rechten "versehen" kannst:

    Code:
    # chmod 755 /dein/Ordner
    
    Musst einfach das "-R" für "Rekursiv" weg lassen.

    Havoc][
     
  10. name

    name Inactive user

    Dabei seit:
    28.08.2004
    Beiträge:
    592
    Zustimmungen:
    0
    Ort:
    Wien->127.0.0.1
    nein!
    Das wird nur die permissions des ordners, aber nicht der Unterordner :oldman
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 Havoc][, 25.05.2005
    Havoc][

    Havoc][ Debian && Gentoo'ler

    Dabei seit:
    27.07.2003
    Beiträge:
    898
    Zustimmungen:
    0
    Ort:
    GER/BaWü/Karlsruhe (bzw. GER/NRW/Siegen)
    Genau. Und so hab ich das auch beschrieben.

    Einen einzigen Ordner, ohne die Dateien und Ordner darunter anzupacken/anzupassen, geht ohne irgendeinen Parameter. bzw. der Parameter "-R" muss definitv weg bleiben.

    Havoc][
     
  13. #11 Wolfgang, 25.05.2005
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    bei exotischen Dateinamen ist es allemal besser folgende pipe zu verwenden:
    find /sorcepath/ -type d -print0| xargs -0n1 chmod 755
    Das stellt sicher, dass selbst bei Zeilenumbrüchen im Ordnernamen jedes einzelne Argument an \0 getrennt wird.
    So werden auch unmögliche vorkommende Namen richtig an das command hinter xargs weitergereicht.
    Auch bei sehr langen Listen wird hier der Fehler:
    argument line too long vermieden.

    Gruß Wolfgang
     
Thema:

Berechtigungen verändern aber nur von Ordnern

Die Seite wird geladen...

Berechtigungen verändern aber nur von Ordnern - Ähnliche Themen

  1. youtube-dl mit WebUI einrichten - Download-Ordner ändern + Berechtigungen

    youtube-dl mit WebUI einrichten - Download-Ordner ändern + Berechtigungen: Hallo, auf meinem Raspberry Pi habe ich youtube-dl (manuelle Installation; systemweit [wie im UU-Wiki beschrieben]) installiert. Dazu...
  2. Samba und Ordnerberechtigungen für windows

    Samba und Ordnerberechtigungen für windows: Hallo ich hab ein kleines problem das ich nicht gelöst bekomme , ich bin mir auch nicht sicher ob das überhaupt mit samba geht also folgendes...
  3. HILFE!!! Gruppen-Ordner-Berechtigungen-Problem

    HILFE!!! Gruppen-Ordner-Berechtigungen-Problem: Hallo zusammen, auf meiner Arbeit muss ich ein Linux-Server mit PDC einrichten. Soweit so gut, dann habe ich Gruppen erstellt mit...
  4. Freenas 8 Benutzer Berechtigungen

    Freenas 8 Benutzer Berechtigungen: Hallo, Ich hab auf meinem FreeNas mehrere Verzeichnisse, wie z.b. /mnt/Daten/Audio /mnt/Daten/Bilder Usw, und die Verzeichnisse haben die...
  5. Berechtigungen

    Berechtigungen: Hallo zusammen, ich habe mich entschieden verstärkt Linux zu lernen und bin momentan bei Samba angekommen und habe schon das erste Problem. Ich...