ATI Control und single head

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von mfries7996, 19.12.2006.

  1. #1 mfries7996, 19.12.2006
    mfries7996

    mfries7996 Mitglied

    Dabei seit:
    28.09.2006
    Beiträge:
    31
    Zustimmungen:
    0
    hallo,

    ich hab eine ati radeon 9550 und den ati-treiber 8.31.05. nach dem installieren des treibers habe ich aticonfig --initial aufgerufen. treiber ist jetzt auch installiert und funktioniert. nur steht im ati control panel, dass der clone mode ausgeführt wird, sprich dass zwei monitore angesteuert werden. ich habe allerdings nur einen monitor. wenn ich auf single mode umstelle, kommt die meldung, dass die änderungen übernommen werden und der x-server neu gestartet werden muss. wenn ich dann neu starte bzw. den x-server neu starte, steht die einstellung wieder auf clone mode.
    was kann ich tun, damit der single mode aktiviert wird?

    hier meine xorg.conf

    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "i2c"
    	Load  "bitmap"
    	Load  "ddc"
    	Load  "extmod"
    	Load  "freetype"
    	Load  "glx"
    	Load  "int10"
    	Load  "type1"
    	Load  "vbe"
    	Load  "fglrx"
    	Load  "dri"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AIGLX" "off"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de"
    	Option	    "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Radeon"
    	Driver      "fglrx"
    	Option	    "BusType" "AGP"
    	Option	    "RenderAccel" "on"
    	Option	    "AGPMode" "4"
    	Option	    "AGPFastWrite" "yes"
    	Option	    "VideoOverlay" "on"
    	Option	    "DesktopSetup" "single"
    EndSection
    
    Section "Screen"
    
    #	Monitor    "aticonfig-Monitor[0]"
    	Identifier "Screen0"
    	Device     "ATI Radeon"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Disable"
    EndSection
    
    kann mir jemand helfen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 hoernchen, 19.12.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    mach mal folgendes als root :

    zuerst das livna-repo einbinden via rpm -Uvh http://rpm.livna.org/livna-release-6.rpm

    yum -y remove kmod-fglrx* xorg-x11-drv-fglrx*
    (haut alles runter)

    yum -y install kmod-fglrx* xorg-x11-drv-fglrx*
    (pappts richtig rauf)

    dann noch das mit aticonfig und fertig; sitz hier vor einem rechner mit einer 9550er und da laeufts prima.

    oder hast du es ohnehin so gemacht ?
     
  4. #3 mfries7996, 19.12.2006
    Zuletzt bearbeitet: 19.12.2006
    mfries7996

    mfries7996 Mitglied

    Dabei seit:
    28.09.2006
    Beiträge:
    31
    Zustimmungen:
    0
    wie gesagt. treiber funzt prima. hab auch opengl-unterstützung. nur steht im ati control panel bei mir immer dual mode anstatt single mode. ich hab nur einen monitor und denke, dass die momentane einstellung zu einer leistungsminderung führt.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    problem behoben (denke ich ;-) )

    habe als root den befehl:

    aticonfig --desktop-setup=single


    eingegeben. nun steht da single mode im desktop-setup so wie es sich gehört.
     
  5. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Hi und frohe Weihnachten zusammen.

    @hoernchen: habe alle deine Tipps versucht, aber ohne Erfolg.
    Neusten ati treiber runterladen und versucht mit sh ./ati.... zu installieren / null erfolg.

    livna eingebunden und mit yum fglrx.... versucht, wie oben angegeben / null erfolg.

    habe immer noch die blöden mesa treiber drauf und immer noch keine 3D unterstüzung

    Kann jemand helfen???? Hier meine PC Daten
    -----
    AMD 3000+ 64 , FC6x64, ati 9800 pro

    Gruß - mali
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

ATI Control und single head

Die Seite wird geladen...

ATI Control und single head - Ähnliche Themen

  1. Artikel: Review: Steam Controller

    Artikel: Review: Steam Controller: Mit dem Steam Controller möchte Valve seine Steamboxen mit Steam OS wohnzimmertauglich machen. Ob die außergewöhnlichen Bedienkonzepte auch unter...
  2. Espruino Pico: Schrumpfkur für den Javascript-Microcontroller

    Espruino Pico: Schrumpfkur für den Javascript-Microcontroller: Die Entwickler des mit Javascript programmierbaren Microcontrollers Espruino haben eine neue Kickstarter-Kampagne ins Leben gerufen, mit der sie...
  3. Nochmaliges Update des Valve Steam Controllers

    Nochmaliges Update des Valve Steam Controllers: Valve hat den Prototypen seines Game-Controllers noch einmal überarbeitet, allerdings gegenüber der im Januar präsentierten Version nur noch...
  4. Samba 4 Domain Controller NSLOOKUP für DomainName

    Samba 4 Domain Controller NSLOOKUP für DomainName: Hallo Leute, wir haben hier eine AD Umgebung mit 4 Standorten laufen. Am Standort 1 steht ein Windows 2008 SBS Server. An Standort 2-4 haben...
  5. RAID 1 Controller gesucht

    RAID 1 Controller gesucht: Hallo, ich suche einen RAID1-Controller, der unter Linux Problemlos funktioniert. Er sollte 2 SATA II (3GB/S)-Anschlüsse haben. Kann hier...