apt-get Fehler

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Chris92, 28.02.2005.

  1. #1 Chris92, 28.02.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Hallo
    Ich habe auf einem installierten Knoppix 3.3 apt-get install mono aus um Mono zu installieren. Dabei kam die Fehlermeldung:

    root@Christoph:/# apt-get install mono
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich ,,apt-get -f install" aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    freeglut3: Hängt ab: libc6 (>= 2.3.2.ds1-4) aber 2.3.2-7 soll installiert werden
    libncurses5-dev: Hängt ab: libncurses5 (= 5.4-4) aber 5.3.20030719-1 soll installiert werden
    mono: Hängt ab: mono-jit (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-utils (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-mcs soll aber nicht installiert werden
    Hängt ab: mono-assemblies-arch soll aber nicht installiert werden
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie ,,apt-get -f install" ohne jeglich Pakete (oder geben Sie eine Lösung an).
    root@Christoph:/#

    Dann hab ich apt-get -f install aufgerufen. Dabei kommt aber diese Fehlermeldung:

    root@Christoph:/# apt-get -f install
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Abhängigkeit werden korrigiert... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    gcc-3.3-base hicolor-icon-theme kdelibs-bin kdelibs-data kdelibs4
    kdepim-kio-plugins ktnef libart-2.0-2 libart-2.0-dev libarts1 libarts1-dev
    libartsc0 libartsc0-dev libasound2 libasound2-dev libaspell15 libc6
    libc6-dev libcupsys2 libcupsys2-gnutls10 libesd0 libesd0-dev libgcc1
    libgcrypt11 libglib2.0-0 libglib2.0-data libglib2.0-dev libgnutls11
    libgpg-error-dev libgpg-error0 libgpgme11 libice-dev libice6 libidn11
    libjack0.80.0-0 libjack0.80.0-dev libjasper-1.701-1 libkdenetwork2
    libkleopatra0a libksieve0 libmad0 libmad0-dev libmal1 libncurses5 libogg-dev
    libogg0 libopencdk8 libopenexr2 libpcre3 libpcre3-dev libpng12-0
    libpng12-dev libqt3-compat-headers libqt3-headers libqt3-mt-dev
    libqt3c102-mt libsm-dev libsm6 libstdc++5 libtasn1-2 libtiff4 libusb-0.1-4
    libusb-dev libvorbis-dev libvorbis0a libvorbisenc2 libvorbisfile3 libwine
    libwine-print libwine-twain libx11-6 libx11-dev libxcursor-dev libxcursor1
    libxext-dev libxext6 libxi-dev libxi6 libxml2 libxmu-dev libxmu6 libxmuu-dev
    libxmuu1 libxp-dev libxp6 libxpm-dev libxpm4 libxrandr-dev libxrandr2
    libxslt1 libxslt1.1 libxt-dev libxt6 libxtrap-dev libxtrap6 libxtst-dev
    libxtst6 libxv-dev libxv1 linux-kernel-headers locales menu menu-xdg pm-dev
    qt3-dev-tools wine wine-utils x-dev xlibs-dev xlibs-static-dev zlib1g
    zlib1g-dev
    Befürwortete Pakete:
    alsa-base libasound2-doc libglib2.0-doc gnutls-bin libjasper-runtime qt3-doc
    libqt3-mt-mysql libqt3-mt-odbc libqt3c102-mt-mysql wine-doc binfmt-support
    msttcorefonts
    Empfohlene Pakete:
    perl-suid akode esound-clients xml-core libqt3-dev
    Die folgenden Pakete werden ENTFERNT:
    kdelibs4-dev kdepim libcupsys2-dev
    Die folgenden NEUEN Pakete werden installiert:
    hicolor-icon-theme kdepim-kio-plugins ktnef libcupsys2-gnutls10 libesd0-dev
    libgcrypt11 libgnutls11 libgpg-error-dev libgpg-error0 libgpgme11 libice-dev
    libice6 libidn11 libjack0.80.0-0 libjack0.80.0-dev libjasper-1.701-1
    libkleopatra0a libksieve0 libmal1 libopencdk8 libopenexr2 libsm-dev libsm6
    libtasn1-2 libtiff4 libx11-6 libx11-dev libxcursor-dev libxcursor1
    libxext-dev libxext6 libxi-dev libxi6 libxmu-dev libxmu6 libxmuu-dev
    libxmuu1 libxp-dev libxp6 libxpm-dev libxpm4 libxrandr-dev libxrandr2
    libxslt1.1 libxt-dev libxt6 libxtrap-dev libxtrap6 libxtst-dev libxtst6
    libxv-dev libxv1 linux-kernel-headers menu-xdg pm-dev x-dev xlibs-static-dev
    Die folgenden Pakete werden aktualisiert
    gcc-3.3-base kdelibs-bin kdelibs-data kdelibs4 libart-2.0-2 libart-2.0-dev
    libarts1 libarts1-dev libartsc0 libartsc0-dev libasound2 libasound2-dev
    libaspell15 libc6 libc6-dev libcupsys2 libesd0 libgcc1 libglib2.0-0
    libglib2.0-data libglib2.0-dev libkdenetwork2 libmad0 libmad0-dev
    libncurses5 libogg-dev libogg0 libpcre3 libpcre3-dev libpng12-0 libpng12-dev
    libqt3-compat-headers libqt3-headers libqt3-mt-dev libqt3c102-mt libstdc++5
    libusb-0.1-4 libusb-dev libvorbis-dev libvorbis0a libvorbisenc2
    libvorbisfile3 libwine libwine-print libwine-twain libxml2 libxslt1 locales
    menu qt3-dev-tools wine wine-utils xlibs-dev zlib1g zlib1g-dev
    55 aktualisiert, 57 neu installiert, 3 zu entfernen und 772 nicht aktualisiert.
    135 nicht vollständig installiert oder entfernt.
    Es müssen noch 0B/69,6MB der Archive geholt werden.
    Nach dem Auspacken werden 51,9MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] J
    Preconfiguring packages ...
    (Lese Datenbank ... 114698 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke libx11-6 (aus .../libx11-6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libxext6 (aus .../libxext6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libXext.so.6.4« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libice6 (aus .../libice6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libICE.so.6.3« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Was mache ich falsch?

    Gruß

    Christoph
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. oldkid

    oldkid Jungspund

    Dabei seit:
    24.11.2004
    Beiträge:
    24
    Zustimmungen:
    0
    versuchs mal mit apt-get -f install mono
     
  4. #3 Chris92, 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Geht auch nicht:

    root@Christoph:/# apt-get -f install mono
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich ,,apt-get -f install" aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    freeglut3: Hängt ab: libc6 (>= 2.3.2.ds1-4) aber 2.3.2-7 soll installiert werden
    libncurses5-dev: Hängt ab: libncurses5 (= 5.4-4) aber 5.3.20030719-1 soll installiert werden
    mono: Hängt ab: mono-jit (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-utils (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-mcs soll aber nicht installiert werden
    Hängt ab: mono-assemblies-arch soll aber nicht installiert werden
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie ,,apt-get -f install" ohne jeglich Pakete (oder geben Sie eine Lösung an).
     
  5. #4 monarch, 01.03.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Sag uns mal was du in der /etc/apt/sources.list, der /etc/apt/apt.conf und der /etc/apt/preferences stehen hast? Kann sein dasses die preferences nicht gibt.
     
  6. #5 Chris92, 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    apt.conf:

    APT::Default-Release "testing";
    APT::Cache-Limit 10000000;
    Apt::Get::Purge;

    sources.list:

    # See sources.list(5) for more information, especialy
    # Remember that you can only use http, ftp or file URIs
    # CDROMs are managed through the apt-cdrom tool.

    # Security updates for "stable"
    deb http://security.debian.org stable/updates main contrib non-free
    deb http://security.debian.org testing/updates main contrib non-free

    # Stable
    deb http://ftp2.de.debian.org/pub/debian stable main contrib non-free
    deb http://ftp2.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free

    # Sources
    deb-src http://ftp2.de.debian.org/pub/debian stable main contrib non-free
    deb-src http://ftp2.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free

    # Testing
    deb http://ftp2.de.debian.org/pub/debian testing main contrib non-free
    deb http://ftp2.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

    # Sources
    deb-src http://ftp2.de.debian.org/pub/debian testing main contrib non-free
    deb-src http://ftp2.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

    # Unstable
    deb http://ftp2.de.debian.org/debian unstable main contrib non-free
    deb http://ftp2.de.debian.org/debian-non-US unstable/non-US main contrib non-free

    # Sources
    deb-src http://ftp2.de.debian.org/debian unstable main contrib non-free
    deb-src http://ftp2.de.debian.org/debian-non-US unstable/non-US main contrib non-free

    # Experimental
    # deb http://debian.uni-essen.de/debian ../project/experimental main contrib non-free
    # deb-src http://debian.uni-essen.de/debian ../project/experimental main contrib non-free

    # Mozilla
    deb http://non-us.debian.org/~kitame/mozilla ./
    deb-src http://non-us.debian.org/~kitame/mozilla ./

    # GNOME 2.0
    # deb http://www.gnome.de/debian/ ./

    # KDE 3
    # deb http://ktown.kde.org/~nolden/kde stable main
    # deb-src http://ktown.kde.org/~nolden/kde stable main
    # We get packages from testing/unstable for now

    # cdbakeoven
    # deb http://coyote.asoc.euitt.upm.es/mud/debian/ ./

    # XFree 4.2/4.3
    deb http://people.debian.org/~branden/packages sid/i386/
    deb-src http://people.debian.org/~branden/packages sid/source/
    deb http://www.penguinppc.org/~daniels/sid/i386 ./
    deb-src http://www.penguinppc.org/~daniels/sid/source ./

    # Java
    deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
    deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
    deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free
    deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free
    # deb http://people.debian.org/~sgybas/jdk13

    # LyX & others (now in debian/unstable)
    # deb ftp://ntama.uni-mainz.de/pub/debian unofficial/
    # deb-src ftp://ntama.uni-mainz.de/pub/debian unofficial/

    # Evolution
    #deb ftp://ftp.ximian.com/pub/debian stable main
    #deb-src ftp://ftp.ximian.com/pub/debian stable main

    # Blades Repository (pppoeconf & co)
    deb http://people.debian.org/~blade/testing ./
    deb-src http://people.debian.org/~blade/testing ./

    # Wine CVS snapshot
    # deb http://people.debian.org/~andreas/debian wine main
    # deb-src http://people.debian.org/~andreas/debian wine main

    # deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427)]/ unstable contrib main non-US/contrib non-US/main

    #DVDs unter Linux
    deb http://www.rarewares.org/debian/packages/unstable ./
    deb http://ftp.de.debian.org/debian/ stable main
    deb-src http://ftp.de.debian.org/debian/ stable main



    preferences ist nicht da.
     
  7. tig

    tig Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    229
    Zustimmungen:
    0
    oha... ich glaube nicht, dass es deinem system so gut tut, woody, sarge und sid zu mixen :>
     
  8. #7 Chris92, 01.03.2005
    Zuletzt bearbeitet: 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Das war Standart. Bis auf die DVDs hab ich nichts geändert.

    Kann es daran liegen, dass es nicht geht?
     
  9. #8 monarch, 01.03.2005
    Zuletzt bearbeitet: 01.03.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Ahja, dein Knoppix verwendet Debian testing (steht in der apt.conf).
    Mono gibts aber nur in unstable (siehst du hier: http://www.debian.org/distrib/packages#search_packages).

    Du hast jetzt die Möglichkeit mono vom unstable zu installieren und dazu braucht er auch ein paar Abhängigkeiten aus unstable. Probier mal: "apt-get install mono -t unstable", dann löst er die Abhängigkeiten aus dem unstable-Zweig auf.
    Das ist hier beschrieben.

    PS: wenns nicht klappen sollte müssen wir evtl. noch eine preferences erstellen, aber probiers erstmal.
     
  10. #9 Chris92, 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Funktioniert nicht. Kommt wieder die selbe Fehlermeldung:

    root@Christoph:/# apt-get install mono -t unstable
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich ,,apt-get -f install" aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    freeglut3: Hängt ab: libc6 (>= 2.3.2.ds1-4) aber 2.3.2-7 soll installiert werden
    libncurses5-dev: Hängt ab: libncurses5 (= 5.4-4) aber 5.3.20030719-1 soll installiert werden
    mono: Hängt ab: mono-jit (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-utils (= 1.0.5-2) soll aber nicht installiert werden
    Hängt ab: mono-mcs soll aber nicht installiert werden
    Hängt ab: mono-assemblies-arch soll aber nicht installiert werden
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie ,,apt-get -f install" ohne jeglich Pakete (oder geben Sie eine Lösung an).
    root@Christoph:/#
     
  11. #10 monarch, 01.03.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Dann erstell dir eine /etc/apt/preferences mit folgendem Inhalt
    __________________________
    Package: *
    Pin: release a=testing
    Pin-Priority: 500

    Package: *
    Pin: release a=unstable
    Pin-Priority: 50
    _________________________


    Damit geht bei mir sogar ein apt-get install mono
     
  12. #11 Chris92, 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Nein, geht immer noch nicht. Wieder die selbe Fehlermeldung.
    Mir wird immer vorgeschlagen ein apt-get install -f zu machen. Dabei kommt aber die Fehlermeldung:

    root@Christoph:/# apt-get -f install
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Abhängigkeit werden korrigiert... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    gcc-3.3-base hicolor-icon-theme kdelibs-bin kdelibs-data kdelibs4
    kdepim-kio-plugins ktnef libart-2.0-2 libart-2.0-dev libarts1 libarts1-dev
    libartsc0 libartsc0-dev libasound2 libasound2-dev libaspell15 libc6
    libc6-dev libcupsys2 libcupsys2-gnutls10 libesd0 libesd0-dev libgcc1
    libgcrypt11 libglib2.0-0 libglib2.0-data libglib2.0-dev libgnutls11
    libgpg-error-dev libgpg-error0 libgpgme11 libice-dev libice6 libidn11
    libjack0.80.0-0 libjack0.80.0-dev libjasper-1.701-1 libkdenetwork2
    libkleopatra0a libksieve0 libmad0 libmad0-dev libmal1 libncurses5 libogg-dev
    libogg0 libopencdk8 libopenexr2 libpcre3 libpcre3-dev libpng12-0
    libpng12-dev libqt3-compat-headers libqt3-headers libqt3-mt-dev
    libqt3c102-mt libsm-dev libsm6 libstdc++5 libtasn1-2 libtiff4 libusb-0.1-4
    libusb-dev libvorbis-dev libvorbis0a libvorbisenc2 libvorbisfile3 libwine
    libwine-print libwine-twain libx11-6 libx11-dev libxcursor-dev libxcursor1
    libxext-dev libxext6 libxi-dev libxi6 libxml2 libxmu-dev libxmu6 libxmuu-dev
    libxmuu1 libxp-dev libxp6 libxpm-dev libxpm4 libxrandr-dev libxrandr2
    libxslt1 libxslt1.1 libxt-dev libxt6 libxtrap-dev libxtrap6 libxtst-dev
    libxtst6 libxv-dev libxv1 linux-kernel-headers locales menu menu-xdg pm-dev
    qt3-dev-tools wine wine-utils x-dev xlibs-dev xlibs-static-dev zlib1g
    zlib1g-dev
    Befürwortete Pakete:
    alsa-base libasound2-doc libglib2.0-doc gnutls-bin libjasper-runtime qt3-doc
    libqt3-mt-mysql libqt3-mt-odbc libqt3c102-mt-mysql wine-doc binfmt-support
    msttcorefonts
    Empfohlene Pakete:
    perl-suid akode esound-clients xml-core libqt3-dev
    Die folgenden Pakete werden ENTFERNT:
    kdelibs4-dev kdepim libcupsys2-dev
    Die folgenden NEUEN Pakete werden installiert:
    hicolor-icon-theme kdepim-kio-plugins ktnef libcupsys2-gnutls10 libesd0-dev
    libgcrypt11 libgnutls11 libgpg-error-dev libgpg-error0 libgpgme11 libice-dev
    libice6 libidn11 libjack0.80.0-0 libjack0.80.0-dev libjasper-1.701-1
    libkleopatra0a libksieve0 libmal1 libopencdk8 libopenexr2 libsm-dev libsm6
    libtasn1-2 libtiff4 libx11-6 libx11-dev libxcursor-dev libxcursor1
    libxext-dev libxext6 libxi-dev libxi6 libxmu-dev libxmu6 libxmuu-dev
    libxmuu1 libxp-dev libxp6 libxpm-dev libxpm4 libxrandr-dev libxrandr2
    libxslt1.1 libxt-dev libxt6 libxtrap-dev libxtrap6 libxtst-dev libxtst6
    libxv-dev libxv1 linux-kernel-headers menu-xdg pm-dev x-dev xlibs-static-dev
    Die folgenden Pakete werden aktualisiert
    gcc-3.3-base kdelibs-bin kdelibs-data kdelibs4 libart-2.0-2 libart-2.0-dev
    libarts1 libarts1-dev libartsc0 libartsc0-dev libasound2 libasound2-dev
    libaspell15 libc6 libc6-dev libcupsys2 libesd0 libgcc1 libglib2.0-0
    libglib2.0-data libglib2.0-dev libkdenetwork2 libmad0 libmad0-dev
    libncurses5 libogg-dev libogg0 libpcre3 libpcre3-dev libpng12-0 libpng12-dev
    libqt3-compat-headers libqt3-headers libqt3-mt-dev libqt3c102-mt libstdc++5
    libusb-0.1-4 libusb-dev libvorbis-dev libvorbis0a libvorbisenc2
    libvorbisfile3 libwine libwine-print libwine-twain libxml2 libxslt1 locales
    menu qt3-dev-tools wine wine-utils xlibs-dev zlib1g zlib1g-dev
    55 aktualisiert, 57 neu installiert, 3 zu entfernen und 762 nicht aktualisiert.
    135 nicht vollständig installiert oder entfernt.
    Es müssen noch 0B/69,6MB der Archive geholt werden.
    Nach dem Auspacken werden 51,9MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] J
    Preconfiguring packages ...
    (Lese Datenbank ... 114698 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke libx11-6 (aus .../libx11-6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libxext6 (aus .../libxext6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libXext.so.6.4« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libice6 (aus .../libice6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libICE.so.6.3« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@Christoph:/#
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 monarch, 01.03.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Das Gemisch aus Sarge und Sid is jetzt nicht so tragisch. Das geht normalerweise schon.


    Hier beißen sich nur 3 Pakete (XFree 4.2/4.3 , libxext6 und libice6) mit den xlibs.
    Du hast nur diese XFree 4.2/4.3 - Geschichte in der sources.list. Knoppix 3.3 ist ja schon etwas betagter, mittlerweile ist aber XFree4.3 in testing angelangt. Es gibts eigentlich keinen Grund extra ne apt-source für XFree zu haben.

    Kommentier das mal aus, schau dass du mit
    apt-get -f install und apt-get upgrade einen Zustand herstellen kannst, dass er nicht mehr motzt.
    Dann installier die xlibs, wenn sie noch nicht da sind und probiers dann nochmal. Hier: http://packages.debian.org/unstable/libs/libgdiplus siehst du dass der ganze Mono-Kram entweder xlibs oder libx11-6 braucht. Hoffen wir mal dass er sich mit xlibs zufrieden gibt.
     
  15. #13 Chris92, 01.03.2005
    Chris92

    Chris92 Jungspund

    Dabei seit:
    27.02.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Harz
    Bei apt-get upgrade kommt die selbe Fehlermeldung, wie bei apt-get -f install:

    Entpacke libx11-6 (aus .../libx11-6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libxext6 (aus .../libxext6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libXext.so.6.4« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Entpacke libice6 (aus .../libice6_4.3.0.dfsg.1-10_i386.deb) ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb (--unpack):
    versuche »/usr/X11R6/lib/libICE.so.6.3« zu überschreiben, welches auch in Paket xlibs ist
    dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochen (broken pipe))
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-10_i386.deb
    /var/cache/apt/archives/libice6_4.3.0.dfsg.1-10_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
Thema:

apt-get Fehler

Die Seite wird geladen...

apt-get Fehler - Ähnliche Themen

  1. Fehler in den Abhängigkeiten apt-get

    Fehler in den Abhängigkeiten apt-get: Hallo zusammen, da ich mit Yast (Suse9.2) irgendwie nicht zurecht komme, habe ich mir apt auf meine Maschine installiert. Aber irgendwie gibts...
  2. Apt-Get und MySQL Fehler

    Apt-Get und MySQL Fehler: Hiho erstmal, ich erhalte immer wenn ich das Programm starten möchte unter Debian Sarge einen Fehler: error while loading shared libraries:...
  3. apt-get Speicherzugriffsfehler

    apt-get Speicherzugriffsfehler: Hallo, habe ein Debian System neu augesetzt und habe anschließend mit apt-get install ssh den SSH-Server installiert. Nun wollte ich weitere...
  4. apt-get fehler über fehler!

    apt-get fehler über fehler!: Hi.. Nachdem ich nun fast 2 stunden gegooglet habe bin ich mit den nerven so ziehmlich am ende. Mit meinem letzten google versuch habe ich...
  5. APT-Get bringt fehler

    APT-Get bringt fehler: Hallo wie ich in dem Thread...zum glück beantwortet bekommen habe muss ich apt-get verwenden um meinen Nvidia Treiber zu installieren hab auch...