apache2 ssl https geht nicht

Dieses Thema im Forum "Gentoo" wurde erstellt von CoolTux, 29.01.2004.

  1. #1 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo Leute


    Habe Gentoo als System!!!
    Ich habe den Apache2 mit ssl und wollte nun Zugriff über das https Protokoll bekommen. Also http geht.

    ssl-error-log sagt mir

    [Thu Jan 29 10:01:41 2004] [error] [client 192.168.1.200] client denied by server configuration: /var/www/localhost/htdocs


    Muß ich noch irgendetwas in meine /etc/apache2/conf/commonapache2.conf Datei eintragen?
    Soweit geht ja ssl und https. Den er fragt schon brav das Zertifikat ab und so, im Browser steht dann aber.

    You don't have permission to access /squirrelmail/src/login.php on this server.

    Apache/2.0.48 (Gentoo/Linux) mod_ssl/2.0.48 OpenSSL/0.9.6k PHP/4.3.4 Server at server.leon.local Port 443




    Danke für eure Hilfe

    Leon
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 29.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  4. #3 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Danke. Ich werde mir das ganze mal anschauen und dann schreiben ob ich was gefunden habe.




    Leon
     
  5. #4 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    So habe mal ein paar Sachen getestet, also mein https und ssl funktionieren. Ich muß den Apache nur noch beibringen, das er die Inhalte der Ordner unterhalb von htdocs über das https protokoll anzeigen darf. Also alle index files und so.

    Aber wie???


    Danke Leon
     
  6. #5 damager, 29.01.2004
    Zuletzt bearbeitet: 29.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    evtl hilft so ne einstellung für das documentroot:

    <Directory /var/www/localhost/htdocs>
    Options Indexes FollowSymLinks Includes
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 155.198.84.123 <---- deine IP ... zum TEST
    </Directory>


    ach ja, wie sieht den deine "Listen" option für SSL aus?

    imho sollte sie so aussehen:
    <IfDefine SSL>
    Listen 80
    Listen 443
    </IfDefine>
     
  7. #6 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    http funktioniert ja ohne Probleme, läuft ja auch schon ne Zeit lang. Alles was ich jetzt versuche ist die selben html files über das https aufzurufen.



    Leon
     
  8. #7 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Also meine Listen sehen so aus

    ###
    ### IP Address/Port
    ###
    #BindAddress *
    Listen 80

    ###
    ### Log configuration Section



    Listen 443 kann ich nicht schreiben, weil er das mod_ssl Modul mit hilfe des Startscriptes läd und somit ist dann der Socket blockiert.
     
  9. #8 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Ok. Vieleln Dank an alle. Hat sich erledigt. Habe das Problem gefunden, lag an der configuration. Jetzt geht es.



    Leon
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 damager, 29.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    kein problem ...
    wäre sicher aber noch interessant was es den genau war :]
     
  12. #10 CoolTux, 29.01.2004
    CoolTux

    CoolTux Grünschnabel

    Dabei seit:
    27.01.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Ich habe ein extra Verzeichnis fuer die html/php-dokumente anlegen müssen

    zB /wwwroot/secure-443/htdocs

    Das habe ich dann als directory in die /etc/apache2/con/modules.d/41_mod_ssl.default-vhost.conf eingetragen:

    Code:
    
    <VirtualHost _default_:443> 
     
     #  General setup for the virtual host 
     
     DocumentRoot "/wwwroot/secure-443/htdocs" 
     #ServerName localhost:443 
     #ServerAdmin root@localhost 
     ErrorLog logs/ssl_error_log 
     
    
    Ausserdem mußte ich noch folgenes in die commonapache2.conf eintragen:


    Code:
    
    
    <Directory /wwwroot/secure-443/htdocs> 
         AllowOverride All 
         Options -Indexes FollowSymLinks MultiViews 
         <IfModule mod_access.c> 
           Order allow,deny 
           Allow from all 
         </IfModule> 
     </Directory> 
     
    

    Fertig das war es dann. Alles was ich als https haben möchte verschiebe ich einfach in den neuen Ordner /wwwroot/secure-443/htdocs



    Klappt super



    Gruß Leon
     
Thema:

apache2 ssl https geht nicht

Die Seite wird geladen...

apache2 ssl https geht nicht - Ähnliche Themen

  1. Apache2 stuerzt ab wegen https

    Apache2 stuerzt ab wegen https: ich habe ein folgendes problem: der apache2 stuertzt nach einer weile ab, es passiert in einem tag oder in eine woche, aber der stuertzt ab....
  2. Apache2 (https) + WebDAV keine Write-Rechte

    Apache2 (https) + WebDAV keine Write-Rechte: Hi Folks! Hab ein Problem mit WebDAV. Kann in ein bestimmtes Directory zwar lesen aber nicht schreiben. Bekomme immer die Fehlermeldung:...
  3. Apache2 mod_proxy

    Apache2 mod_proxy: Hallo Gemeinde, ich raff es einfach nicht. Ich habe mir den Apache2-Server als Proxy eingerichtet, damit ich mir hinter meiner Firewall über...
  4. Newbie:apache2/befehl htdigest Problem

    Newbie:apache2/befehl htdigest Problem: Hallo Leute, ich habe ein Problem mit diesem Befehl: htdigest -c /etc/apache2/passwords xxxxx xxxxx xxxx= usernamen sollen eingefügt werden...
  5. apache2: Virtualhost ohne subdomain

    apache2: Virtualhost ohne subdomain: Hi, ich möchte bei apache einen virtualhost für fqdn.de/testname einrichten. Folgendes habe ich (unter Anderem) in der entsprechenden Datei im...